Results 1 to 3 of 3

Thread: [SOLVED] Problems importing mail

  1. #1
    Join Date
    Sep 2008
    Northern Virginia
    Rep Power

    Default [SOLVED] Problems importing mail

    Hi all,

    I've searched around, and I'm not finding anything specific related to my problem. Hopefully someone might have some insight as to what's going on here. It's obvious that it's a permissions issue of wherever it's trying to write the temp files, but I can't figure out where this is happening.

    I'm trying to migrate my mail from a qmail/courier setup. After fighting with the imapsync syntax to get logged in to both servers, it shows me all the folders/number of messages it's going to transfer, then fails when it tries to actually copy a message. The syntax I'm using for imapsync is:

    /usr/bin/imapsync --buffersize 8192000 --nosyncacls --subscribe --syncinternaldates --host1 OLDHOST --user1 OLDUSER --passfile1 PASSFILE --authmech1 CRAM-MD5 --host2 ZIMBRAHOST--user2 NEWUSER --passfile2 PASSFILE --noauthmd5 --ssl2
    It should be noted that I had to run this as the zimbra user. When run as root, it fails to connect to the zimbra server via SSL for some reason.

    The relevant error info is below:
    ++++ Looping on each folder ++++
    From Folder [INBOX]
    To   Folder [INBOX]
    Subscribing to folder INBOX on destination server
    ++++ From [INBOX] Parse 1 ++++
    ++++ To   [INBOX] Parse 1 ++++
    ++++ Verifying [INBOX] -> [INBOX] ++++
    + NO msg #12221 [RbCofTaXRMXjfivhwvcPPw:4778] in INBOX
    + Copying msg #12221:4778 to folder INBOX
    Unable to open tmp_imapsync_8093: Permission denied at /usr/bin/imapsync line 1143
    error [tmp_imapsync_8093]: No such file or directory  at /usr/bin/imapsync line 1495.

  2. #2
    Join Date
    Jul 2007
    Rep Power


    if it's tryign to create the tmp_imapsync file in the zimbra home directory (/opt/zimbra by default) you'll find actually that the zimbra user doesn't have write access to it's home directory. I don't know why you're having problems running as root. Try creating a regular user on teh system and running it see if that works.

    What is line 1143 anyway?

  3. #3
    Join Date
    Sep 2008
    Northern Virginia
    Rep Power


    Looks like that was it. I chown'd /opt/zimbra to zimbra, and it's now copying away. Weird. Thanks for the hint, that was driving me crazy.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 12:41 AM
  3. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  4. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  5. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts