Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: [SOLVED] Running sshd on non standard port, having problems changing it in Zimbra 5.0

  1. #1
    Join Date
    Mar 2006
    Posts
    79
    Rep Power
    9

    Default [SOLVED] Running sshd on non standard port, having problems changing it in Zimbra 5.0

    Hi,

    I run Zimbra 5.0.8 on Debian Etch (4.0).

    I decided to use port 36220 for sshd.

    I'm trying to change this config in Zimbra's config.

    As user zimbra, I run this commant :

    Code:
    zmprov ms SERVER.DOMAIN.COM zimbraRemoteManagementPort 36220
    But I'm getting the following error :

    Code:
    ERROR: service.INVALID_REQUEST (invalid request: port 143 conflict between zimbraImapBindPort and zimbraImapProxyBindPort on server SERVER.DOMAIN.COM)
    When I run the following command :

    Code:
    zmprov getServer SERVER.DOMAIN.COM | grep -i port
    I get the following result :

    Code:
    zimbraAdminPort: 7071
    zimbraImapBindPort: 143
    zimbraImapProxyBindPort: 143
    zimbraImapSSLBindPort: 993
    zimbraImapSSLProxyBindPort: 993
    zimbraLmtpBindPort: 7025
    zimbraMailPort: 80
    zimbraMailProxyPort: 0
    zimbraMailSSLPort: 443
    zimbraMailSSLProxyPort: 0
    zimbraMemcachedBindPort: 11211
    zimbraPop3BindPort: 110
    zimbraPop3ProxyBindPort: 110
    zimbraPop3SSLBindPort: 995
    zimbraPop3SSLProxyBindPort: 995
    zimbraRemoteManagementPort: 22
    zimbraSmtpPort: 25
    And with this command :

    Code:
    zmprov getServer SERVER.DOMAIN.COM | grep -i proxy
    I get :

    Code:
    zimbraImapProxyBindPort: 143
    zimbraImapSSLProxyBindPort: 993
    zimbraMailProxyPort: 0
    zimbraMailSSLProxyPort: 0
    zimbraPop3ProxyBindPort: 110
    zimbraPop3SSLProxyBindPort: 995
    zimbraReverseProxyHttpEnabled: FALSE
    zimbraReverseProxyImapSaslGssapiEnabled: FALSE
    zimbraReverseProxyImapStartTlsMode: only
    zimbraReverseProxyLookupTarget: FALSE
    zimbraReverseProxyMailEnabled: TRUE
    zimbraReverseProxyPop3SaslGssapiEnabled: FALSE
    zimbraReverseProxyPop3StartTlsMode: only
    What do I need to change in order to be able to change my zimbraRemoteManagementPort to 36220?

    Thanx for your help.

  2. #2
    Join Date
    Apr 2008
    Location
    New Paltz, NY
    Posts
    336
    Rep Power
    7

    Default

    As far as I can tell - the problem is that zmprov is seeing another error (that you have the following two ports the same: zimbraImapBindPort: 143 and ZimbraImapProxyBindPort: 143).

    If you first change your ZimbraImapProxyBindPort from 143 to something else, you should then be able to change the ZimbraRemoteManagementPort as far as I can tell.

  3. #3
    Join Date
    Mar 2006
    Posts
    79
    Rep Power
    9

    Default

    Thanx for your input, it is appreciated.

    I under stand what you say.

    I recall when I installed Zimbra 5.0.8, it asked me if I wanted to enable proxing and I answered no.

    I was wondering, if I manually change the port number for zimbraImapProxyBindPort, to some other port, will it cause an other problem?

    Should I activate proxying instead so that, according to the doc here, the ports get changed to 7xxx ports?

    If during install it was possible to avoid activating proxying, isn't it odd that then zmprov complains about ports being the same?

    Thanx!

  4. #4
    Join Date
    Apr 2008
    Location
    New Paltz, NY
    Posts
    336
    Rep Power
    7

    Default

    We're not using Proxying here so I left it at the default ports (shown below) without any problems.

    zimbraImapProxyBindPort: 7143
    zimbraImapSSLProxyBindPort: 7993
    zimbraMailProxyPort: 8080
    zimbraMailSSLProxyPort: 8443
    zimbraPop3ProxyBindPort: 7110
    zimbraPop3SSLProxyBindPort: 7995

  5. #5
    Join Date
    Mar 2006
    Posts
    79
    Rep Power
    9

    Default

    Ok, thanx for the tip I'll try it.

  6. #6
    Join Date
    Mar 2006
    Posts
    79
    Rep Power
    9

    Default

    Hum,

    Maybe it's me, maybe i'm doing it wrong but I can't get any ports to change. I always get an error.

    Code:
    zimbra@SERVER:~$ zmprov ms SERVER.DOMAIN.COM zimbraImapProxyBindPort 7143
    ERROR: service.INVALID_REQUEST (invalid request: port 993 conflict between zimbraImapSSLBindPort and zimbraImapSSLProxyBindPort on server SERVER.DOMAIN.COM)
    zimbra@SERVER:~$ zmprov ms SERVER.DOMAIN.COM zimbraImapSSLProxyBindPort 7993
    ERROR: service.INVALID_REQUEST (invalid request: port 143 conflict between zimbraImapBindPort and zimbraImapProxyBindPort on server SERVER.DOMAIN.COM)
    zimbra@SERVER:~$ zmprov ms SERVER.DOMAIN.COM zimbraPop3ProxyBindPort 7110
    ERROR: service.INVALID_REQUEST (invalid request: port 143 conflict between zimbraImapBindPort and zimbraImapProxyBindPort on server SERVER.DOMAIN.COM)
    zimbra@SERVER:~$ zmprov ms SERVER.DOMAIN.COM zimbraPop3SSLProxyBindPort 7995
    ERROR: service.INVALID_REQUEST (invalid request: port 143 conflict between zimbraImapBindPort and zimbraImapProxyBindPort on server SERVER.DOMAIN.COM)
    Should I be doing these commands while Zimbra is stopped?

    Or shoutld I just enable proxying? How do I enable proxying?

    Thanx!
    Last edited by jml75; 09-10-2008 at 10:14 AM.

  7. #7
    Join Date
    Apr 2008
    Location
    New Paltz, NY
    Posts
    336
    Rep Power
    7

    Default

    Having proxying on won't fix the problem - it will then potentially be worse (since I don't know whether the proxy or the regular one of each of those will work).

    I would call this a bug in my opinion - Zimbra is complaining about ports being wrong - but not letting you change them because OTHER ports are wrong.

    If you have a supported version I'd drop them a note asking how you can change all of the Proxy ports at once.

  8. #8
    Join Date
    Apr 2008
    Location
    New Paltz, NY
    Posts
    336
    Rep Power
    7

    Default

    Actually... thought of one thing you can do.

    You can change the IMAP/POP ports (though not the proxies that I can find) in the web admin (under configuration, server, double click on your domain).

    Change regular IMAP, POP (and their SSL counterparts) temporarily to different ports. Then run the command line utility to change the proxy ports (it won't complain now), then change the non-proxy IMAP/POP back to their regular ports. That should do it all (then let you make the change you wanted to make in the first place).

  9. #9
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Are you absolutely sure that proxying is actually off? It should only be giving you warnings like that if you decided to install proxying, which you should NOT do unless you are actually going to use it on that server as it causes many strange errors for a regular server to have it installed.

  10. #10
    Join Date
    Mar 2006
    Posts
    79
    Rep Power
    9

    Default

    Hi,

    Thanx for your posts.

    ArcaneMagus:
    As far as I remember, during install, I did not activate proxying. Also, since
    Code:
    zimbraImapBindPort: 143
    zimbraImapProxyBindPort: 143
    have the same port value, I think this indicates that proxying is not enabled because if it was, they would be at

    Code:
    zimbraImapBindPort: 7143
    zimbraImapProxyBindPort: 143
    so I think that proxying is not enabled.

    Really, I don't think that I need proxying and I don't absolutly want it to be on but I really want to be able to change the port for sshd.

    chauvetp:
    I'll think about your suggestion and I will probably try it. I'll confirm you if it works or not.

    So you think that this is a bug that I should report? If any of you Zimbra employees read this threat, I'd like your opinion on this please.

    Thanx!

Similar Threads

  1. Problem Install Zimbra ver 5.0.4_GA_2101.F7
    By maman in forum Installation
    Replies: 5
    Last Post: 04-14-2008, 12:50 PM
  2. Replies: 22
    Last Post: 12-02-2007, 04:05 PM
  3. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 06:38 PM
  5. Network edition - strange behavior
    By goetzi in forum Installation
    Replies: 6
    Last Post: 11-16-2005, 02:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •