Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 47

Thread: Postfix problem

  1. #21
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Something's wrong with LDAP, and your config.

    Try
    zmcontrol stop
    ps auxx | grep zimbra (kill any left over processes)
    su root
    chown -R zimbra:zimbra /opt/zimbra/*
    cd /opt/zimbra/libexec
    ./zmfixperms
    su zimbra
    zmcontrol start
    tail -100 /opt/zimbra/log/mailbox.log

    post that

  2. #22
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Thanks. I've done that. I still get the error -- here are the relevant lines at the end of the maillog.

    Rob

    2007-03-04 15:49:32,441 INFO [main] [] soap - Servlet SoapServlet starting up
    2007-03-04 15:49:32,468 INFO [main] [] soap - Adding service AccountService to SoapServlet
    2007-03-04 15:49:32,565 INFO [main] [] soap - Adding service MailService to SoapServlet
    2007-03-04 15:49:32,781 INFO [main] [] soap - Adding service IMService to SoapServlet
    2007-03-04 15:49:32,788 INFO [main] [] misc - version=4.5.3_GA_733.FC5 release=20070228105051 builddate=20070228-1051 buildhost=wolfowitz.
    liquidsys.com
    2007-03-04 15:49:32,790 INFO [main] [] misc - LANG environment is set to: en_US.UTF-8
    2007-03-04 15:49:32,816 INFO [main] [] DbPool - Setting mysql connector property: maxActive=16
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_calendar_force_utc) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_validate_outgoing_icalendar) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_conversation) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_filter) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_message_analysis) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_mime_part_extraction) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_indexing) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_objects) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_indexing_attachments_separate ly) was null, returning empty string
    2007-03-04 15:49:33,184 WARN [main] [] misc - LC.get(debug_disable_indexing_attachments_together ) was null, returning empty string
    2007-03-04 15:49:33,185 WARN [main] [] misc - LC.get(debug_disable_mailbox_group) was null, returning empty string
    2007-03-04 15:49:33,204 INFO [main] [] extensions - Loading extensions from /opt/zimbra/lib/ext
    2007-03-04 15:49:33,206 INFO [main] [] extensions - extension com.zimbra.clam.ClamScanner found in /opt/zimbra/lib/ext/clamscanner/clamsca
    nner.jar
    2007-03-04 15:49:33,206 INFO [main] [] extensions - Initializing extensions
    2007-03-04 15:49:33,213 INFO [main] [] ClamScanner - attachment scan is disabled
    2007-03-04 15:49:33,305 INFO [main] [] extensions - Initialized extension clamscanner: com.zimbra.clam.ClamScanner@com.zimbra.cs.extension
    .ZimbraExtensionClassLoader@7a36a2
    2007-03-04 15:49:33,320 INFO [IndexWritersSweeper] [] MailboxIndex - IndexWritersSweeper thread starting
    2007-03-04 15:49:33,341 INFO [main] [] RedoLogManager - Starting pre-startup crash recovery
    2007-03-04 15:49:33,368 INFO [main] [] RedoPlayer - No uncommitted transactions to redo
    2007-03-04 15:49:33,443 INFO [main] [] RedoLogManager - Finished pre-startup crash recovery
    2007-03-04 15:49:33,473 INFO [NOTIFY-7035-Server] [] misc - starting server loop
    2007-03-04 15:49:33,480 FATAL [main] [] system - invalid value -1 for zimbraLmtpNumThreads
    2007-03-04 15:49:37,725 INFO [main] [] soap - Servlet SoapServlet starting up
    2007-03-04 15:49:37,752 INFO [main] [] soap - Adding service AccountService to SoapServlet
    2007-03-04 15:49:37,850 INFO [main] [] soap - Adding service MailService to SoapServlet
    2007-03-04 15:49:38,065 INFO [main] [] soap - Adding service IMService to SoapServlet
    2007-03-04 15:49:38,072 INFO [main] [] misc - version=4.5.3_GA_733.FC5 release=20070228105051 builddate=20070228-1051 buildhost=wolfowitz.
    liquidsys.com
    2007-03-04 15:49:38,073 INFO [main] [] misc - LANG environment is set to: en_US.UTF-8
    2007-03-04 15:49:38,092 INFO [main] [] DbPool - Setting mysql connector property: maxActive=16
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_calendar_force_utc) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_validate_outgoing_icalendar) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_conversation) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_filter) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_message_analysis) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_mime_part_extraction) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_indexing) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_objects) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_indexing_attachments_separate ly) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_indexing_attachments_together ) was null, returning empty string
    2007-03-04 15:49:38,459 WARN [main] [] misc - LC.get(debug_disable_mailbox_group) was null, returning empty string
    2007-03-04 15:49:38,466 INFO [main] [] extensions - Loading extensions from /opt/zimbra/lib/ext
    2007-03-04 15:49:38,468 INFO [main] [] extensions - extension com.zimbra.clam.ClamScanner found in /opt/zimbra/lib/ext/clamscanner/clamsca
    nner.jar
    2007-03-04 15:49:38,468 INFO [main] [] extensions - Initializing extensions
    2007-03-04 15:49:38,475 INFO [main] [] ClamScanner - attachment scan is disabled
    2007-03-04 15:49:38,567 INFO [main] [] extensions - Initialized extension clamscanner: com.zimbra.clam.ClamScanner@com.zimbra.cs.extension
    .ZimbraExtensionClassLoader@12d8ecd
    2007-03-04 15:49:38,582 INFO [IndexWritersSweeper] [] MailboxIndex - IndexWritersSweeper thread starting
    2007-03-04 15:49:38,603 INFO [main] [] RedoLogManager - Starting pre-startup crash recovery
    2007-03-04 15:49:38,637 INFO [main] [] RedoPlayer - No uncommitted transactions to redo
    2007-03-04 15:49:38,663 INFO [main] [] RedoLogManager - Finished pre-startup crash recovery
    2007-03-04 15:49:38,710 INFO [NOTIFY-7035-Server] [] misc - starting server loop
    2007-03-04 15:49:38,717 FATAL [main] [] system - invalid value -1 for zimbraLmtpNumThreads

  3. #23
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    What's going on here? Are you leaving something out? Did you have a server crash or something?

    Post these, and make sure you use the code function:
    netstat -a | grep 389
    netstat -a | grep slapd
    netstat -a | grep zimbra

    cat /etc/hosts

  4. #24
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Hi,

    No, no server crash. A clean install on new disks.

    Code:
    [zimbra@ls2kserver libexec]$ netstat -a | grep 389
    [zimbra@ls2kserver libexec]$ netstat -a | grep slapd
    [zimbra@ls2kserver libexec]$ netstat -a | grep zimbra
    unix  2      [ ACC ]     STREAM     LISTENING     170858 /opt/zimbra/logger/db/mysql.sock
    unix  2      [ ACC ]     STREAM     LISTENING     170939 /opt/zimbra/db/mysql.sock
    unix  2      [ ACC ]     STREAM     LISTENING     171334 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/state/mux
    unix  2      [ ACC ]     STREAM     LISTENING     171245 /opt/zimbra/amavisd/amavisd.sock
    unix  3      [ ]         STREAM     CONNECTED     170937 /opt/zimbra/logger/db/mysql.sock
    [zimbra@ls2kserver libexec]$ cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost 
    192.168.0.222   ls2kserver.lifestyletrust.org.nz ls2kserver
    [zimbra@ls2kserver libexec]$
    If it helps you to know, I have set up split DNS as descibed on the wiki. I don't know if that is relevant.

    Thanks,

    Rob

  5. #25
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default LDAP Not starting??

    How about
    su zimbra
    ldap status

    and

    telnet localhost 389
    and
    telnet mail.domainhere.com 389

    post those

  6. #26
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    I have a complete copy of the entire contents of the old array (OS, Zimbra, the lot) under /old_disks/ on the new array. Do you think it would be possible to use chroot to use the old installation temporarily while I get this sorted out?

    Rob

  7. #27
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Aha!

    Code:
    [zimbra@ls2kserver libexec]$ ldap status
    slapd running pid: 23694
    [zimbra@ls2kserver libexec]$ telnet localhost 389
    Trying 127.0.0.1...
    telnet: connect to address 127.0.0.1: Connection refused
    telnet: Unable to connect to remote host: Connection refused
    [zimbra@ls2kserver libexec]$
    But ...

    Code:
    [zimbra@ls2kserver libexec]$ telnet ls2kserver 389
    Trying 192.168.0.222...
    Connected to ls2kserver.lifestyletrust.org.nz (192.168.0.222).
    Escape character is '^]'.
    and ...

    Code:
    [zimbra@ls2kserver libexec]$ telnet ls2kserver.lifestyletrust.org.nz 389
    Trying 192.168.0.222...
    Connected to ls2kserver.lifestyletrust.org.nz (192.168.0.222).
    Escape character is '^]'.
    Last edited by robscovell; 03-03-2007 at 08:11 PM.

  8. #28
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by robscovell View Post
    I have a complete copy of the entire contents of the old array (OS, Zimbra, the lot) under /old_disks/ on the new array. Do you think it would be possible to use chroot to use the old installation temporarily while I get this sorted out?

    Rob
    Not on the same box. That would just be a mess.

  9. #29
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    okay then-
    zmlocalconfig | grep ldap

  10. #30
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Quote Originally Posted by jholder View Post
    okay then-
    zmlocalconfig | grep ldap
    Code:
    [zimbra@ls2kserver libexec]$ zmlocalconfig | grep ldap
    ldap_cache_account_maxage = 15
    ldap_cache_account_maxsize = 5000
    ldap_cache_cos_maxage = 15
    ldap_cache_cos_maxsize = 100
    ldap_cache_domain_maxage = 15
    ldap_cache_domain_maxsize = 100
    ldap_cache_server_maxage = 15
    ldap_cache_server_maxsize = 100
    ldap_cache_timezone_maxsize = 100
    ldap_cache_zimlet_maxage = 15
    ldap_cache_zimlet_maxsize = 100
    ldap_connect_pool_debug = false
    ldap_connect_pool_initsize = 1
    ldap_connect_pool_maxsize = 25
    ldap_connect_pool_prefsize = 0
    ldap_connect_pool_timeout = 120000
    ldap_connect_timeout = 10000
    ldap_host = ls2kserver.lifestyletrust.org.nz
    ldap_is_master = true
    ldap_log_level = 0
    ldap_master_url = ldap://ls2kserver.lifestyletrust.org.nz:389
    ldap_port = 389
    ldap_root_password = *
    ldap_url = ldap://ls2kserver.lifestyletrust.org.nz:389
    postfix_sender_canonical_maps = ldap:/opt/zimbra/conf/ldap-scm.cf
    postfix_transport_maps = ldap:/opt/zimbra/conf/ldap-transport.cf
    postfix_virtual_alias_domains = ldap://opt/zimbra/conf/ldap-vad.cf
    postfix_virtual_alias_maps = ldap:/opt/zimbra/conf/ldap-vam.cf
    postfix_virtual_mailbox_domains = ldap:/opt/zimbra/conf/ldap-vmd.cf
    postfix_virtual_mailbox_maps = ldap:/opt/zimbra/conf/ldap-vmm.cf
    zimbra_class_provisioning = com.zimbra.cs.account.ldap.LdapProvisioning
    zimbra_ldap_password = *
    zimbra_ldap_user = zimbra
    zimbra_ldap_userdn = uid=zimbra,cn=admins,cn=zimbra
    zimbra_zmprov_default_to_ldap = false
    [zimbra@ls2kserver libexec]$

Similar Threads

  1. Replies: 23
    Last Post: 04-19-2013, 10:06 PM
  2. Replies: 3
    Last Post: 11-03-2007, 11:55 PM
  3. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  4. Problem with Postfix on Ubuntu
    By kgmeyer in forum Installation
    Replies: 6
    Last Post: 01-22-2007, 04:49 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •