Page 4 of 5 FirstFirst ... 2345 LastLast
Results 31 to 40 of 47

Thread: Postfix problem

  1. #31
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    4. Removed Zimbra 4.5 from /opt/zimbra
    5. Restored 3.1 to /opt/zimbra
    6. Ran install.sh to upgrade from 3.1 to 4.5
    Can you explain a little more how you did #4 and how you restored #5?

  2. #32
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Quote Originally Posted by jholder View Post
    Can you explain a little more how you did #4 and how you restored #5?
    I followed these instructions:

    http://www.zimbra.com/forums/showthread.php?t=4713

    This is how I did 4 and 5:

    #4: rm -rf /opt/zimbra
    #5: rsync -av /old_disks/opt/zimbra /opt/

  3. #33
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Okay-
    Follow these instructions:
    http://wiki.zimbra.com/index.php?title=UnInstall_Zimbra

    I'm willing to bet LDAP was still running when you blasted it away

  4. #34
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Quote Originally Posted by jholder View Post
    Okay-
    Follow these instructions:
    http://wiki.zimbra.com/index.php?title=UnInstall_Zimbra

    I'm willing to bet LDAP was still running when you blasted it away
    OK, I'm doing that now. Should I then do this? ---

    1. rsync -av /old_disks/opt/zimbra /opt/
    2. Start the upgrade process again.

    ?

  5. #35
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by robscovell View Post
    OK, I'm doing that now. Should I then do this? ---

    1. rsync -av /old_disks/opt/zimbra /opt/
    2. Start the upgrade process again.

    ?
    Well you need to *upgrade* using the same version that you're rsyncing. For example, if the zimbra that's in /old_disks is 3.1, then you need to run the 3.1 installer, THEN and ONLY THEN do you upgrade to 4.5.3



    john

  6. #36
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Quote Originally Posted by jholder View Post
    Well you need to *upgrade* using the same version that you're rsyncing. For example, if the zimbra that's in /old_disks is 3.1, then you need to run the 3.1 installer, THEN and ONLY THEN do you upgrade to 4.5.3



    john
    OK done that. Now doing this:

    http://wiki.zimbra.com/index.php?tit...rce_Version%29

    Is that the right thing to do now?

    Rob

  7. #37
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    Quote Originally Posted by robscovell View Post
    OK done that. Now doing this:

    http://wiki.zimbra.com/index.php?tit...rce_Version%29

    Is that the right thing to do now?

    Rob
    Heh,
    I actually wrote that a while ago, but it should still be valid.

  8. #38
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default

    Quote Originally Posted by jholder View Post
    Heh,
    I actually wrote that a while ago, but it should still be valid.
    OK, this is what I have done:

    1. Completely uninstalled 4.5 as per the wiki.
    2. Tried to install a clean 3.1 prior to doing the restore-backup procedure.

    However, 3.1 doesn't seem to want to install on FC5.

    Code:
       q) Quit                                    
    
    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] 
    Save config in file: [/opt/zimbra/config.17726] 
    Saving config in /opt/zimbra/config.17726...Done
    The system will be modified - continue? [No] Yes
    Operations logged to /tmp/zmsetup.log.17726
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...FAILED (256)
    
    
    ERROR
    
    
    
    Configuration failed
    
    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration

  9. #39
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    21

    Default

    cat /tmp/zmsetup.log.17726
    post that

  10. #40
    Join Date
    Mar 2006
    Posts
    34
    Rep Power
    9

    Default /tmp/zmsetup.log.17726

    Code:
    ** Creating CA private key
    
    
    Generating a 1024 bit RSA private key
    ...................................++++++
    .............++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/server/server.key'
    -----
    ** Signing cert request
    
    Using configuration from /opt/zimbra/ssl/ssl/zmssl.cnf
    Check that the request matches the signature
    Signature ok
    Certificate Details:
            Serial Number: 2 (0x2)
            Validity
                Not Before: Mar  4 04:09:00 2007 GMT
                Not After : Mar  3 04:09:00 2008 GMT
            Subject:
                countryName               = US
                stateOrProvinceName       = N/A
                organizationName          = Zimbra Collaboration Suite
                commonName                = ls2kserver.lifestyletrust.org.nz
            X509v3 extensions:
                X509v3 Basic Constraints: 
                    CA:FALSE
                Netscape Comment: 
                    OpenSSL Generated Certificate
                X509v3 Subject Key Identifier: 
                    78:95:2C:97:D2:60:C0:DC:23:9D:60:24:77:AC:DA:B0:31:E5:8C:8B
                X509v3 Authority Key Identifier: 
                    DirName:/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite/CN=ls2kserver.lifestyletrust.org.nz
                    serial:D7:56:BA:38:95:5A:15:09
    
    Certificate is to be certified until Mar  3 04:09:00 2008 GMT (365 days)
    
    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=ls2kserver.lifestyletrust.org.nz
    Getting CA Private Key
    unable to write 'random state'
    ERROR - failed to start slapd

Similar Threads

  1. Replies: 23
    Last Post: 04-19-2013, 10:06 PM
  2. Replies: 3
    Last Post: 11-03-2007, 11:55 PM
  3. Replies: 13
    Last Post: 07-20-2007, 04:21 AM
  4. Problem with Postfix on Ubuntu
    By kgmeyer in forum Installation
    Replies: 6
    Last Post: 01-22-2007, 04:49 AM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •