Results 1 to 4 of 4

Thread: Setting a different schedule for automatic backups

  1. #1
    Join Date
    Jul 2007
    Posts
    9
    Rep Power
    8

    Default Setting a different schedule for automatic backups

    Hi, I have a ZCS Network Edition 5.0.6 under Red Hat Enterprise Linux 5 and works very fine, but the process of automatic backup is eating almost all the hard disk space.

    By default, it's scheduled to delete backups older than 1 month, but I want to do it every 10 days or so. The help page for zmschedulebackup is not very clear to set it, the syntax is something like this:

    zmschedulebackup -R d "n{d|m|y}"
    Where the quoted string is the time specifier to delete bakups, but every combination I typed it's wrong, do somebody know how to do this?

    Greetings.

  2. #2
    Join Date
    Apr 2006
    Location
    Illinois
    Posts
    194
    Rep Power
    9

    Default

    Try:

    zmschedulebackup -R d 10d "0 0 * * *"

    The stuff in quotes is crontab formatted, so if you want it to run at a different hour than midnight, change those values.

    The problem with this format is that it will replace your complete backup schedule. So, what you are going to want to do is be sure you write down what your current schedule is then use the -A option, not the -R option to schedule your daily backups and also your 10d deletions.

    Does that make sense?

  3. #3
    Join Date
    Jul 2007
    Posts
    9
    Rep Power
    8

    Default It works.

    Just like you said, I used the '-A' option and now my schedule is this.


    f 0 1 * * 6 -a all
    i 0 1 * * 0-5 -a all
    d 1m 0 0 * * *
    d 10d 0 0 * * *

    Thank you.

  4. #4
    Join Date
    Apr 2006
    Location
    Illinois
    Posts
    194
    Rep Power
    9

    Default

    I'm glad you have what you want, but you may want to reconfigure to remove the monthly delete too.

Similar Threads

  1. Initializing ldap...failed. (28416) on RHEL 5
    By Nicrad in forum Installation
    Replies: 35
    Last Post: 10-22-2012, 06:57 PM
  2. Installation with a configuration file problems...
    By smurraysb in forum Installation
    Replies: 4
    Last Post: 04-16-2008, 11:22 PM
  3. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  4. Shared Folder
    By drdre in forum Administrators
    Replies: 20
    Last Post: 01-20-2008, 12:07 PM
  5. Server platform change RH to Ubuntu issues
    By marke in forum Administrators
    Replies: 5
    Last Post: 11-07-2007, 11:27 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •