Results 1 to 5 of 5

Thread: [SOLVED] Problem when install CAcert certificate

Hybrid View

  1. #1
    Join Date
    Jul 2007
    Location
    Brazil
    Posts
    55
    Rep Power
    8

    Question [SOLVED] Problem when install CAcert certificate

    Hi All,

    I installed the new certificate (create by CACert) without problem.
    But when I restart the zimbra the webmail haven't worked anymore.

    I show bellow the message when I start the zimbra.

    [zimbra@mailhost ~]$ zmcontrol start
    Host mailhost.coc.ufrj.br
    Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...Done.
    Starting stats...Done.
    [zimbra@mailhost ~]$

    Why do I have problem with ldap after I installed the new cert?
    How do I fix this?

    Best regards,
    Bibo

  2. #2
    Join Date
    Jul 2007
    Location
    Brazil
    Posts
    55
    Rep Power
    8

    Default

    Hi,

    I forgot to say that I imported the root and intermediate certficate in PEM format from CACert using administrator console (web).

    Bellow I show the output from zmcertmgr to verify certs.

    root@mailhost ca]# /opt/zimbra/bin/zmcertmgr verifycrt comm
    ** Verifying /opt/zimbra/ssl/zimbra/commercial/commercial.crt against /opt/zimbra/ssl/zimbra/commercial/commercial.key
    Certificate (/opt/zimbra/ssl/zimbra/commercial/commercial.crt) and private key (/opt/zimbra/ssl/zimbra/commercial/commercial.key) match.
    Valid Certificate: /opt/zimbra/ssl/zimbra/commercial/commercial.crt: OK

    How do I fix the ldap problem?

    Best regards,
    Bibo

  3. #3
    Join Date
    Aug 2007
    Posts
    12
    Rep Power
    8

    Default

    Any solution???

  4. #4
    Join Date
    Jul 2007
    Location
    Brazil
    Posts
    55
    Rep Power
    8

    Default

    Quote Originally Posted by dehylus View Post
    Any solution???
    Yes. I generate another certificate with webmail.mydomain.com and alternative name with myserver name. The problem was that the ldap have to have myserver name inside the certificate.

    Regards,
    Bibo

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

Similar Threads

  1. problem with certificate + WM6?
    By raul_denia in forum Zimbra Mobile
    Replies: 0
    Last Post: 09-01-2008, 06:39 AM
  2. install DNS server for zimbra problem
    By wajdislama in forum Installation
    Replies: 1
    Last Post: 08-16-2008, 10:17 AM
  3. Replies: 0
    Last Post: 01-15-2008, 01:33 PM
  4. Replies: 6
    Last Post: 04-06-2007, 09:32 PM
  5. Certificate problem following 3.1.0 -> 4.0 upgrade
    By simonellistonball in forum Migration
    Replies: 5
    Last Post: 09-26-2006, 02:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •