Results 1 to 5 of 5

Thread: LDAP connection refused

  1. #1
    Join Date
    Sep 2008
    Posts
    3
    Rep Power
    7

    Default LDAP connection refused

    I've just install Zimbra 5.0.9 under Ubuntu 8.04 and it's all working fine apart from accessing the address book from Thunderbird. I followed the wiki instructions to setup Thunderbird but searching the address book from Thunderbird returns no results.

    If I ssh in to the server (called zimbra.mms or zimbra) and telnet to zimbra (or zimbra.mms) 389 I can successfully connect. From another computer if I try telnetting to zimbra 389 I get connection refused. I have disabled ufw and iptables is empty.

    Is there some way I can get it to accept connections from other computers?

    TIA

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    What does this show please
    Code:
    netstat -an | grep 389
    and also
    Code:
    cat /etc/hosts
    su - zimbra
    zmlocalconfig | grep 389
    Last edited by uxbod; 09-15-2008 at 02:04 AM.

  3. #3
    Join Date
    Sep 2008
    Posts
    3
    Rep Power
    7

    Default

    Quote Originally Posted by uxbod View Post
    Welcome to the forums

    What does this show please
    Thanks!

    Code:
    mark@zimbra:~$ netstat -an | grep 389
    tcp        0      0 127.0.1.1:389           0.0.0.0:*               LISTEN
    tcp        0      0 127.0.1.1:389           127.0.1.1:53270         ESTABLISHED
    tcp        0      0 127.0.1.1:389           127.0.1.1:53269         ESTABLISHED
    tcp6       0      0 127.0.1.1:53270         127.0.1.1:389           ESTABLISHED
    tcp6       0      0 127.0.1.1:53269         127.0.1.1:389           ESTABLISHED
    Code:
    mark@zimbra:~$ cat /etc/hosts
    127.0.0.1       localhost
    127.0.1.1       zimbra.mms      zimbra
    Code:
    zimbra@zimbra:~$ zmlocalconfig | grep 389
    ldap_master_url = ldap://zimbra.mms:389
    ldap_port = 389
    ldap_url = ldap://zimbra.mms:389
    TIA

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Does it work if you telnet to the IP address from another workstation ? As the server is on a private IP can the workstation even resolve the zimbra hostname ?

  5. #5
    Join Date
    Sep 2008
    Posts
    3
    Rep Power
    7

    Default

    Quote Originally Posted by uxbod View Post
    Does it work if you telnet to the IP address from another workstation ? As the server is on a private IP can the workstation even resolve the zimbra hostname ?
    I can ping zimbra and ssh in but I can't telnet to port 389 but I've realised after reading what I posted before that I changed the ip address to 127.0.1.1 instead of its static lan address. I might try changing that back before doing anything else.

    TIA

Similar Threads

  1. DNS Questions and Trouble Installing
    By smurraysb in forum Installation
    Replies: 22
    Last Post: 03-14-2008, 04:27 PM
  2. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  3. Lots of deferred errors all of a sudden
    By CdtDelta in forum Administrators
    Replies: 0
    Last Post: 12-01-2007, 08:27 AM
  4. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 07:25 AM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •