Results 1 to 2 of 2

Thread: Cannot send or receive email

  1. #1
    Join Date
    Jul 2008
    Posts
    12
    Rep Power
    7

    Default Cannot send or receive email

    Hi all, was trying to install pop-before smtp and all went well with the installation following a guide from this forum.

    However, Now I can neither send out nor receive any mail. My log files look like this;

    com.zimbra.common.service.ServiceException: system failure: MessagingException
    ExceptionId:btpool0-8:1221546362063:2f44326c94ece8f2
    Code:service.FAILURE
    at com.zimbra.common.service.ServiceException.FAILURE (ServiceException.java:253)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:327)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:117)
    at com.zimbra.cs.service.mail.SendMsg.doSendMessage(S endMsg.java:184)
    at com.zimbra.cs.service.mail.SendMsg.handle(SendMsg. java:150)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:410)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:267)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:159)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:266)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:188)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1093)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1084)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:360)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:716)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:406)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:350)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:844)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:205)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)
    Caused by: com.zimbra.cs.mailbox.MailSender$SafeMessagingExce ption: Read timed out; chained exception is:
    java.net.SocketTimeoutException: Read timed out
    at com.sun.mail.smtp.SMTPTransport.readServerResponse (SMTPTransport.java:1598)
    at com.sun.mail.smtp.SMTPTransport.openServer(SMTPTra nsport.java:1356)
    at com.sun.mail.smtp.SMTPTransport.protocolConnect(SM TPTransport.java:399)
    at javax.mail.Service.connect(Service.java:275)
    at javax.mail.Service.connect(Service.java:156)
    at javax.mail.Service.connect(Service.java:105)
    at javax.mail.Transport.send0(Transport.java:168)
    at javax.mail.Transport.send(Transport.java:98)
    at com.zimbra.cs.mailbox.MailSender.sendMessage(MailS ender.java:456)
    at com.zimbra.cs.mailbox.MailSender.sendMimeMessage(M ailSender.java:251)
    ... 33 more

    Someone kindly help. I have tried everything including undoing all the changes that I made in installing pop-before-smtp but still not able to do anything.

    Regards,
    Mugo
    Last edited by mugo; 09-16-2008 at 12:10 AM. Reason: adding info

  2. #2
    Join Date
    Jul 2008
    Posts
    12
    Rep Power
    7

    Default Still cannot send mail.....help!

    Hi guys, as in the above post, Im having trouble with my mail server. The strange thing is that I can telnet to most mail ports especially 25.

    Wondering what pop-before-smtp could have changed though because the zimbra logs consistently show a broken pipe problem as here;-

    java.net.SocketException: Broken pipe
    at java.net.SocketOutputStream.socketWrite0(Native Method)
    at java.net.SocketOutputStream.socketWrite(SocketOutp utStream.java:92)
    at java.net.SocketOutputStream.write(SocketOutputStre am.java:136)
    at java.io.BufferedOutputStream.flushBuffer(BufferedO utputStream.java:65)
    at java.io.BufferedOutputStream.flush(BufferedOutputS tream.java:123)
    at com.zimbra.cs.imap.TcpImapHandler.sendLine(TcpImap Handler.java:258)
    at com.zimbra.cs.imap.ImapHandler.sendResponse(ImapHa ndler.java:3534)
    at com.zimbra.cs.imap.ImapHandler.sendOK(ImapHandler. java:3521)
    at com.zimbra.cs.imap.ImapHandler.doLOGOUT(ImapHandle r.java:964)
    at com.zimbra.cs.imap.ImapHandler.executeRequest(Imap Handler.java:459)
    at com.zimbra.cs.imap.TcpImapHandler.processCommand(T cpImapHandler.java:124)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:160)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:128)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)

    and

    javax.net.ssl.SSLHandshakeException: Received fatal alert: bad_certificate
    at com.sun.net.ssl.internal.ssl.Alerts.getSSLExceptio n(Alerts.java:150)
    at com.sun.net.ssl.internal.ssl.Alerts.getSSLExceptio n(Alerts.java:117)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.recvAle rt(SSLSocketImpl.java:1650)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRec ord(SSLSocketImpl.java:925)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.perform InitialHandshake(SSLSocketImpl.java:1089)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHa ndshake(SSLSocketImpl.java:1116)
    at com.sun.net.ssl.internal.ssl.SSLSocketImpl.startHa ndshake(SSLSocketImpl.java:1100)
    at com.zimbra.cs.pop3.TcpPop3Handler.startTLS(TcpPop3 Handler.java:78)
    at com.zimbra.cs.pop3.Pop3Handler.doSTLS(Pop3Handler. java:616)
    at com.zimbra.cs.pop3.Pop3Handler.processCommandInter nal(Pop3Handler.java:283)
    at com.zimbra.cs.pop3.Pop3Handler.processCommand(Pop3 Handler.java:142)
    at com.zimbra.cs.pop3.TcpPop3Handler.processCommand(T cpPop3Handler.java:48)
    at com.zimbra.cs.tcpserver.ProtocolHandler.processCon nection(ProtocolHandler.java:160)
    at com.zimbra.cs.tcpserver.ProtocolHandler.run(Protoc olHandler.java:128)
    at EDU.oswego.cs.dl.util.concurrent.PooledExecutor$Wo rker.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)

    I am running Zimbra 5.0.8 on CentOS 5. I am thinking that this is a posfix problem and it is simila to this ones

    http://www.zimbra.com/forums/install...ing-email.html
    http://www.zimbra.com/forums/adminis...exception.html

    $ zmcontrol status
    returns that everything is working fine. I'm stumped.

    Kindly help with this, I'll be eternally grateful

    Mugo
    Last edited by mugo; 09-16-2008 at 05:50 AM.

Similar Threads

  1. Unable to send email
    By carnold in forum Administrators
    Replies: 5
    Last Post: 10-31-2007, 11:32 AM
  2. cann't receive email at remote network, but send is ok
    By koolokamba in forum Administrators
    Replies: 4
    Last Post: 09-15-2007, 06:27 PM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 02:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •