Results 1 to 5 of 5

Thread: Unable to determine enabled services from ldap

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Posts
    44
    Rep Power
    7

    Default Unable to determine enabled services from ldap

    I looked around the forum and wikis but i cannot find a solution for my situation.

    I get this error when i type: zmcontrol status
    Code:
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    Host mail.domain.com
            antispam                Stopped
                    zmmtaconfigctl is not running
                    zmamavisdctl is not running
            antivirus               Stopped
                    zmmtaconfigctl is not running
                    zmamavisdctl is not running
                    zmclamdctl is not running
            imapproxy               Stopped
                    nginx is not running
                    memcached is not running
            ldap                    Stopped
            logger                  Stopped
                    logmysql.server is not running
                    zmlogswatchctl is not running
            mailbox                 Stopped
                    zmmtaconfigctl is not running
                    mysql.server is not running
                    zmmailboxdctl is not running
            mta                     Stopped
                    zmmtaconfigctl is not running
                    postfix is not running
                    saslauthd is not running
                    zmsaslauthdctl is not running
            snmp                    Stopped
                    swatch is not running
            spell                   Stopped
                    Apache not running.  No PID file found.
                    zmapachectl is not running
            stats                   Stopped
    Version Info:
    Code:
    zimbra@mail:~$ zmcontrol -v
    
    Release 5.0.9_GA_2533.UBUNTU8 UBUNTU8
    ------------------------------------------------------------
    Code:
    zimbra@mail:~$ ps -ef | grep slapd
    zimbra   29458 25632  0 13:20 pts/0    00:00:00 grep slapd
    ------------------------------------------------------------
    Code:
    zimbra@mail:~$ zmhostname
    mail.domain.com
    i have run this code from a port i found on this forum but i still get this error:
    Code:
    chown -R zimbra:zimbra /opt/zimbra
    /opt/zimbra/libexec/zmfixperms -verbose
    Code:
    zimbra@mail:~$ cat /etc/hosts
    127.0.0.1       localhost.localdomain   localhost
    192.168.1.11    mail.domain.com   mail
    
    # The following lines are desirable for IPv6 capable hosts
    ::1     ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Code:
    zimbra@mail:~$ host `hostname`
    Host mail not found: 3(NXDOMAIN)
    Code:
    zimbra@mail:~$ dig domain.com mx
    
    ; <<>> DiG 9.4.2-P1 <<>> domain.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61162
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;domain.com.              IN      MX
    
    ;; ANSWER SECTION:
    domain.com.       604800  IN      MX      10 mail.domain.com.
    
    ;; AUTHORITY SECTION:
    domain.com.       604800  IN      NS      mail.domain.com.
    
    ;; ADDITIONAL SECTION:
    mail.domain.com.  604800  IN      A       192.168.1.11
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.11#53(192.168.1.11)
    ;; WHEN: Thu Sep 18 13:33:12 2008
    ;; MSG SIZE  rcvd: 85
    i also did it with mail.domain.com
    Code:
    zimbra@mail:~$ dig mail.domain.com mx
    
    ; <<>> DiG 9.4.2-P1 <<>> mail.domain.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23081
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.domain.com.         IN      MX
    
    ;; AUTHORITY SECTION:
    domain.com.       604800  IN      SOA     mail.domain.com. admin.domain.com. 80729 604800 86400 2419200 604800
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.11#53(192.168.1.11)
    ;; WHEN: Thu Sep 18 13:36:47 2008
    ;; MSG SIZE  rcvd: 81
    Code:
    zimbra@mail:~$ dig domain.com any
    
    ; <<>> DiG 9.4.2-P1 <<>> domain.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61513
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;domain.com.              IN      ANY
    
    ;; ANSWER SECTION:
    domain.com.       604800  IN      SOA     mail.domain.com. admin.domain.com. 80729 604800 86400 2419200 604800
    domain.com.       604800  IN      NS      mail.domain.com.
    domain.com.       604800  IN      MX      10 mail.domain.com.
    domain.com.       604800  IN      A       192.168.1.11
    
    ;; ADDITIONAL SECTION:
    mail.domain.com.  604800  IN      A       192.168.1.11
    
    ;; Query time: 19 msec
    ;; SERVER: 192.168.1.11#53(192.168.1.11)
    ;; WHEN: Thu Sep 18 13:38:15 2008
    ;; MSG SIZE  rcvd: 143
    also did it with mail.domain.com
    Code:
    zimbra@mail:~$ dig mail.domain.com any
    
    ; <<>> DiG 9.4.2-P1 <<>> mail.domain.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50904
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;mail.domain.com.         IN      ANY
    
    ;; ANSWER SECTION:
    mail.domain.com.  604800  IN      A       192.168.1.11
    
    ;; AUTHORITY SECTION:
    domain.com.       604800  IN      NS      mail.domain.com.
    
    ;; Query time: 0 msec
    ;; SERVER: 192.168.1.11#53(192.168.1.11)
    ;; WHEN: Thu Sep 18 13:40:46 2008
    ;; MSG SIZE  rcvd: 69
    Code:
    zimbra@mail:~$ cat /etc/resolv.conf
    nameserver 192.168.1.11
    if theres anything else i need to por, please let me know.
    I've tried to reinstall but this still comes up.

    Previously i was running ZCS 5.0.7 on Ubuntu 7.10 then i upgraded to ubuntu 8.04 followed by an upgrade to ZCS 5.0.9

    Thank you

  2. #2
    Join Date
    Jun 2009
    Posts
    11
    Rep Power
    6

    Default ldap problem

    zmcontrol start
    Host localhost
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.

    i created touch /opt/zimbra/.zmcontrol.cache

    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    198.168.1.3 linux.hitechos.com linux

    cat /etc/resolv.conf
    nameserver 192.168.1.3
    nameserver 202.54.12.164
    nameserver 203.197.12.42

    dig linux.hitechos.com

    ; <<>> DiG 9.3.3rc2 <<>> linux.hitechos.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13047
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;linux.hitechos.com. IN A

    ;; ANSWER SECTION:
    linux.hitechos.com. 3600 IN A 192.168.1.0

    ;; AUTHORITY SECTION:
    hitechos.com. 3600 IN NS linux.hitechos.com.

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.3#53(192.168.1.3)
    ;; WHEN: Thu Jun 25 20:02:39 2009
    ;; MSG SIZE rcvd: 66


    dig hitechos.com mx

    ; <<>> DiG 9.3.3rc2 <<>> hitechos.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64965
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hitechos.com. IN MX

    ;; ANSWER SECTION:
    hitechos.com. 3600 IN MX 0 linux.hitechos.com.

    ;; AUTHORITY SECTION:
    hitechos.com. 3600 IN NS linux.hitechos.com.

    ;; ADDITIONAL SECTION:
    linux.hitechos.com. 3600 IN A 192.168.1.0

    ;; Query time: 49 msec
    ;; SERVER: 192.168.1.3#53(192.168.1.3)
    ;; WHEN: Thu Jun 25 20:03:15 2009
    ;; MSG SIZE rcvd: 82


    please help me
    Last edited by ocbineesh; 06-25-2009 at 02:03 AM.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ocbineesh View Post
    dig linux.hitechos.com
    The problem is that you are not using the domain name for your dig command, what you've used is a subdomain (it's also the FQDN of your server). The correct command to check your DNS is this:
    Code:
    dig hitechos.com mx
    dig hitechos.com any
    If that returns no A or MX record then you should create those records for that domain.

    Quote Originally Posted by ocbineesh View Post
    please help me
    This problem, and it's resolution, has been covered many times in these forums if you'd searched.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Jun 2009
    Posts
    11
    Rep Power
    6

    Default dig hitechos.com mx

    dig hitechos.com mx

    ; <<>> DiG 9.3.3rc2 <<>> hitechos.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16192
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hitechos.com. IN MX

    ;; ANSWER SECTION:
    hitechos.com. 3600 IN MX 0 linux.hitechos.com.

    ;; AUTHORITY SECTION:
    hitechos.com. 3600 IN NS linux.hitechos.com.

    ;; ADDITIONAL SECTION:
    linux.hitechos.com. 3600 IN A 192.168.1.0

    ;; Query time: 1 msec
    ;; SERVER: 192.168.1.3#53(192.168.1.3)
    ;; WHEN: Fri Jun 26 18:42:35 2009
    ;; MSG SIZE rcvd: 82

    [root@linux ~]# dig hitechos.com any

    ; <<>> DiG 9.3.3rc2 <<>> hitechos.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42322
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hitechos.com. IN ANY

    ;; ANSWER SECTION:
    hitechos.com. 3600 IN SOA linux.hitechos.com. root.linux.hitechos.com. 2 10800 3600 604800 3600
    hitechos.com. 3600 IN A 192.168.1.0
    hitechos.com. 3600 IN MX 0 linux.hitechos.com.
    hitechos.com. 3600 IN NS linux.hitechos.com.

    ;; ADDITIONAL SECTION:
    linux.hitechos.com. 3600 IN A 192.168.1.0

    ;; Query time: 28 msec
    ;; SERVER: 192.168.1.3#53(192.168.1.3)
    ;; WHEN: Fri Jun 26 18:42:58 2009
    ;; MSG SIZE rcvd: 139

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by ocbineesh View Post
    ;; ADDITIONAL SECTION:
    linux.hitechos.com. 3600 IN A 192.168.1.0
    A rather late reply to this but I guess you found out that you're using the wrong IP in the DNS records?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Replies: 48
    Last Post: 09-18-2012, 08:49 AM
  2. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 02:08 AM
  3. DNS Questions and Trouble Installing
    By smurraysb in forum Installation
    Replies: 22
    Last Post: 03-14-2008, 03:27 PM
  4. Debian - Upgrade from 4.5.6
    By magikman in forum Installation
    Replies: 1
    Last Post: 01-19-2008, 11:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •