I know this is more of a question for the postfix forum but they seem to keep blocking my subscription attempts. Anyway the emails i am tring to send are supposed to be landing on a Zimbra server so i figure i should be able to post this here at Zimbra

Hello all i need to change the outgoing port used by postfix from 25 to 325. This is just a simple standalone postfix server no Zimbra involved.

I need to do this as my isp blocks outgoing port 25. My incoming isp the location of the Zimbra server where i want my mail to arrive forwards port 325 to port 25 just for occasions like these.

I know this has been discussed many times on many lists but i cannot get any of the posted solutions to work. Maybe i am encountering a different problem??

Here is a the simple break down need to send mail out on port 325

there is a firewall that is allowing all outbound traffic. As you can see from the output of the telnet command below that i can access the email server i wish to send mail to with port 325.

telnet mx1.canmail.org 325
Connected to mx1.canmail.org.
Escape character is '^]'.
220 mx1.canmail.org ESMTP Postfix

*****I have tried changing this in master.cf but is does not work think smtpd is inbound anyway.
#smtp inet n - - - - smtpd
325 inet n - - - - smtpd

Sep 18 19:05:45 bao postfix/smtp[8072]: 767BF32092: to=<king@computerking.ca>, relay=none, delay=2113, delays=2083/0.07/30/0, dsn=4.4.1, status=deferred (connect to mx1.canmail.org[]:25: Connection timed out)

*****I have also tried this thinking this might control outbound port but it does not work
#smtp unix - - - - - smtp
325 unix - - - - - smtp

Sep 18 19:08:31 bao postfix/pickup[8172]: 12D7B32094: uid=1000 from=<c0mputerking>
Sep 18 19:08:31 bao postfix/cleanup[8190]: 12D7B32094: message-id=<20080919010831.12D7B32094@bao.computerking.ca>
Sep 18 19:08:31 bao postfix/qmgr[8174]: 12D7B32094: from=<c0mputerking@bao.computerking.ca>, size=343, nrcpt=1 (queue active)
Sep 18 19:08:31 bao postfix/qmgr[8174]: warning: connect to transport smtp: Connection refused
Sep 18 19:08:31 bao postfix/error[8192]: 12D7B32094: to=<king@computerking.ca>, relay=none, delay=0.11, delays=0.08/0.01/0/0.02, dsn=4.3.0, status=deferred (mail transport unavailable)

*****I have tried adding this to my master.cf file but always get errors in my mail.log like below
* smtp:[boa.computerking.ca]:325
fatal: /etc/postfix/master.cf: line 26: bad transport type: smtp:[boa.computerking.ca]:325


Computer King & CaN Mail - Sales Service Hosting Backup

Computer King CaNMail | Welcome to CaNMail

NEW!!! Custom Service Packages
Secure IMAP Email - Automated Remote Backups - Photo Blogs - Online Accounting Packages