Results 1 to 2 of 2

Thread: [SOLVED] zmlogprocess not working

  1. #1
    Join Date
    Oct 2005
    Posts
    34
    Rep Power
    10

    Default [SOLVED] zmlogprocess not working

    Hi,

    I've been having problems with stats because zmlogprocess is not working correctly. I have data in raw_logs but when zmlogprocess runs it does not put any data into the mta, amavis, or disk_status tables. See http://www.zimbra.com/forums/adminis...tml#post108777.

    I had a quick look at the zmlogprocess script. Here's one problem I see, in processMta there is a line:

    Code:
      my $sth = sqlExec("select distinct(postfix_qid) from raw_logs ".
        "where postfix_qid is not null and app ".
        "like 'postfix%' and id > '".$lastRowID."'");
    lastRowID is taken from the processing_history table. The value for "mta" is 3554329, but all the new rows in the raw_logs table have an id below this so the select from zmlogprocess always returns an empty table. I believe this is also the case for amavis and disk_status.

    Why is lastRowID higher than the current IDs? How do I fix it?

    I guess the question is, what, other than zmlogprocess, uses the processing_history table? And, can I just set the id's in this table to 0 to reset it all?

    Justin.
    Last edited by JustinC; 09-28-2008 at 02:21 AM.

  2. #2
    Join Date
    Oct 2005
    Posts
    34
    Rep Power
    10

    Default

    I reset all the IDs in the processing_history table to zero. zmlogprocess magically started working.

Similar Threads

  1. [SOLVED] Gal not working
    By carnold in forum Administrators
    Replies: 3
    Last Post: 07-26-2008, 06:30 AM
  2. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 12:41 PM
  3. Zimlets all not working?
    By jadestorm in forum Administrators
    Replies: 16
    Last Post: 10-28-2007, 08:25 PM
  4. Replies: 6
    Last Post: 10-10-2007, 06:11 PM
  5. User UI not working, Admin UI works
    By zpotonaator in forum Administrators
    Replies: 8
    Last Post: 08-03-2007, 05:28 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •