I am trying to customise this setting in a COS level. I have issued the command:

zmprov mc archive zimbraArchiveAccountNameTemplate ${user}@${domain}.archive
However, when I then check to see if the command work I get this:

zmprov gc archive zimbraArchiveAccountNameTemplate
# name archive
zimbraArchiveAccountNameTemplate: @.archive
Then when I try to provision a user I get this:

zmarchiveconfig enable user@domain.com
Exception in thread "main" com.zimbra.common.soap.SoapFaultException: invalid request: can't extract domain from: @.archive
at com.zimbra.common.soap.Soap12Protocol.soapFault(So ap12Protocol.java:88)
at com.zimbra.common.soap.SoapTransport.extractBodyEl ement(SoapTransport.java:245)
at com.zimbra.common.soap.SoapTransport.parseSoapResp onse(SoapTransport.java:221)
at com.zimbra.common.soap.SoapHttpTransport.invoke(So apHttpTransport.java:251)
at com.zimbra.common.soap.SoapTransport.invoke(SoapTr ansport.java:297)
at com.zimbra.common.soap.SoapTransport.invoke(SoapTr ansport.java:261)
at com.zimbra.cs.account.soap.SoapProvisioning.invoke (SoapProvisioning.java:185)
at com.zimbra.cs.archive.ArchiveSoapProvisioning.enab leArchive(ArchiveSoapProvisioning.java:61)
at com.zimbra.cs.archive.ArchiveUtil.main(ArchiveUtil .java:143)

Any ideas why my customisation does not seem to be having an effect? I also tried:

zmprov mc archive zimbraArchiveAccountNameTemplate '${user}@${domain}.archive'
and although that came up properly when I checked to see if it had been altered correctly, I still get the same error upon provisioning.

Any advice or suggestions would be welcome.

Many thanks,