Results 1 to 9 of 9

Thread: Relay for one ip cont...

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default Relay for one ip cont...

    Good Morning.

    This is continuing my thread here - http://www.zimbra.com/forums/showthread.php?t=2085 - a few weeks back.

    I successfully allowed relay from one particular ip and it is working for the user. Every time the user sends an email (any domain, gmail, yahoo, etc) it successfully gets delivered to the intended recipient.

    However, with every message sent, the user gets this message returned to him.

    Subject: Undelivered Mail Returned to Sender

    This is the Postfix program at host cmsfwd02.mx.net.

    I'm sorry to have to inform you that your message could not be be delivered to one or more recipients. It's attached below.

    The Postfix program

    <james.teeters@xxxxxxxxxxx.com>: host mx.usa.net[165.212.65.113] said:
    554
    Too many hops 33 (30 max) (in reply to end of DATA command)

    None of the hosts listed here is my host. Can anyone shed some light on this for me? Thank you.

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    When the hop count gets that high it's likely there is some sort of mail loop. Can you pull your postfix logs from a message test and also run a traceroute from your server to the destination server, and post it here. If you want to blank out names just make sure you keep the same ones together and use like xxx, yyy, zzz so we can tell which ones match up between the postfix logs, the traceroute, and the message itself.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    Thanks Kevin.

    postfix log from some messages.
    ---------------
    Mar 28 09:24:08 dmrmail01 postfix/smtpd[15672]: initializing the server-side TLS engine
    Mar 28 09:24:08 dmrmail01 postfix/smtpd[15672]: connect from unknown[xx.xx.xx.xx]
    Mar 28 09:24:09 dmrmail01 postfix/smtpd[15672]: 15EC91FA70: client=unknown[xx.xx.xx.xx], sasl_method=LOGIN, sasl_username=xxxxxx@poboxdmr.com
    Mar 28 09:24:09 dmrmail01 postfix/cleanup[15676]: 15EC91FA70: message-id=<00dd01c6528c$1185fa90$0a01010a@JTeeters>
    Mar 28 09:24:09 dmrmail01 postfix/qmgr[12664]: 15EC91FA70: from=<xxxxxxx@coldwellbanker.com>, size=3840, nrcpt=1 (queue active)
    Mar 28 09:24:09 dmrmail01 postfix/smtpd[15680]: initializing the server-side TLS engine
    Mar 28 09:24:09 dmrmail01 postfix/smtpd[15680]: connect from localhost[127.0.0.1]
    Mar 28 09:24:09 dmrmail01 postfix/smtpd[15680]: 711A21FAB9: client=localhost[127.0.0.1]
    Mar 28 09:24:09 dmrmail01 postfix/cleanup[15676]: 711A21FAB9: message-id=<00dd01c6528c$1185fa90$0a01010a@JTeeters>
    Mar 28 09:24:09 dmrmail01 postfix/qmgr[12664]: 711A21FAB9: from=<xxxxxxx@coldwellbanker.com>, size=4429, nrcpt=1 (queue active)
    Mar 28 09:24:09 dmrmail01 postfix/smtpd[15680]: disconnect from localhost[127.0.0.1]
    Mar 28 09:24:09 dmrmail01 postfix/smtp[15677]: 15EC91FA70: to=<xxxxxx@dmrcom.com>, relay=127.0.0.1[127.0.0.1], delay=0, status=sent (250 2.6.0 Ok, id=10347-07, from MTA([127.0.0.1]:10025): 250 Ok: queued as 711A21FAB9)
    Mar 28 09:24:09 dmrmail01 postfix/qmgr[12664]: 15EC91FA70: removed
    Mar 28 09:24:09 dmrmail01 postfix/smtp[15681]: 711A21FAB9: to=<xxxxxx@dmrcom.com>, relay=mail.surfsidedigital.com[70.167.112.4], delay=0, status=sent (250 OK)
    Mar 28 09:24:09 dmrmail01 postfix/qmgr[12664]: 711A21FAB9: removed
    Mar 28 09:24:11 dmrmail01 postfix/smtpd[15672]: disconnect from unknown[xx.xx.xx.xx]
    ----------------
    Mar 28 08:35:44 dmrmail01 postfix/smtpd[3658]: connect from unknown[xx.xx.xx.xx]
    Mar 28 08:35:44 dmrmail01 postfix/smtpd[3658]: 99AE91FA20: client=unknown[xx.xx.xx.xx], sasl_method=LOGIN, sasl_username=xxxxxxx@poboxdmr.com
    Mar 28 08:35:44 dmrmail01 postfix/cleanup[3664]: 99AE91FA20: message-id=<007401c65285$4e50bd40$0a01010a@JTeeters>
    Mar 28 08:35:50 dmrmail01 postfix/qmgr[12664]: 99AE91FA20: from=<xxxxxxx@coldwellbanker.com>, size=864938, nrcpt=1 (queue active)
    Mar 28 08:35:51 dmrmail01 postfix/smtpd[3663]: connect from localhost[127.0.0.1]
    Mar 28 08:35:51 dmrmail01 postfix/smtpd[3663]: 0A5911FA6F: client=localhost[127.0.0.1]
    Mar 28 08:35:51 dmrmail01 postfix/cleanup[3659]: 0A5911FA6F: message-id=<007401c65285$4e50bd40$0a01010a@JTeeters>
    Mar 28 08:35:51 dmrmail01 postfix/qmgr[12664]: 0A5911FA6F: from=<xxxxxxx@coldwellbanker.com>, size=865371, nrcpt=1 (queue active)
    Mar 28 08:35:51 dmrmail01 postfix/smtpd[3663]: disconnect from localhost[127.0.0.1]
    Mar 28 08:35:51 dmrmail01 postfix/smtp[3661]: 99AE91FA20: to=<xxxxxxx@yahoo.com>, relay=127.0.0.1[127.0.0.1], delay=7, status=sent (250 2.6.0 Ok, id=10347-06, from MTA([127.0.0.1]:10025): 250 Ok: queued as 0A5911FA6F)
    Mar 28 08:35:51 dmrmail01 postfix/qmgr[12664]: 99AE91FA20: removed
    Mar 28 08:35:53 dmrmail01 postfix/smtpd[3658]: disconnect from unknown[69.28.108.198]
    ------------------------

    Traceroute from my server to cmsfwd01.mx.net (don't know who this is)

    traceroute cmsfwd01.mx.net
    traceroute to cmsfwd01.mx.net (165.212.11.1), 30 hops max, 40 byte packets
    1 7206-1-f0-0.dmrcom.com (xx.xx.xx.xx) 1.008 ms 0.642 ms 0.920 ms
    2 xx.xx.xx.xx 2.450 ms 1.809 ms 1.405 ms
    3 lax-inetcore1.telekenex.com (69.28.97.129) 2.118 ms 1.307 ms 2.360 ms
    4 500.Serial3-2.GW3.LAX1.ALTER.NET (208.214.140.9) 3.319 ms 2.745 ms 3.059 ms
    5 122.at-1-0-0.XL1.LAX1.ALTER.NET (152.63.52.246) 3.142 ms 3.575 ms 2.608 ms
    6 0.so-7-0-0.XL1.DEN4.ALTER.NET (152.63.88.54) 41.003 ms 41.192 ms 40.448 ms
    7 177.ATM6-0.GW3.dEN4.ALTER.NET (152.63.72.69) 40.331 ms 39.959 ms 40.458 ms
    8 internap-gw.customer.ALTER.NET (157.130.162.54) 37.083 ms 36.791 ms 36.960 ms
    9 border3.ge2-0-bbnet.den.pnap.net (216.52.40.7) 37.084 ms 37.209 ms 37.059 ms
    10 * * *
    11 * * *
    12 * * *
    13 * * *
    14 * * *
    15 * * *
    16 * * *
    17 * * *
    18 * * *
    19 * * *
    20 * * *
    21 * * *
    22 * * *
    23 * * *
    24 * * *
    25 * * *
    26 * * *
    27 * * *
    28 * * *
    29 * * *
    30 * * *

    The error message that is returned to the user.
    -------
    This is the Postfix program at host cmsfwd01.mx.net.

    I'm sorry to have to inform you that your message could not be be delivered
    to one or more recipients. It's attached below.

    The Postfix program

    <xxxxxxx@coldwellbanker.com>: host mx.usa.net[165.212.65.113] said:
    554
    Too many hops 33 (30 max) (in reply to end of DATA command)

  4. #4
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    One more piece of info. I've set up relay capabilities for another ip address as well, and they relay successfully without any error message being returned to them.

    might it just be the particular customer and their mail host?

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Seems like who ever your sending too is trying to fwd' the mail to another host and it never gets there. Are you using a relay MTA at your ISP or just sending the mail out yourself? Are all the domains you host configured so their Mx record points to your server?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #6
    Join Date
    Feb 2006
    Location
    Southern California
    Posts
    49
    Rep Power
    9

    Default

    I am the ISP - hence, i am just sending mail out myself. We are providing mail relay services for a few T1 customers on a trial basis as we look at the feasability of Zimbra in a production env. I only have one domain configured on this server for now and dns (MX, etc) is pointing at my server. When you ask "Are all the domains you host configured so their Mx record points to your server?" - i hope that answers your question. I have other customers testing the relay aspect for me as well, but this is the first i've seen this problem - and only with this particular customer.

Similar Threads

  1. Replies: 32
    Last Post: 03-18-2011, 11:03 AM
  2. I got Ubuntu and Zimbra working
    By pacsteel in forum Installation
    Replies: 73
    Last Post: 06-23-2008, 11:41 AM
  3. Ability to designate an IP Address
    By Isi in forum Administrators
    Replies: 18
    Last Post: 05-22-2007, 03:45 AM
  4. Replies: 1
    Last Post: 04-13-2006, 04:47 PM
  5. SMTP Relay for particular ip's
    By DMRDave in forum Administrators
    Replies: 8
    Last Post: 03-10-2006, 03:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •