Results 1 to 5 of 5

Thread: Clamd getting stuck

  1. #1
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default Clamd getting stuck

    Running zimbra-core-4.5.10_GA_1575.FC5-20071117095155 here, as there's no Finnish translation of v5 yet, and I've the following problem..

    The clamd process gets stuck a lot. First I get an alert that mail is not going anywhere, and in "top" I can see the clamd process taking all CPU. It will never stop (at least it can run all night without getting anywhere), and it will not even die with simple kill, only kill -9 will do.

    The log looks something like this. There's nothing further after the disconnects.

    Code:
    Fri Oct 10 12:46:50 2008 -> /opt/zimbra/amavisd/tmp/amavis-20081010T123021-24644/parts/p002: HTML.Phishing.Bank-1272 FOUND
    Fri Oct 10 12:56:12 2008 -> No stats for Database check - forcing reload
    Fri Oct 10 12:56:12 2008 -> Reading databases from /opt/zimbra/clamav/db
    Fri Oct 10 12:56:44 2008 -> Database correctly reloaded (578243 signatures)
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:00:51 2008 -> Client disconnected
    Fri Oct 10 13:01:15 2008 -> Client disconnected
    Fri Oct 10 13:01:15 2008 -> Client disconnected
    Fri Oct 10 13:01:37 2008 -> Client disconnected
    Fri Oct 10 13:01:46 2008 -> Client disconnected
    Fri Oct 10 13:01:50 2008 -> Client disconnected
    Fri Oct 10 13:01:59 2008 -> Client disconnected
    Fri Oct 10 13:02:00 2008 -> Client disconnected
    Any clues?

  2. #2
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default

    Is it possible that this might have been related to the stats being broken? The stats SQL was "stuck" and I had to rebuild it with repair table use_frm, bringing it's size down from over 10 gigs to about 400m too, and since then the clamd problem has not happened?

  3. #3
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Very possible especially if the stats (MySQL) have been swallowing all your system resources.

  4. #4
    Join Date
    Jun 2006
    Posts
    34
    Rep Power
    9

    Default

    It didn't take any unusual amounts of cpu or mem, just a lot of space.

  5. #5
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Very odd indeed

Similar Threads

  1. [SOLVED] clamd won't start: malformed database
    By thenetmonkey in forum Administrators
    Replies: 5
    Last Post: 06-23-2008, 04:15 PM
  2. Clamd: ERROR: Unable to lock database directory!
    By zibra in forum Administrators
    Replies: 4
    Last Post: 03-11-2008, 11:07 AM
  3. Email Getting Stuck in Active Queue
    By soxfan in forum Administrators
    Replies: 11
    Last Post: 12-20-2006, 02:19 PM
  4. Mail stuck in queue
    By sandman67 in forum Installation
    Replies: 6
    Last Post: 10-09-2006, 12:40 AM
  5. Client gets stuck downloading images...
    By spector@zeitgeist.com in forum Users
    Replies: 5
    Last Post: 09-28-2006, 08:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •