Results 1 to 4 of 4

Thread: [SOLVED] Anybody else having issues w/new users w/5.0.10?

  1. #1
    Join Date
    Nov 2007
    Rep Power

    Question [SOLVED] Anybody else having issues w/new users w/5.0.10?

    I am wondering if anyone else is seeing anything like this...

    When trying to create a new account, I receive a message:

    Server error encountered
    Message: createAccount invalid attr value: [LDAP: error code 21 -
    objectClass: value #3 invalid per syntax] Error code:
    account.INVALID_ATTR_VALUE Method: CreateAccountRequest

    We just upgraded to 5.0.10 on Monday and this is the first time since that I had tried to create a user account. Modifying user accounts works fine, but creating new accounts fails.

    This was in the mailbox.log:

    2008-10-15 10:19:31,057 INFO [btpool0-7] [;mid=4;ip=;ua =ZimbraWebClient - FF3.0 (Mac);] soap - CreateAccountRequest
    2008-10-15 10:19:31,061 INFO [btpool0-7] [;mid=4;ip=;ua =ZimbraWebClient - FF3.0 (Mac);] SoapEngine - handler exception
    com.zimbra.cs.account.AccountServiceException: createAccount invalid attr value: [LDAP: error code 21 - objectClass: value #3 invalid per syntax]
    at com.zimbra.cs.account.AccountServiceException.INVA LID_ATTR_VALUE(
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.creat eEntry(
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Account(
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Account(
    at com.zimbra.cs.service.admin.CreateAccount.handle(C
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:268)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: ion: [LDAP: error code 21 - objectClass: value #3 invalid per syntax]; remaining name 'uid=slu,ou=people,dc=toolcase,dc=com'
    at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.jav a:2998)
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt
    at com.sun.jndi.ldap.LdapCtx.c_createSubcontext(LdapC
    at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_cre ateSubcontext(
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex t.createSubcontext( :248)
    at context(
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.creat eEntry(
    ... 33 more

  2. #2
    Join Date
    Mar 2006
    Rep Power


    Post marked solved with no solutions???

  3. #3
    Join Date
    Jul 2008
    Rep Power


    Is this an upgrade from a previous version? If so did you have some kind of samba/posix integration?

    Also what does "zmprov gacf |grep Extra" output?

  4. #4
    Join Date
    Dec 2008
    Rep Power

    Default Solution

    Okay, looks like you began the LDAP Authentication and then it broke or you stopped.

    Run these two commands as your zimbra user account on your server:

    >zmprov mcf -zimbraAccountExtraObjectClass posixAccount

    >zmprov mcf -zimbraAccountExtraObjectClass sambaSamAccount

    And that should fix it.

Similar Threads

  1. Login showing wrong users email
    By gfdos.sys in forum Administrators
    Replies: 10
    Last Post: 04-08-2008, 09:13 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 08:46 PM
  3. Need Help Troubleshooting Web Client Issues
    By soxfan in forum Administrators
    Replies: 2
    Last Post: 03-23-2007, 06:27 AM
  4. Installation review
    By npollock in forum Administrators
    Replies: 1
    Last Post: 01-14-2006, 10:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts