Results 1 to 4 of 4

Thread: [SOLVED] Anybody else having issues w/new users w/5.0.10?

  1. #1
    Join Date
    Nov 2007
    Posts
    30
    Rep Power
    7

    Question [SOLVED] Anybody else having issues w/new users w/5.0.10?

    I am wondering if anyone else is seeing anything like this...

    When trying to create a new account, I receive a message:

    Server error encountered
    -------------------------------------------
    Message: createAccount invalid attr value: [LDAP: error code 21 -
    objectClass: value #3 invalid per syntax] Error code:
    account.INVALID_ATTR_VALUE Method: CreateAccountRequest
    Details:soap:Sender



    We just upgraded to 5.0.10 on Monday and this is the first time since that I had tried to create a user account. Modifying user accounts works fine, but creating new accounts fails.



    This was in the mailbox.log:

    2008-10-15 10:19:31,057 INFO [btpool0-7] [name=rpetty@domain.com;mid=4;ip=192.168.104.209;ua =ZimbraWebClient - FF3.0 (Mac);] soap - CreateAccountRequest
    2008-10-15 10:19:31,061 INFO [btpool0-7] [name=rpetty@domain.com;mid=4;ip=192.168.104.209;ua =ZimbraWebClient - FF3.0 (Mac);] SoapEngine - handler exception
    com.zimbra.cs.account.AccountServiceException: createAccount invalid attr value: [LDAP: error code 21 - objectClass: value #3 invalid per syntax]
    ExceptionId:btpool0-7:1224087571061:673ea3e50c4d7908
    Code:account.INVALID_ATTR_VALUE
    at com.zimbra.cs.account.AccountServiceException.INVA LID_ATTR_VALUE(AccountServiceException.java:161)
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.creat eEntry(ZimbraLdapContext.java:570)
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Account(LdapProvisioning.java:790)
    at com.zimbra.cs.account.ldap.LdapProvisioning.create Account(LdapProvisioning.java:637)
    at com.zimbra.cs.service.admin.CreateAccount.handle(C reateAccount.java:58)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:411)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:268)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:189)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser vletHolder.java:487)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1093)
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA gentFilter.java:81)
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(ServletHandler.java:1084)
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se rvletHandler.java:360)
    at org.mortbay.jetty.security.SecurityHandler.handle( SecurityHandler.java:216)
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se ssionHandler.java:181)
    at org.mortbay.jetty.handler.ContextHandler.handle(Co ntextHandler.java:716)
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA ppContext.java:406)
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(ContextHandlerCollection.java:211)
    at org.mortbay.jetty.handler.HandlerCollection.handle (HandlerCollection.java:114)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(RewriteHandler.java:350)
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha ndlerWrapper.java:139)
    at org.mortbay.jetty.Server.handle(Server.java:313)
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt pConnection.java:506)
    at org.mortbay.jetty.HttpConnection$RequestHandler.co ntent(HttpConnection.java:844)
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa rser.java:211)
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec tion.java:381)
    at org.mortbay.io.nio.SelectChannelEndPoint.run(Selec tChannelEndPoint.java:396)
    at org.mortbay.thread.BoundedThreadPool$PoolThread.ru n(BoundedThreadPool.java:442)
    Caused by: javax.naming.directory.InvalidAttributeValueExcept ion: [LDAP: error code 21 - objectClass: value #3 invalid per syntax]; remaining name 'uid=slu,ou=people,dc=toolcase,dc=com'
    at com.sun.jndi.ldap.LdapCtx.mapErrorCode(LdapCtx.jav a:2998)
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt x.java:2931)
    at com.sun.jndi.ldap.LdapCtx.processReturnCode(LdapCt x.java:2737)
    at com.sun.jndi.ldap.LdapCtx.c_createSubcontext(LdapC tx.java:770)
    at com.sun.jndi.toolkit.ctx.ComponentDirContext.p_cre ateSubcontext(ComponentDirContext.java:319)
    at com.sun.jndi.toolkit.ctx.PartialCompositeDirContex t.createSubcontext(PartialCompositeDirContext.java :248)
    at javax.naming.directory.InitialDirContext.createSub context(InitialDirContext.java:183)
    at com.zimbra.cs.account.ldap.ZimbraLdapContext.creat eEntry(ZimbraLdapContext.java:562)
    ... 33 more

  2. #2
    Join Date
    Mar 2006
    Posts
    300
    Rep Power
    9

    Default

    Post marked solved with no solutions???

  3. #3
    Join Date
    Jul 2008
    Location
    openhagen
    Posts
    81
    Rep Power
    7

    Default

    Is this an upgrade from a previous version? If so did you have some kind of samba/posix integration?

    Also what does "zmprov gacf |grep Extra" output?

  4. #4
    Join Date
    Dec 2008
    Posts
    1
    Rep Power
    6

    Default Solution

    Okay, looks like you began the LDAP Authentication and then it broke or you stopped.

    Run these two commands as your zimbra user account on your server:

    >zmprov mcf -zimbraAccountExtraObjectClass posixAccount

    >zmprov mcf -zimbraAccountExtraObjectClass sambaSamAccount

    And that should fix it.

Similar Threads

  1. Login showing wrong users email
    By gfdos.sys in forum Administrators
    Replies: 10
    Last Post: 04-08-2008, 08:13 AM
  2. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  3. Need Help Troubleshooting Web Client Issues
    By soxfan in forum Administrators
    Replies: 2
    Last Post: 03-23-2007, 05:27 AM
  4. Installation review
    By npollock in forum Administrators
    Replies: 1
    Last Post: 01-14-2006, 09:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •