Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to do an only data Backup to put int different server?

  1. #1
    Join Date
    Oct 2008
    Posts
    86
    Rep Power
    7

    Unhappy How to do an only data Backup to put int different server?

    Nowbody knows to do an only data backup, to change from an opensuse to a red hat or ubuntu, from the same zimbra version, and same host in two machines.

  2. #2
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

  3. #3
    Join Date
    Oct 2008
    Posts
    86
    Rep Power
    7

    Smile I want in Open source edition

    Sorry but that url is to use in Network edition, I want to do it in Open source edition, the free edition.

  4. #4
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    Zimbra Network Edition contains a backup feature, and although itís useful, we wonít be using it in this tip.
    It should work. All you're doing is stopping the services, copying the data and reinstalling over the top.. You're not using any features of NE to do it as far as I can tell.

  5. #5
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    y@w is right, but the formal documentation of that fact is here:
    Moving ZCS to New Server - Zimbra :: Wiki

    But don't overlook that "same version" part. You can restore, for example, 4.5.9 RedHat to 4.5.9 Ubuntu, but don't try to restore to a different release--things will break! If you are wanting to upgrade do it either before or after you do the version-to-version restore.
    Cheers,

    Dan

  6. #6
    Join Date
    Oct 2008
    Posts
    86
    Rep Power
    7

    Default Im agree

    I want to migrate to the same version obviously, but the problem is the Operating System, than in one machine is opensuse and in the other is red hat, how can I migrate a zimbra users, mails.. from one to other? that is my problem, having two machines with diferent operating system, the same host and same version of zimbra.

    Thanks

  7. #7
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    That's precisely what we are trying to say. As long as you use the same numeric release, you do your migration by:

    1. Stop Zimbra
    2. make a complete copy of /opt/zimbra
    3. Install the EXACT SAME version (x.x.x) of Zimbra on your new OS, as the version that's running on your old OS, using the same hostname, ip address, etc, that the old machine had.
    4. Once that install is complete, stop Zimbra services on the new machine
    5. copy or rsync the contents of your backed up /opt/zimbra from the old machine onto /opt/zimbra in the new machine
    6. Restart Zimbra services.
    Cheers,

    Dan

  8. #8
    Join Date
    Jan 2008
    Posts
    658
    Rep Power
    8

    Default

    Here's an example of someone else doing the same thing. You haven't specified what version of ZCS you are on, but they were on 4.5.

    http://www.zimbra.com/forums/adminis...-1-ubuntu.html

  9. #9
    Join Date
    Oct 2008
    Posts
    86
    Rep Power
    7

    Default

    Rsync makes a copy like if I do cp /opt/zimbra /.../zimbra

    when I install the same version of zimbra, I rm the opt/zimbra of the new server and I put the version of the /../zimbra thats not work? inside opt/zimbra are not executables that belong to the OS. Thats my problem.

  10. #10
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    Quote Originally Posted by a.ambrosio View Post
    Rsync makes a copy like if I do cp /opt/zimbra /.../zimbra

    when I install the same version of zimbra, I rm the opt/zimbra of the new server and I put the version of the /../zimbra thats not work? inside opt/zimbra are not executables that belong to the OS. Thats my problem.
    Don't rm /opt/zimbra first. Just rsync or copy the backup contents into /opt/zimbra. That way any unique files that were needed in your new install will not be lost.
    Cheers,

    Dan

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  2. [SOLVED] Why my MTA Cross???
    By fsloke in forum Installation
    Replies: 6
    Last Post: 07-30-2008, 09:55 PM
  3. [SOLVED] Backups failing, "unable to read metadata for account"
    By smcgrath1111 in forum Administrators
    Replies: 10
    Last Post: 04-10-2008, 04:15 PM
  4. FYI: ZCS NE backup to fuse/sshfs mount, worked.
    By jagipson in forum Administrators
    Replies: 0
    Last Post: 09-28-2007, 07:37 AM
  5. Data in Outlook not syncing to zimbra server
    By brian-ccs in forum Migration
    Replies: 3
    Last Post: 03-05-2007, 08:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •