Results 1 to 7 of 7

Thread: TICImapsync - NO CAPABILITY for AUTHENATE PLAIN

  1. #1
    starcenterlr Guest

    Question TICImapsync - NO CAPABILITY for AUTHENATE PLAIN

    I'm attempting to move from a 3.x Zimbra server to a 5.0x Zimbra server, and I'm currently in the process of using Imapsync to transfer the mail from the 3.x server to the 5.x server

    My problem is that I'm running into the error:

    "Host abc.domain.org says it has NO CAPABILITY for AUTHENTICATE PLAIN"
    I did zmprov gs to check on this:

    zimbraImapCleartextLoginEnabled: TRUE
    The script worked perfect when I ran it between two virtual machines of 5.x installs, so I know there's an issue with my 3.x server, I just can't figure it out.

    IMAP Server, SSL for IMAP, and Clear Text Login are all enabled, and I just restarted the server as well to make sure those changes took place.

    The flags I'm running with imapsync are

    --authmech1 plain --authmech2 plain --authuser1 admin -password1 password --authuser2 admin --password2 password --ssl1 --port1 686 --ssl2
    Server 3.x does run on a non-standard SSL port.

    Any suggestions as to how I can make it say "has CAPABILITY for AUTHENTICATE PLAIN"?

    Any responses are great appreciated.

  2. #2
    starcenterlr Guest

    Default

    I'm thinking I may have needed to post this in the Administrators forum -- If so, is there any chance someone could move this for me?

    **EDIT**

    Wow, also, I'm not sure how I messed up the title so bad.

    Please change to " Imapsync - NO CAPABILITY for AUTHENTICATE PLAIN ", if possible.

    Thanks!
    Last edited by starcenterlr; 11-04-2008 at 09:33 AM.

  3. #3
    starcenterlr Guest

    Default

    I'm still not able to get the 3.x server to have the capability to authenticate plain.

  4. #4
    starcenterlr Guest

    Default

    Here's what comes out of zmprov gs:

    zimbraAdminPort: 7071
    zimbraFileUploadMaxSize: 8388608
    zimbraId: a3ac801e-3441-48a5-a516-8c12642dde63
    zimbraImapBindOnStartup: TRUE
    zimbraImapBindPort: 286
    zimbraImapCleartextLoginEnabled: TRUE
    zimbraImapNumThreads: 200
    zimbraImapProxyBindPort: 143
    zimbraImapSSLBindOnStartup: TRUE
    zimbraImapSSLBindPort: 686
    zimbraImapSSLProxyBindPort: 993
    zimbraImapSSLServerEnabled: TRUE
    zimbraImapServerEnabled: TRUE
    zimbraLmtpBindOnStartup: FALSE
    zimbraLmtpBindPort: 7025
    zimbraLmtpNumThreads: 20
    zimbraMailMode: mixed
    zimbraMailPort: 486
    zimbraMailSSLPort: 5742
    zimbraMessageCacheSize: 1671168
    zimbraMtaAuthEnabled: TRUE
    zimbraMtaAuthHost: mail.domain
    zimbraMtaAuthURL: https://mail.domain:5742/service/soap/
    zimbraMtaDnsLookupsEnabled: FALSE
    zimbraMtaTlsAuthOnly: TRUE
    I've tried pretty much every port, just by chance, but ended up with nothing.

    It's almost as if imapsync is pretending that my 3.x server's imap isn't using SSL.

    I had absolutely ZERO problems running imapsync between two zimbra 5.x virtual boxes.
    Last edited by starcenterlr; 11-06-2008 at 02:24 PM.

  5. #5
    starcenterlr Guest

    Default

    Apparently I don't have Capability for AUTHENTICATE LOGIN either?

    Any suggestions? I really need the AUTH PLAIN, as I don't know all the users passwords.

  6. #6
    starcenterlr Guest

    Default

    Even with IMAP SSL and ClearText authentication enabled, as shown in one of the previous posts, this is all my server comes up with when I telnet into it and run the "capability" command.

    3.x server
    * CAPABILITY IMAP4rev1 CHILDREN ID LITERAL+ LOGIN-REFERRALS NAMESPACE QUOTA UIDP LUS UNSELECT
    . OK CAPABILITY COMPLETED
    5.0.10

    * CAPABILITY IMAP4rev1 AUTH=PLAIN AUTH=X-ZIMBRA ACL BINARY CATENATE CHILDREN CONDSTORE ENABLE ESEARCH ID IDLE LIST-EXTENDED LITERAL+ LOGIN-REFERRALS MULTIAPPEND NAMESPACE QRESYNC QUOTE RIGHTS=ektx SASL-IR SEARCHRES UIDPLUS UNSELECT WITHIN
    . OK CAPABILITY completed
    So obviously, my 3.x server doesn't currently have the capability to authenticate PLAIN, so how do I add it? Everything I've read says simply enable Clear Text Login and make sure SSL and what not is enabled under the IMAP settings in the web interface.

    I'm at a loss and I really need some advice on what to do next.

  7. #7
    starcenterlr Guest

    Default

    Does Zimbra 3.x IMAP even support any of these auth methods? Does anyone know?

Similar Threads

  1. Migration from qmail to zimbra
    By ravin in forum Installation
    Replies: 16
    Last Post: 08-26-2008, 02:15 AM
  2. Replies: 1
    Last Post: 08-02-2008, 01:12 PM
  3. network edition does not have capability LOGIN??
    By jameztcc in forum Migration
    Replies: 1
    Last Post: 06-17-2007, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •