Results 1 to 2 of 2

Thread: Zimbra and apache proxy on diferent servers

Hybrid View

  1. #1
    Join Date
    Oct 2008
    Posts
    2
    Rep Power
    7

    Default Zimbra and apache proxy on diferent servers

    I have a zimbra host installed over ubuntu 8.04 server. It has only 1 nic with a private address. My network is connected to internet througt another ubuntu 8.04 server, as a gateway firewall, apache sever.
    I want to open ports 80 and 443 only to my gateway apache web server.
    I need to proxy connections to zimbra server with my apache server, using mod_proxy.
    I have followed tis article:
    Provide HTTP(s) Integration with Apache - Zimbra :: Wiki
    Using virtualservers.
    Here is my site file:
    <VirtualHost *:80>
    ServerAlias correo.*
    ProxyPass / Domain Name Registration, E-mail, Web Hosting
    ProxyPassReverse / Domain Name Registration, E-mail, Web Hosting
    ErrorLog /var/log/apache2/correo-error.log
    </VirtualHost>

    Ven i reload apache i get:
    [Sat Nov 08 13:32:31 2008] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results.

    My zimbra box internaly resolves to mail.mydomain.com.
    I would like to use externaly correo.mydomain.com or Domain Names, Shared Web Hosting and Site Design Tools - MyDomain.
    All i have read in zimbra wiki is for zimbra and apache on the same box.
    Any advice to do it with 2 boxes?
    Thanks

  2. #2
    Join Date
    Oct 2008
    Posts
    2
    Rep Power
    7

    Default

    Finaly y have configured this way:

    ProxyRequests Off
    ProxyPreserveHost On

    <Proxy *>
    Order deny,allow
    Allow from all
    </Proxy>

    ProxyPass /correo http://192.168.1.2
    ProxyPassReverse /correo http://192.168.1.2
    <Location /correo>
    Order allow,deny
    Allow from all
    </Location>


    But now, when i go to Domain Names, Shared Web Hosting and Site Design Tools - MyDomain, y get a html login page.
    If i try to log in, i get 404 error.

    Can anybody help me with this?

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. [SOLVED] Spam Being Sent Thru Server - Help Needed!
    By msf004 in forum Administrators
    Replies: 22
    Last Post: 03-14-2008, 11:11 PM
  3. Replies: 9
    Last Post: 03-01-2008, 07:21 PM
  4. Replies: 1
    Last Post: 01-02-2008, 08:31 PM
  5. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •