Results 1 to 3 of 3

Thread: [SOLVED] Messages stuck in user_root folder

Hybrid View

  1. #1
    Join Date
    Oct 2007
    Posts
    8
    Rep Power
    8

    Default [SOLVED] Messages stuck in user_root folder

    I have a user who tried to import a PST file using the Outlook File/Import functionality. The PST in question had most of its messages located in the root folder. As such, Outlook dutifully uploaded those messages into the Zimbra USER_ROOT (/) folder. The only reason I even noticed this is because Outlook (Zimbra connector) appeared to be having troubles importing messages with X.500 style addresses.

    Anyway, these messages are basically invisible to this user. I've tried mounting the user's folder via the DAV interface, but the messages themselves are not exposed this way. I've also tried mounting this user's folder into my hierarchy and looking at it with IMAP, but it appears that Zimbra is showing the user's root folder as unable to contain messages (I forget the exact IMAP semantic for this). With the user's full mailbox mounted inside my folder list, I *can* see the messages in the USER_ROOT folder in the Web UI. This is the only way I've been able to see them so far. zmmailbox doesn't even seem to have what I'm looking for. All I need to do is clear out *all* items from, but *only* from the USER_ROOT folder. There are about 5K messages in there from the import, so going through them via the Web UI would be rather slow.

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    Code:
    zmsoap -z -m user@domain.com -v -e FolderActionRequest/action op=empty id=1 recursive=false
    (zmjava com.zimbra.common.soap.SoapCommandUtil got revamped into zmsoap in 5.0.7)
    Vote for Bug 17144 - RFE: Subfolder Empty should be optional to add that to zmmailbox.

  3. #3
    Join Date
    Oct 2007
    Posts
    8
    Rep Power
    8

    Default Excellent!

    Quote Originally Posted by mmorse View Post
    Code:
    zmsoap -z -m user@domain.com -v -e FolderActionRequest/action op=empty id=1 recursive=false
    (zmjava com.zimbra.common.soap.SoapCommandUtil got revamped into zmsoap in 5.0.7)
    Vote for Bug 17144 - RFE: Subfolder Empty should be optional to add that to zmmailbox.
    Thanks! That's exactly what I was looking for. I had played with zmmailbox and noticed that it's emptyFolder command deleted subfolders too, which I couldn't have. And I did vote for that bug...

Similar Threads

  1. [SOLVED] Re-creating the spam training e-mail account
    By richard-hdd in forum Administrators
    Replies: 21
    Last Post: 03-20-2012, 08:34 AM
  2. Zimbra + Funambol Sync4j Code
    By KevinH in forum Mobility
    Replies: 563
    Last Post: 01-16-2010, 02:20 AM
  3. .pst migration issues
    By jimklein in forum Migration
    Replies: 13
    Last Post: 02-16-2009, 01:55 AM
  4. Error when Using Outlook PST Importer
    By chh in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 01-19-2009, 05:20 AM
  5. Replies: 3
    Last Post: 08-11-2007, 01:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •