Results 1 to 7 of 7

Thread: Moving Zimbra to a different platform

  1. #1
    Join Date
    May 2008
    Rep Power

    Default Moving Zimbra to a different platform

    I am considering moving my Zimbra installation from OpenSUSE 10 to Ubuntu.

    is there any documentation on how to do this?

  2. #2
    Join Date
    May 2006
    Rep Power


    Moving ZCS to Another Server » Zimbra :: Blog (note how the ./ -s is used in step 3)

    If changing architecture (x86 vs x86_64) have a read of Exporting and Importing Zimbra LDAP Data » Zimbra :: Blog (I know you're not NE but for those running across this later here's another article: Network Edition: Moving from 32-bit to 64-bit Server - Zimbra :: Wiki)

  3. #3
    Join Date
    May 2008
    Rep Power


    I followed the instructions. But I am getting the following error:

    Setting defaults...done.
    Setting defaults from existing config...done.
    Checking for port conflicts
    Setting defaults from ldap...done.
    is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/ line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/ line 30.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/ line 991.

    I have checked, and I do have Scalar::Util. Per another thread I ran the following bit of perl code:
    use lib "/opt/zimbra/libexec";
    use lib "/opt/zimbra/libexec/scripts";
    use lib "/opt/zimbra/zimbramon/mrtg/lib/mrtg2";
    use lib "/opt/zimbra/zimbramon/lib";
    use lib "/opt/zimbra/zimbramon/lib/Zimbra";
    use Scalar::Util qw/dualvar/;

    And it completed without error.

    So, I think I am close, any ideas on how to resolve this?

    I am on Ubuntu LTS 8.04 (moving from openSUSE 10)

  4. #4
    Join Date
    Nov 2008
    Rep Power



    Which Zimbra Release you are using it on ubuntu 8.04? I'm using this: with the instrucation as mmorse provided and I moved the zimbra to 3 different servers without any problems.

    This is a short document handled by me to move zimbra from server to server (Same OS Same ZCS version)

    # Backing Up
    $ As zimbra: zmcontrol stop
    $ As root: ps aux | grep zimbra (make sure everything’s stopped)
    $ As root: rsync -avr /opt/zimbra /mnt/migration (this may take a while)
    # Create a "dummy" Install Then Remove It
    $ As root: Run the installer with the -s option: ./ -s
    $ As root: Remove the dummy install: rm -rf /opt/zimbra
    # Mount Your Backup HD, rsync, and Install
    $ As root: rsync -avr /mnt/migration/zimbra /opt/
    $ As root: chown -R zimbra:zimbra /opt/zimbra
    $ As root: run zmfixperms located in /opt/zimbra/libexec
    $ As root: rerun the installer without the -s option (It will detect ZCS already installed, and ask if you want to upgrade. Select Yes)
    # If the mailbox mysql.server is not running Try initializing mysql by hand:
    $ As zimbra: /opt/zimbra/libexec/zmmyinit
    # If you couldn't get the mail queue from the admin consol
    $ As zimbra: zmsshkeygen
    $ As zimbra: zmupdateauthkeys
    Last edited by snake_eyes; 12-30-2008 at 09:45 PM.

  5. #5
    Join Date
    May 2008
    Rep Power


    Yep, that's the one I am using, and that is exactly the process I used.

    I suspect that the problem is the difference in platforms from my source to my destination. Since it appears to not be using the perl libraries on my machine.

    My installation has two directories in /opt/zimbra/zimbramon/lib (i486-linux-gnu-thread-multi & i586-linux-thread-multi) which both appear to have the proper auto libraries.

    Any other ideas? I am pretty much dead in the water...

  6. #6
    Join Date
    May 2007
    Rep Power


    The problem with the technique you are using is that it keeps around the perl libraries that were built on a different platform, which is where the incompatibility is coming from. After you rsync over /opt/zimbra, remove the old /opt/zimbra/zimbramon/lib directory, before re-running the installer for the correct platform. That way, the correct perl libraries will get installed when it reinstalls zimbra-core.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    Zimbra :: the leader in open source messaging and collaboration

  7. #7
    Join Date
    May 2008
    Rep Power


    Perfect. Worked like a champ.


Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. slapd message error
    By smoke in forum Administrators
    Replies: 7
    Last Post: 04-27-2008, 03:23 PM
  3. /tmp filling
    By Nutz in forum Administrators
    Replies: 8
    Last Post: 02-22-2008, 01:00 AM
  4. zmperditionctl start asking for password
    By k7sle in forum Administrators
    Replies: 32
    Last Post: 02-20-2008, 10:13 AM
  5. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts