Results 1 to 2 of 2

Thread: Problem Accessing via Squirrelmail (with solution)

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    9

    Default Problem Accessing via Squirrelmail (with solution)

    Howdy,

    This was initially a request for help, until I managed to solve it while typing out this message :-) Now, maybe it'll be able to help someone else.

    Some of our users want to be able to access the IMAP data via other clients, such as squirrelmail (don't ask :-)

    That seems simple enough, and worked fine until we actually tried accessing an account with mail in it. Now that we've migrated mail to this account, we're receiving the following error when attempting to view the Inbox in squirrelmail:

    Code:
    ERROR : Bad or malformed request.
    Query: SORT (ARRIVAL) ISO-8859-1 ALL
    Server responded: parse error: command not implemented
    I had also received "parse error: command not permitted with UID" at one point.

    The problem is the sort... which doesn't seem to currently be supported by Zimbra.

    Squirrelmail offers a number of config options that can be altered in it's config.php (on RedHat/CentOS systems, this is in /etc/squirrelmail/config.php).

    In there, is an option named "allow_server_sort", which by default, is "true".

    Simply change it to "false" to get things working.

    Have fun :-)
    -Eric

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Just for the record.

    > Does Zimbra support IMAP SORT?

    No! And Squirrelmail is a BAD CLIENT for not looking at the CAPABILITY response, realizing that SORT isn't supported, and not using it.

    If supporting IMAP SORT this is a priority, please file a bug so we can track it. We may not support all the SORT variants, but we can *probably* handle a few.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. Replies: 10
    Last Post: 02-17-2007, 05:02 PM
  2. Problem Accessing Web Admin Console
    By PimpDaDdy in forum Administrators
    Replies: 2
    Last Post: 01-27-2007, 03:25 PM
  3. strange MTA Relay Problem
    By pfuschi in forum Installation
    Replies: 0
    Last Post: 10-31-2006, 10:51 AM
  4. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-28-2006, 11:36 PM
  5. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 10:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •