Results 1 to 3 of 3

Thread: still cannot resolve "system failure: exception during auth"

  1. #1
    Join Date
    Nov 2008
    Rep Power

    Default still cannot resolve "system failure: exception during auth"

    I've been combing the forums for days trying to get this resolved. I get this common error when trying to manage/view certificates or mail queue status in zimbraAdmin:

    Message: system failure: exception during auth {RemoteManager:>} Error code: service.FAILURE Method: GetCertRequest Details:soap:Receiver
    I see from the archives that this is a very FAQ, and is usually resolved by checking sshd and key setup. I've done all that and verified that I've got it all correct. sshd is running on port 22, keys are generated and in place. Here's the results from testing:

    $ ssh -vi ~/.ssh/zimbra_identity -o strictHostKeyChecking=no -p 22
    OpenSSH_4.7p1 Debian-8ubuntu1.2, OpenSSL 0.9.8g 19 Oct 2007
    debug1: Reading configuration data /etc/ssh/ssh_config
    debug1: Applying options for *
    debug1: Connecting to [] port 22.
    debug1: Connection established.
    debug1: identity file .ssh/zimbra_identity type 2
    debug1: Remote protocol version 2.0, remote software version OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: match: OpenSSH_4.7p1 Debian-8ubuntu1.2 pat OpenSSH*
    debug1: Enabling compatibility mode for protocol 2.0
    debug1: Local version string SSH-2.0-OpenSSH_4.7p1 Debian-8ubuntu1.2
    debug1: SSH2_MSG_KEXINIT sent
    debug1: SSH2_MSG_KEXINIT received
    debug1: kex: server->client aes128-cbc hmac-md5 none
    debug1: kex: client->server aes128-cbc hmac-md5 none
    debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
    debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
    debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
    debug1: Host '' is known and matches the RSA host key.
    debug1: Found key in /opt/zimbra/.ssh/known_hosts:1
    debug1: ssh_rsa_verify: signature correct
    debug1: SSH2_MSG_NEWKEYS sent
    debug1: expecting SSH2_MSG_NEWKEYS
    debug1: SSH2_MSG_NEWKEYS received
    debug1: SSH2_MSG_SERVICE_REQUEST sent
    debug1: SSH2_MSG_SERVICE_ACCEPT received
    debug1: Authentications that can continue: publickey,keyboard-interactive
    debug1: Next authentication method: publickey
    debug1: Offering public key: .ssh/zimbra_identity
    debug1: Remote: Forced command: /opt/zimbra/libexec/zmrcd
    debug1: Server accepts key: pkalg ssh-dss blen 434
    debug1: read PEM private key done: type DSA
    debug1: Remote: Forced command: /opt/zimbra/libexec/zmrcd
    Connection closed by <myhost_ip>
    I've gone through the wiki page on Mail Queue Monitoring. Still no luck.

    SElinux/apparmor services are disabled. Host machine is running Ubuntu 8.04.1 LTS, kernel 2.6.24-21, zcs version is 5.0.10_GA_2638.UBUNTU8.20081003052843. I'm running zimbraAdmin from a host that is inside my firewall, along with the zimbra host.

    The zimbra host machine is using ldap+krb5 auth against my AD server, but the zimbra account is a local service account. Whenever I "su - zimbra" in a shell, I get "su: Authentication failure (Ignored)", and still get a shell. Running cronjobs as zimbra user also raises lots of warnings in my logs, but still seem to run.

    So what else am I missing? All archive threads seem to point in the same direction, but are not helpful to my case. I have got server status and statistics to work after running some of the logging utils manually. It's only these last two that are returning errors for me.

    Any suggestions are appreciated.


  2. #2
    Join Date
    Feb 2009
    Rep Power


    I had the same problem running on Ubuntu 8.0.4 LTS too. I have tried the solutions at Mail Queue Monitoring - Zimbra :: Wiki but the problem still remain.

    However in my case, the debug1 message show that connecting to port 22 is refused. How do I check if our port 22 is blocked? Any advise?

  3. #3
    Join Date
    Feb 2009
    Rep Power


    I had two interfaces on my machine, after installation and configuration, I did minor tuning of my server and make the ssh instance stick with one of the backend interface. When I started having the same issue I rollback the changes I did with ssh instance, and the issue was resolved. Check the settings of your firewall and stuff like that.

Similar Threads

  1. LDAP crashing / repeated failure
    By geterdone in forum Administrators
    Replies: 3
    Last Post: 08-31-2010, 01:11 AM
  2. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  3. Replies: 8
    Last Post: 10-19-2008, 09:52 AM
  4. Replies: 4
    Last Post: 08-04-2008, 06:17 PM
  5. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 06:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts