Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Help I cant send mail

  1. #1
    Join Date
    Feb 2006
    Posts
    28
    Rep Power
    9

    Default Help I cant send mail

    ok I can receive mail to both domains just fine. However I cant send mail out. here is some output of commands

    [root@mail ~]# host `hostname`
    mail.graystarr.com has address 66.29.169.139

    [root@mail ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    192.168.20.10 mail.graystarr.com mail

    [root@mail ~]# cat /etc/resolv.conf
    search graystarr.com
    nameserver 76.74.236.21
    nameserver 192.168.20.1

    [root@mail ~]# dig nuendorocks.com mx

    ; <<>> DiG 9.2.4 <<>> nuendorocks.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 60149
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;nuendorocks.com. IN MX

    ;; ANSWER SECTION:
    nuendorocks.com. 7200 IN MX 0 mail.nuendorocks.com.

    ;; Query time: 91 msec
    ;; SERVER: 192.168.20.1#53(192.168.20.1)
    ;; WHEN: Tue Nov 25 09:46:35 2008
    ;; MSG SIZE rcvd: 54

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    As your server is on a private IP, hence the host command returns your external IP, you will need to setup a Split DNS - Zimbra :: Wiki architecture.

  3. #3
    Join Date
    Feb 2006
    Posts
    28
    Rep Power
    9

    Default

    ok I have that setup but it doesnt seem like like its working. what do you need to look at to help me out?
    cat /etc/named.conf

    options {
    directory "/var/named";
    dump-file "/var/named/data/cache_dump.db";
    statistics-file "/var/named/data/named_stats.txt";
    forwarders { 212.139.132.70; 212.139.132.102;
    };
    include "/etc/rndc.key";
    // We are the master server for mail.graystarr.com
    zone "graystarr.com" {
    type master;
    file "db.mail.graystarr.com";
    };
    zone "0.0.127.in-addr.arpa"{
    type master;
    file "named.local";
    allow-update { none; };
    };

    [root@mail ~]# cat /var/named/db.mail.graystarr.com
    ;
    ; Addresses and other host information.
    ;
    @ IN SOA mail.graystarr.com. hostmaster.mail.graystarr.com. (
    10118 ; Serial
    43200 ; Refresh
    3600 ; Retry
    3600000 ; Expire
    2592000 ) ; Minimum
    ; Define the nameservers and the mail servers
    IN NS 192.168.20.10
    IN A 192.168.20.10
    IN MX 10 mail.graystarr.com.

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    You will need to change your /etc/resolv.conf
    Code:
    search graystarr.com
    nameserver 192.168.20.10

  5. #5
    Join Date
    Feb 2006
    Posts
    28
    Rep Power
    9

    Default

    ok after changing the resolv.conf i get this

    [root@mail ~]# host `hostname`
    Host mail.graystarr.com not found: 2(SERVFAIL)
    [root@mail ~]#

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    ok can you resolve any other domains ?
    Code:
    dig zimbra.com mx
    if not then has BIND actually been started ? Also check /var/log/messages for any errors from when BIND starts.

  7. #7
    Join Date
    Feb 2006
    Posts
    28
    Rep Power
    9

    Default

    ~]# dig zimbra.com mx

    ; <<>> DiG 9.2.4 <<>> zimbra.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34904
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 5, ADDITIONAL: 3

    ;; QUESTION SECTION:
    ;zimbra.com. IN MX

    ;; ANSWER SECTION:
    zimbra.com. 7200 IN MX 15 mta01.zimbra.com.
    zimbra.com. 7200 IN MX 5 mta03.zimbra.com.
    zimbra.com. 7200 IN MX 10 mta02.zimbra.com.

    ;; AUTHORITY SECTION:
    zimbra.com. 172800 IN NS ns3.yahoo.com.
    zimbra.com. 172800 IN NS ns4.yahoo.com.
    zimbra.com. 172800 IN NS ns5.yahoo.com.
    zimbra.com. 172800 IN NS ns1.yahoo.com.
    zimbra.com. 172800 IN NS ns2.yahoo.com.

    ;; ADDITIONAL SECTION:
    mta03.zimbra.com. 7200 IN A 66.163.172.82
    mta02.zimbra.com. 7200 IN A 207.126.229.144
    mta01.zimbra.com. 7200 IN A 207.126.229.143

    ;; Query time: 126 msec
    ;; SERVER: 192.168.20.10#53(192.168.20.10)
    ;; WHEN: Tue Nov 25 11:21:28 2008
    ;; MSG SIZE rcvd: 238

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Your db.mail.graystarr.com is wrong, you need to change the IN A entry to
    Code:
    mail IN A 192.168.20.10
    or if you want graystarr.com to resolve aswell use
    Code:
    IN A 192.168.20.10
    mail IN A 192.168.20.10
    and then reload BIND.

  9. #9
    Join Date
    Feb 2006
    Posts
    28
    Rep Power
    9

    Default

    ok you mean like this?

    [root@mail ~]# cat /var/named/db.mail.graystarr.com
    ;
    ; Addresses and other host information.
    ;
    @ IN SOA mail.graystarr.com. hostmaster.mail.graystarr.com. (
    10118 ; Serial
    43200 ; Refresh
    3600 ; Retry
    3600000 ; Expire
    2592000 ) ; Minimum
    ; Define the nameservers and the mail servers
    IN A 192.168.20.10
    mail IN A 192.168.20.10

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Code:
    @ IN SOA mail.graystarr.com. hostmaster.mail.graystarr.com. (
    10118 ; Serial
    43200 ; Refresh
    3600 ; Retry
    3600000 ; Expire
    2592000 ) ; Minimum
    ; Define the nameservers and the mail servers
    IN NS 192.168.20.10
    IN MX 10 mail
    IN A 192.168.20.10
    mail IN A 192.168.20.10

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. zmamavisdctl stopped and won't restart
    By alto in forum Installation
    Replies: 2
    Last Post: 04-18-2008, 12:41 AM
  3. [SOLVED] Upgraded to 5.0 OSS - Sendmail Problem
    By Chewie71 in forum Installation
    Replies: 11
    Last Post: 12-28-2007, 06:07 PM
  4. Issues...
    By timothyalangorman in forum Administrators
    Replies: 3
    Last Post: 11-19-2007, 09:43 AM
  5. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •