Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: Tomcat personnal php webapp

  1. #21
    Join Date
    May 2007
    Rep Power


    Quote Originally Posted by dzed View Post
    Everything is working

    Thanks a lot Phoenix, to point me in the right/easyest direction.
    Thanks also goes to Amitbapat.

    If anyone need it, I past the way to do what i have done here :

    I am using a Debian Sarge.

    First of all, change zimbraMailPort and restart zimbra so our apache can listen on 80, do it like this :

    zmprov ms zimbraMailPort 81
    /etc/init.d/zimbra restart

    Then, install your prefered apache version (1.3 / 2) and add the proxy module :

    for apache 1.3 :
    echo "LoadModule proxy_module /usr/lib/apache/1.3/" >> /etc/apache/modules.conf
    apachectl restart

    for apache 2 :
    ln -s /etc/apache2/mods-available/proxy.load /etc/apache2/mods-enabled/proxy.load
    ln -s /etc/apache2/mods-available/proxy.conf /etc/apache2/mods-enabled/proxy.conf
    /etc/init.d/apache2 restart

    Now we can add our virtualhosts.

    for apache 1.3, go into /etc/apache/conf.d/ and create/edit vhosts.conf :
    [for apache 2 go into /etc/apache2/conf.d/]
    NameVirtualHost *:80

    <VirtualHost *:80>
    DocumentRoot /var/www/myweb
    ErrorLog /var/log/apache/myweb-error.log
    CustomLog /var/log/apache/myweb-access.log common

    <VirtualHost *:80>
    ProxyPass /
    ProxyPassReverse /
    ErrorLog /var/log/apache/zimbra-error.log
    CustomLog /var/log/apache/zimbra-access.log common

    Almost done.
    Restart everythings.
    Test your new hosts.
    Enjoy ZIMBRA

    When I try to restart Apache (/etc/init.d/apache2 restart) I get the following error message:

    Forcing reload of web server (apache2)...httpd (pid 26315) not running
    (98) Address already in use: make_sock: could not bind to address [::]:81
    (98) Address already in use: make_sock: could not bind to address
    no listening sockets available, shuting down
    Unable to open logs

    Anyone knows what is missing?

  2. #22
    Join Date
    Dec 2007
    Rep Power


    Quote Originally Posted by dijichi2 View Post
    comment out zimbra entries in /etc/ run 'ldconfig'. start apache. uncomment zimbra entries in run zimbra. you can do this in the apache init script. fwiw I haven't seemed to have to do this with recent zimbra releases, sure you've got latest release?
    But I dont have those entries in my
    Im using 5.0 RC2 Ubuntu6 release.

Similar Threads

  1. Running tomcat after installation(solved)
    By mildred in forum Installation
    Replies: 0
    Last Post: 04-23-2007, 09:26 AM
  2. tomcat not running / postfix/postqueue errors
    By seravitae in forum Installation
    Replies: 7
    Last Post: 03-10-2007, 08:18 PM
  3. tomcat - macosx install - please help
    By gmsmith in forum Installation
    Replies: 3
    Last Post: 04-19-2006, 01:30 PM
  4. Replies: 2
    Last Post: 03-10-2006, 03:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts