Results 1 to 8 of 8

Thread: [SOLVED] Redirecting all http requests to https - Please help!

  1. #1
    Join Date
    Nov 2008
    Posts
    78
    Rep Power
    6

    Default [SOLVED] Redirecting all http requests to https - Please help!

    Hi!


    I have installed a comodo.com SSL certificate. I can see it is installed correctly in the admin UI. When I login to mydomain.com:443 I get this message from Firefox: Firefox can't establish a connection to the server at mydomain.com:443.

    My goal is to redirect all port 80 requests over to a secure connection: https://mydomain.com. How is this accomplished?


    Knut

  2. #2
    Join Date
    Jul 2007
    Location
    San Jose, CA
    Posts
    1,027
    Rep Power
    10

    Default

    This wiki is half your answer:
    CLI zmtlsctl to set Web Server Mode - Zimbra :: Wiki

    As to getting the http requests to redirect to https and stay there, I can't find anything for ZCS 5, only 4.x. Perhaps other users can fill in the gaps. . .
    Cheers,

    Dan

  3. #3
    Join Date
    Nov 2008
    Posts
    78
    Rep Power
    6

    Default

    Quote Originally Posted by dwmtractor View Post
    This wiki is half your answer:
    CLI zmtlsctl to set Web Server Mode - Zimbra :: Wiki

    As to getting the http requests to redirect to https and stay there, I can't find anything for ZCS 5, only 4.x. Perhaps other users can fill in the gaps. . .
    Thank you for the reply! I run "zmtlsctl https" logged on as "zimbra" threw SSH and did a reboot. I can know logg inn using https using my Comodo SSL sertificate

    But I really need to forward all trafikk from port 80(http) to 443(https)! This will be much easier for my customers. Then they can just type domain.com instead of https://domain.com


    Knut

  4. #4
    Join Date
    Nov 2008
    Posts
    78
    Rep Power
    6

    Default

    I've done some research in the old archives. In earlier versions of Zimbra there where a file: /opt/zimbra/tomcat/webapps/zimbra/public/Login.jsp where you could change the value "initMode=" + currentProto" to initMode=https". This was the solution to redirect http to https.

    This file is probably still in use somewhere. An other solution was to modefi IP Tables, I don't know how to configure this, to advanced for me without a guide. A third method was to place an .xml file in the port 80 path that redirected the page to 443.

    Anyone???

  5. #5
    Join Date
    Feb 2007
    Location
    Portland, OR
    Posts
    1,147
    Rep Power
    10

    Default

    Try reading the Wiki page more carefully next time:
    mixed - If the user goes to http:// it will redirect to https:// for the login only, then will revert to http:// for normal session traffic. If they browse to https:// then they will stay https://
    redirect - like mixed, if the user goes to http:// it will redirect to https:// but they will stay https:// for their entire session.
    Code:
    zmtlsctl redirect
    Hope that solves your issue.

    Edit: I should take my own advice Note that the redirect command is only available in zcs 5+ so this will not work if your server is still using a 4.5.x build

  6. #6
    Join Date
    Nov 2008
    Posts
    78
    Rep Power
    6

    Default

    Quote Originally Posted by ArcaneMagus View Post
    Try reading the Wiki page more carefully next time:

    Code:
    zmtlsctl redirect
    Hope that solves your issue.

    Edit: I should take my own advice Note that the redirect command is only available in zcs 5+ so this will not work if your server is still using a 4.5.x build
    Thank you so much, I overlooked this one It did the job perfectly!

  7. #7
    Join Date
    Oct 2007
    Posts
    54
    Rep Power
    7

    Default

    Better check this out before relying on 'redirect'

    http://www.zimbra.com/forums/adminis...g-non-ssl.html

  8. #8
    Join Date
    May 2009
    Posts
    2
    Rep Power
    6

    Default Recent 5.x versions slightly buggy

    If anyone has trouble on a new installation with going straight to https only:
    zmtlsctl https
    ...where it doesn't seem to do a darn thing and stays on http even though all the settings appear to have changed properly and you've restarted services, rebooted blah, blah, then try doing a:
    zmtlsctl redirect
    ...and a zmcontrol stop/start, then go ahead and try the:
    zmtlsctl https
    ...again followed by another zmcontrol stop/start - it will work this time!!

Similar Threads

  1. Replies: 1
    Last Post: 09-02-2008, 11:31 PM
  2. Replies: 2
    Last Post: 01-18-2007, 02:05 PM
  3. Switching From Https to Http Protocol in JSP
    By Shyam in forum Administrators
    Replies: 1
    Last Post: 10-10-2006, 06:58 AM
  4. Changing browser access from HTTPS to Both HTTPS and HTTP
    By kelley.ch in forum Administrators
    Replies: 5
    Last Post: 09-18-2006, 11:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •