Results 1 to 4 of 4

Thread: Empty trash error on webmail

  1. #1
    Join Date
    Jul 2008
    Rep Power

    Default Empty trash error on webmail

    When i try to clean my trash folder i always receive this message (webmail).

    A network service error has occurred. msg: system failure: marking deletions for conversations crossing folder 1777
    code: service.FAILURE
    method: FolderActionRequest
    detail: soap:Receiver
    trace: btpool0-1145:1229359924943:7274c21977433427

    --- mailbox.log ---------------------------

    com.zimbra.common.service.ServiceException: system failure: marking deletions for conversations crossing folder 1777
    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.cs.db.DbMailItem.markDeletionTargets(Db
    at com.zimbra.cs.mailbox.Folder.propagateDeletion(Fol
    at com.zimbra.cs.mailbox.MailItem.delete(MailItem.jav a:2391)
    at com.zimbra.cs.mailbox.MailItem.delete(MailItem.jav a:2372)
    at com.zimbra.cs.mailbox.Folder.deleteSingleFolder(Fo
    at com.zimbra.cs.mailbox.Folder.empty( )
    at com.zimbra.cs.mailbox.Mailbox.emptyFolder(Mailbox. java:6250)
    at com.zimbra.cs.service.mail.FolderAction.handleFold er(
    at com.zimbra.cs.service.mail.FolderAction.handle(Fol
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:288)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:167)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: java.sql.SQLException: Got error 28 from storage engine

    Query being executed when exception was thrown:

    com.mysql.jdbc.ServerPreparedStatement[44443] - UPDATE mboxgroup21.mail_item, (SELECT parent_id pid, COUNT(*) count FROM mboxgroup21.mail_item WHERE mailbox_id = 1221 AND folder_id = 1777 AND parent_id IS NOT NULL GROUP BY parent_id) AS x SET size = size - count, metadata = NULL, mod_metadata = 3724, change_date = 1229357837 WHERE mailbox_id = 1221 AND id = pid AND type = 4
    at com.mysql.jdbc.SQLError.createSQLException(SQLErro
    at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.ja va:2870)
    at com.mysql.jdbc.MysqlIO.sendCommand( 73)
    at com.mysql.jdbc.ServerPreparedStatement.serverExecu te(
    at com.mysql.jdbc.ServerPreparedStatement.executeInte rnal(
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre
    at com.mysql.jdbc.PreparedStatement.executeUpdate(Pre
    at org.apache.commons.dbcp.DelegatingPreparedStatemen t.executeUpdate( 33)
    at com.zimbra.cs.db.DbMailItem.markDeletionTargets(Db
    ... 38 more

    I'm still trying to figure out the problem.


  2. #2
    Join Date
    Sep 2005
    Rep Power


    any errors in the mysql error log? does this persist across a restart? I've never seen that "marking deletions for conversations crossing folder 1777" - what operation are you performing, empty trash? Trash shouldn't be folder 1777 - is there a folder IN your trash?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    Join Date
    Sep 2005
    Rep Power


    $ perror 28
    OS error code  28:  No space left on device
    Gotta love MySQL error reporting.

  4. #4
    Join Date
    Feb 2009
    Rep Power


    I haved the same problem.

    In my case i mounted in /tmp a smbfs directory and zimbra failed to write into /tmp directory and caused this fail. When i dismount /tmp all run ok.

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. [SOLVED] scheduled empty trash emtpy junk for users
    By jason in forum Administrators
    Replies: 10
    Last Post: 04-07-2009, 12:13 PM
  3. Replies: 6
    Last Post: 04-28-2008, 08:25 AM
  4. Disable Empty Trash?
    By jdanda in forum Users
    Replies: 2
    Last Post: 07-20-2007, 04:47 AM
  5. Empty trash folder function configuration
    By fmodola in forum Users
    Replies: 7
    Last Post: 04-07-2006, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts