Results 1 to 8 of 8

Thread: Mail deferred with Connection timed out

  1. #1
    Join Date
    Dec 2007
    Location
    Hungary
    Posts
    76
    Rep Power
    8

    Default Mail deferred with Connection timed out

    Hi,

    I recently setup another server with Zimbra (this time a FOSS version). Everything went smooth. The server can receive email without any trouble. When trying to send however I get the following error on the web client:

    The email is queued in the mailserver and never gets delivered. I am trying to send to a gmail account.


    Looking at the logs I get this message:

    Dec 21 15:22:31 mail postfix/smtpd[28445]: connect from mail.servername.com[XXX.XXX.XXX.XXX]
    Dec 21 15:22:31 mail postfix/smtpd[28445]: B5CFC6A702EE: client=mail.servername.com[XXX.XXX.XXX.XXX]
    Dec 21 15:22:31 mail postfix/cleanup[28448]: B5CFC6A702EE: message-id=<1901058934.351229869351589.JavaMail.root@mail. servername.com>
    Dec 21 15:22:31 mail postfix/qmgr[18000]: B5CFC6A702EE: from=<mkalman@servername.com>, size=1195, nrcpt=1 (queue active)
    Dec 21 15:22:31 mail postfix/smtpd[28445]: disconnect from mail.servername.com[XXX.XXX.XXX.XXX]
    Dec 21 15:22:31 mail amavis[18345]: (18345-01) ESMTP::10024 /opt/zimbra/data/amavisd/tmp/amavis-20081221T152231-18345: <mkalman@servername.com> -> <miklos.kalman@gmail.com> SIZE=1195 Received: from mail.servername.com ([127.0.0.1]) by localhost (mail.servername.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP for <miklos.kalman@gmail.com>; Sun, 21 Dec 2008 15:22:31 +0100 (CET)
    Dec 21 15:22:31 mail amavis[18345]: (18345-01) Checking: JAcxpmm3I8gW [XXX.XXX.XXX.XXX] <mkalman@servername.com> -> <miklos.kalman@gmail.com>
    Dec 21 15:22:31 mail clamd[4414]: SelfCheck: Database status OK.
    Dec 21 15:22:32 mail postfix/smtpd[28452]: connect from localhost.localdomain[127.0.0.1]
    Dec 21 15:22:32 mail postfix/smtpd[28452]: 401736A702F7: client=localhost.localdomain[127.0.0.1]
    Dec 21 15:22:32 mail postfix/cleanup[28448]: 401736A702F7: message-id=<1901058934.351229869351589.JavaMail.root@mail. servername.com>
    Dec 21 15:22:32 mail postfix/qmgr[18000]: 401736A702F7: from=<mkalman@servername.com>, size=1668, nrcpt=1 (queue active)
    Dec 21 15:22:32 mail postfix/smtpd[28452]: disconnect from localhost.localdomain[127.0.0.1]
    Dec 21 15:22:32 mail amavis[18345]: (18345-01) FWD via SMTP: <mkalman@servername.com> -> <miklos.kalman@gmail.com>,BODY=7BIT 250 2.6.0 Ok, id=18345-01, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 401736A702F7
    Dec 21 15:22:32 mail amavis[18345]: (18345-01) Passed CLEAN, [XXX.XXX.XXX.XXX] [XXX.XXX.XXX.XXX] <mkalman@servername.com> -> <miklos.kalman@gmail.com>, Message-ID: <1901058934.351229869351589.JavaMail.root@mail.ser vername.com>, mail_id: JAcxpmm3I8gW, Hits: -0.047, size: 1194, queued_as: 401736A702F7, 512 ms
    Dec 21 15:22:32 mail postfix/smtp[28449]: B5CFC6A702EE: to=<miklos.kalman@gmail.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=0.57, delays=0.03/0.02/0.02/0.5, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as 401736A702F7)
    Dec 21 15:22:32 mail postfix/qmgr[18000]: B5CFC6A702EE: removed
    Dec 21 15:22:32 mail amavis[18345]: (18345-01) extra modules loaded: /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/autosplit.ix, /opt/zimbra/zimbramon/lib/x86_64-linux-thread-multi/auto/Net/SSLeay/randomize.al, IO/Socket/SSL.pm, Net/LDAP/Extension.pm, Net/SSLeay.pm
    Dec 21 15:23:02 mail postfix/smtp[28453]: connect to gmail.com[66.249.91.83]: Connection timed out (port 25)


    Please help.

    Miklos

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Miklos Kalman View Post
    Dec 21 15:23:02 mail postfix/smtp[28453]: connect to gmail.com[66.249.91.83]: Connection timed out (port 25)
    That server may be down, try a connection via telnet to that IP on port 25 and see what the response is. You may also be trying to connect to the wrong IP, I don't believe that's the google smtp server. You should also check there's no outbound blocking of port 25 i.e. no firewall and/or SElinux.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by Miklos Kalman View Post
    I tried to send to gmail with another Zimbra (NE 5.0.10) and it worked perfectly there. However there the log was different, alot more entries but a successful delivery. Any ideas what I am doing wrong on the first :
    Please don't post a ton of logs in the forums unless you're asked to. I've already given you a test to try from the 'failing' server, have you tried a telnet to that ip shown in the logs? Have you also checked the firewall, SElinux and any outbound blocks on port 25?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    Join Date
    Dec 2007
    Location
    Hungary
    Posts
    76
    Rep Power
    8

    Default

    Hi, Sorry for the long paste. The server doesn't have SELinux enabled, nor a firewall and nothing is blocking port 25 as it can deliver to my other server's addresses. The other server takes a different approach to delivering the email to a gmail account. It is full of slapd calls, whereas the new server just tries to connect and fails. What could be causing this.

    Thanks,
    Miklos

  5. #5
    Join Date
    Dec 2007
    Location
    Hungary
    Posts
    76
    Rep Power
    8

    Default

    I have also tried to send mail to a yahoo email account but receive the same error:

    Dec 21 17:03:03 mail postfix/smtp[17479]: 34E9F6A7031E: to=<account@yahoo.com>, relay=none, delay=60, delays=0.01/0/60/0, dsn=4.4.1, status=deferred (connect to yahoo.com[206.190.60.37]: Connection timed out)

    Please help.

    Thanks,
    Miklos

  6. #6
    Join Date
    Dec 2007
    Location
    Hungary
    Posts
    76
    Rep Power
    8

    Default

    The same effect also happens when trying to send mail to other locations like yahoo.com, gmail.com, hushmail.com. They all get deferred with a connection timeout.

    Any ideas? Please help since I am really stuck on this one.

    Thanks,
    Miklos

  7. #7
    Join Date
    Jan 2009
    Posts
    16
    Rep Power
    6

    Default

    I'm having a similar situation like this. Does anyone has found any solution for this problem? Thanks in advance

  8. #8
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default

    none solved the issue? i have it, too
    Why zimbra does not try another ip, after the first one?
    if (connect to gmail.com[173.194.35.22]:25: Connection timed out)
    is in timeout, try another one, isn't it?

    Edit:
    I solved using this post:
    http://www.zimbra.com/forums/adminis...e-setting.html
    "Enable DNS lookups
    The Zimbra MTA makes an explicit DNS query for the MX record of the recipient domain. The default is enabled. If this option is disabled, set a relay host in the Relay MTA for external delivery field. "

    In my case, it was unchecked
    Last edited by maumar; 11-17-2012 at 03:41 PM. Reason: i add something

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. Migration Assistance
    By dwill in forum Administrators
    Replies: 10
    Last Post: 12-02-2008, 08:20 AM
  3. Problem with Postfix and MTA
    By ZMilton in forum Administrators
    Replies: 16
    Last Post: 04-16-2008, 07:47 AM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 12:44 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •