Results 1 to 5 of 5

Thread: 450 Helo command rejected: Host not found

  1. #1
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default 450 Helo command rejected: Host not found

    Dec 23 15:28:55 mail postfix/smtpd[20184]: NOQUEUE: reject: RCPT from mail.incomingdomain.org[123.456.789.123]: 450 4.7.1 <hostxx.internalsubnet.incomingdomain.org>: Helo command rejected: Host not found; from=<person@commercialdomain.com> to=<myperson@mydomain.com> proto=ESMTP helo=<hostxx.internalsubnet.incomingdomain.org>
    Above is the error I get in mail.log, details edited to protect the innocent.

    The following are turned on in the global settings:
    • Hostname in greeting violates RFC (reject_invalid_hostname)
    • Client's IP address (reject_unknown_client)
    • Hostname in greeting (reject_unknown_hostname)
    • Sender's domain (reject_unknown_sender_domain)

    The two FQDN options are off since so many people can't configure a DNS server correctly.

    Anyway, is there a way I can allow matching domain.com type addresses through? All of a sudden recently (last couple weeks) this has been rather common.
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  2. #2
    Join Date
    Aug 2007
    Location
    Anchorage, AK
    Posts
    376
    Rep Power
    8

    Default

    Any ideas out there?
    Culley
    Mail | Dell 2950III | 2x Quad Core 5420 | 8gb RAM | 6x 146gb SAS RAID 0+1 | Red Hat 5.3 | Zimbra 6.0.10 Network Edition
    Test | VMware ESXi Whitebox | Phenom II Black 3.2ghz | 12gb RAM | 6x 1tb SATA RAID 0+1 | CentOS 5.4 | FOSS, Not in use now

  3. #3
    Join Date
    Aug 2009
    Posts
    18
    Rep Power
    6

    Default

    bump
    same issue here

  4. #4
    Join Date
    Dec 2009
    Posts
    75
    Rep Power
    6

    Default

    The only thing you can do is to disable the "Hostname in greeting (reject_unknown_hostname)" option.

    The better way would be to force the admin of the other company to configure his mailserver and DNS server corectly

    yogg
    Release 7.1.2_GA_3268.UBUNTU8_64 UBUNTU8_64 NETWORK edition.

  5. #5
    Join Date
    Sep 2006
    Location
    477 Congress Street | Portland, ME 04101
    Posts
    1,374
    Rep Power
    11

    Default

    In our experience working with large mail servers over the years, there are too many large ISPs and other corporate systems configured not in strict compliance with the RFCs.

    So, to avoid filtering out legitimate email ("false positives") in Zimbra, we find that on the Configuration > Global Settings section > MTA tab in the Console that the only Protocol Check which can be safely enabled is reject_non_fqdn_sender, and the only DNS Check which can be safely enabled is reject_unknown_sender_domain.

    Enabling any other Protocol or DNS Checks will result in false positives and upset end users.

    The good news is that a well-tuned anti-spam system will block all the garbage those additional Protocol and DNS Checks would have blocked, but without false positives.

    Hope that helps,
    Mark

Similar Threads

  1. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 10:10 AM
  2. Fresh Zimbra installation does not work
    By Datax in forum Installation
    Replies: 4
    Last Post: 08-18-2008, 02:18 PM
  3. Replies: 20
    Last Post: 03-18-2008, 06:37 AM
  4. Replies: 2
    Last Post: 10-04-2007, 04:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •