Results 1 to 2 of 2

Thread: [SOLVED] Customized local GAL...

  1. #1
    Join Date
    Sep 2008
    Posts
    74
    Rep Power
    7

    Default [SOLVED] Customized local GAL...

    I'm trying to set up a domain with a GAL that only returns that domain's addresses (rather than all the address for all domains on that server)--thus making "Internal" not a viable choice for the GAL config since it doesn't allow me to put in a GAL filter. So I need to use "External" and point Zimbra at itself, right?

    Well, the Zimbra server isn't listening because it's hostname doesn't resolve to itself. (It's a long story, but it's not supposed to in this setup.) So, I've been digging around and it looks like in order to get slapd to listen on this server, I'd need to modify the url entry (in the -h option) to the IP address instead of the hostname.

    SO,

    Would the best way of making this change permanent be to manually set the $bind_url (in Zimbra's ldap command) to the IP address?

  2. #2
    Join Date
    Sep 2008
    Posts
    74
    Rep Power
    7

    Thumbs up

    Ok, so I went ahead and modified the ldap command to include the local server's IP address. (A couple things on that... 1: Used $ldap_url instead of $bind_url because of an if statement. 2: Added the IP version of the url instead of replacing the hostname version. The -h option of slapd allows for spaced separated list; and the hostname url was being used somehow--was getting errors without it.) It worked--the issue of getting Zimbra to listen on 389 even when it's hostname doesn't resolve to its own ip, is resovled.

    Anyway, still ran into a problem though. The new domain can now search only its own GAL, but old domains (utilizing "Both" GAL--the external part being completely unrelated to this new setup I'm trying) see the new domain accounts too. Since there is no way to customize the "internal" part of "Both" (the source of my problems to begin with) I can't filter out the new domain from the old ones.

    I just keep running into this problem of not being able to modify what domains share and what they don't. (This time, the current object being the GAL--another immutable feature being Resources and Locations). Might as well throw out my customary "too bad this isn't documented anywhere" comment, too.

Similar Threads

  1. LDAP Cannot bind on migration to new server
    By neekster in forum Migration
    Replies: 23
    Last Post: 03-09-2009, 03:08 AM
  2. postfix transport maps
    By pheonix1t in forum Administrators
    Replies: 12
    Last Post: 01-17-2009, 11:42 PM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 01:42 AM
  4. Replies: 13
    Last Post: 05-15-2007, 07:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •