Results 1 to 3 of 3

Thread: LDAP Hell!! Crashed System

  1. #1
    Join Date
    Apr 2007
    Posts
    39
    Rep Power
    8

    Default LDAP Hell!! Crashed System

    Over the Christmas Vacation. We had a Certificate expire. The tech on call tried to create a new cert but was having issues. So they decided to update from Ubuntu 6.06 to 8.04. To make a long story short we have not had an email server for almost a week now. We reinstalled from scratch Ubuntu 8.04 and followed the directions on the Wiki to backup and restore on a new server. (I think the backup is bad)

    But we keep getting the same message:
    ldap_url and ldap_master_url cannot be the same on an ldap replica

    Setting defaults from ldap...ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException localhost:389)

    ERROR: service.FAILURE (system failure: ZimbraLdapContext) (cause: javax.naming.CommunicationException localhost:389)


    I have already visited the forum and have verified my Hostname ran zmfixperm.

    System: Ubuntu 8.04.1 - FOSS 5.0.11

  2. #2
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    21

    Default

    So the plan was copy over the /opt/zimbra backup and run .install.sh -s using the Ubuntu 8 package right?
    Was this the first time you've ran the installer? Or is this a 2nd+ time and you had previous failures?

    Let's check your /opt/zimbra/conf/localconfig.xml values:
    -ldap_is_master (is this false on mistake?)
    -ldap_master_url
    -ldap_url
    -zimbra_server_hostname

    You may need to:
    mv /opt/zimbra/conf/localconfig.xml /opt/opt/zimbra/conf/localconfig.xml.2
    mv /opt/zimbra/.saveconfig /opt/zimbra/.saveconfig2
    Copy in your good localconfig.xml from backup.
    Run the installer again.

    To help you further we really need the /opt/zimbra/.install_history, as well as the relevant /tmp/install.log.# & zmsetup.#.log

  3. #3
    Join Date
    Apr 2007
    Posts
    39
    Rep Power
    8

    Default

    I was able to get the server up and the clients and mailboxes over. It was an LDAP password issue. I used the zmldappasswd. The problem that I have now is all email is being deferred.

    The postque -p shows:

    (host email.myserver.com[xx.xx.xx.xx] said: 451 4.0.0 Temporary message delivery failure try again (in reply to end of DATA command)

    And users are getting an error sending mail:

    A network service error has occurred. msg: system failure: IOException
    code: service.FAILURE
    method: SendMsgRequest
    detail: soap:Receiver
    trace: btpool0-3:1230641275264:5b43fa78fb7be2b0

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  2. upgrading from 5.0.4 to 5.0.5 opensource
    By smoke in forum Installation
    Replies: 4
    Last Post: 10-19-2008, 10:38 AM
  3. Replies: 8
    Last Post: 10-19-2008, 09:52 AM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •