Results 1 to 1 of 1

Thread: [SOLVED] mysql.server is not running

  1. #1
    Join Date
    Aug 2007
    Rep Power

    Default [SOLVED] mysql.server is not running

    As the title suggests, my mysql.server is not running when start the Zimbra server. This is a production 5.0.10 server which has been running flawlessly for several months now. It is running on Ubuntu 6.06 LTS x64 with 4gb of memory.

    I installed a new certificate and after running zmcontrol stop and zmcontrol start the status looked like this:

    zimbra@www:~/logger/db/data$ zmcontrol status
            antispam                Running
            antivirus               Running
            imapproxy               Running
            ldap                    Running
            logger                  Stopped
                    logmysql.server is not running
                    zmlogswatchctl is not running
            mailbox                 Stopped
                    mysql.server is not running
            mta                     Running
            snmp                    Running
            spell                   Running
            stats                   Stopped
    Attempting to manually start the server appears to work, but then connecting to it results in

    zimbra@www:~/logger/db/data$ mysql mysql
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    I have spent some hours trying everything I could find in the wikis and on the forums and have had no luck. I even reinstalled the server and ran the zmfixperms script.

    The error in /opt/zimbra/log/logger_mysql_error.log is
    090105 09:42:17  mysqld started
    090105  9:42:17 [ERROR] Can't start server: cannot resolve hostname!: Connection timed out
    090105 09:42:17  mysqld ended
    My /etc/hosts files looks like this
    administrator@www:/opt/zimbra/log$ cat /etc/hosts localhost.localdomain locahost www
    MX and A records resolve properly, I can post logs of these as well if needed.

    If any more info is needed I will be glad to provide anything to help troubleshoot this.

    EDIT: Restarting the server for a fourth time has resulted in things sorting out and everything is up and running again. I have marked this solved but not sure why it is now solved. I made no system changes between this restart and the two previous failed restarts.
    Last edited by fogogg; 01-05-2009 at 08:17 AM.

Similar Threads

  1. [SOLVED] mysql.server not running
    By king0770 in forum Administrators
    Replies: 23
    Last Post: 07-25-2009, 03:07 PM
  2. zmmailboxdctl is stopped frequently..
    By tamilnandhu in forum Installation
    Replies: 13
    Last Post: 04-12-2008, 08:59 AM
  3. Can't seem to get global in BES
    By sdemeyer in forum Zimbra Connector for BlackBerry
    Replies: 12
    Last Post: 03-19-2008, 08:22 AM
  4. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 10:38 AM
  5. Trouble sending mail from Outlook
    By czaveri in forum Users
    Replies: 15
    Last Post: 07-24-2006, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts