Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: ZCS 3.1 upgrade

  1. #11
    Join Date
    Mar 2006
    Posts
    67
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Maybe a timing issue and it tried to access MySQL before it came up. You can try to re-run the upgrade.
    I just reran the upgrade and instead of running some migration code (like when I went from 301-160 to 310-279) it looked like a new install. It seems to be running ok though.

  2. #12
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Unhappy New problems now with LDAP

    Well, I just tried twice and was unsuccessful. This time, it looks like its not able to get as far as it did originally.

    I went through the ./install.sh again and it removes all rpms, then installs the new ones, sets defaults from saved config in /opt/zimbra/.saveconfig/config.save, checks port conflicts, says it started ldap... Done, then attempts to set defaults from ldap and then gets this error:
    Code:
    Starting ldap...Done
    Setting defaults from ldap...ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    Done
    Checking ldap on localhost:389...
    After that, the "Checking ldap on localhost:389" will fail too and it will then go to this:
    Code:
    Checking ldap on localhost:389...FAILED ( ldap_result: Can't contact LDAP server (-1)
    # extended LDIF
    #
    # LDAPv3
    # base <> with scope subtree
    # filter: (objectclass=*)
    # requesting: ALL
    #
     )
    Checking ldap on localhost:389...FAILED ( ldap_bind: Can't contact LDAP server (-1) )
    
    Main menu
    
       1) Hostname:                                hail.networkpenguin.com
       2) Ldap master host:                        hail.networkpenguin.com
       3) Ldap port:                               389
       4) Ldap password:                           set
       5) zimbra-ldap:                             Enabled
       6) zimbra-store:                            Enabled
            +Create Admin User:                    no
            +SMTP host:                            hail.networkpenguin.com
    ******* +Web server HTTP port:                 UNSET
    ******* +Web server HTTPS port:                UNSET
            +Web server mode:                      mixed
            +IMAP server port:                     143
            +IMAP server SSL port:                 993
            +POP server port:                      110
            +POP server SSL port:                  995
            +Use spell check server:               yes
            +Spell server URL:                     http://hail.networkpenguin.com:7780/aspell.php
    
       7) zimbra-mta:                              Enabled
       8) zimbra-snmp:                             Enabled
       9) zimbra-logger:                           Enabled
      10) zimbra-spell:                            Enabled
       r) Start servers after configuration        yes
       s) Save config to file
       x) Expand menu
       q) Quit
    
    Address unconfigured (**) items or correct ldap configuration  (? - help)
    II attempt to fix "Web server HTTP port" and the HTTPS one, because I previously changed them from the defaults using zmprov, I believe. But even with those set, it seems like its having ldap issues.

  3. #13
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    This seems pretty unambigous:

    Setting defaults from ldap...ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause:
    host hail.networkpenguin.com
    hail.networkpenguin.com has address 192.168.200.11

    I can look up your host by name (private IP space in public DNS? Shame on you - what's in this host's /etc/resolv.conf that prevents it from resolving it's own name?


    Quote Originally Posted by hootjr29
    Well, I just tried twice and was unsuccessful. This time, it looks like its not able to get as far as it did originally.

    I went through the ./install.sh again and it removes all rpms, then installs the new ones, sets defaults from saved config in /opt/zimbra/.saveconfig/config.save, checks port conflicts, says it started ldap... Done, then attempts to set defaults from ldap and then gets this error:
    Code:
    Starting ldap...Done
    Setting defaults from ldap...ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    ERROR: service.FAILURE (system failure: unable to lookup server by name: hail.networkpenguin.com) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])
    Done
    Checking ldap on localhost:389...
    After that, the "Checking ldap on localhost:389" will fail too and it will then go to this:
    Code:
    Checking ldap on localhost:389...FAILED ( ldap_result: Can't contact LDAP server (-1)
    # extended LDIF
    #
    # LDAPv3
    # base <> with scope subtree
    # filter: (objectclass=*)
    # requesting: ALL
    #
     )
    Checking ldap on localhost:389...FAILED ( ldap_bind: Can't contact LDAP server (-1) )
    
    Main menu
    
       1) Hostname:                                hail.networkpenguin.com
       2) Ldap master host:                        hail.networkpenguin.com
       3) Ldap port:                               389
       4) Ldap password:                           set
       5) zimbra-ldap:                             Enabled
       6) zimbra-store:                            Enabled
            +Create Admin User:                    no
            +SMTP host:                            hail.networkpenguin.com
    ******* +Web server HTTP port:                 UNSET
    ******* +Web server HTTPS port:                UNSET
            +Web server mode:                      mixed
            +IMAP server port:                     143
            +IMAP server SSL port:                 993
            +POP server port:                      110
            +POP server SSL port:                  995
            +Use spell check server:               yes
            +Spell server URL:                     http://hail.networkpenguin.com:7780/aspell.php
    
       7) zimbra-mta:                              Enabled
       8) zimbra-snmp:                             Enabled
       9) zimbra-logger:                           Enabled
      10) zimbra-spell:                            Enabled
       r) Start servers after configuration        yes
       s) Save config to file
       x) Expand menu
       q) Quit
    
    Address unconfigured (**) items or correct ldap configuration  (? - help)
    II attempt to fix "Web server HTTP port" and the HTTPS one, because I previously changed them from the defaults using zmprov, I believe. But even with those set, it seems like its having ldap issues.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #14
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    Yep. I did that to attempt to fool postfix at one point because I couldn't remember how to force it to not lookup MX's and instead use itself. 3.0 has been running on this box for the last few months. I have rebooted it a few times and have not done updates recently on this system. So as soon as I finish upgrading Zimbra, I'll do some yum updates. But nothing has change until today when I tried upgrading.

    the hosts
    Code:
    [root@hail ~]# cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost.localdomain   localhost
    192.168.200.11  hail.networkpenguin.com hail
    and the resolv.conf

    Code:
    [root@hail ~]# cat /etc/resolv.conf
    search networkpenguin.com
    nameserver 4.2.2.1
    nameserver 4.2.2.2
    nameserver 68.168.224.162
    [root@hail ~]# pign hail
    [root@hail ~]# ping hail.networkpenguin.com
    PING hail.networkpenguin.com (192.168.200.11) 56(84) bytes of data.
    64 bytes from hail.networkpenguin.com (192.168.200.11): icmp_seq=0 ttl=64 time=6.62 ms
    64 bytes from hail.networkpenguin.com (192.168.200.11): icmp_seq=1 ttl=64 time=0.208 ms

  5. #15
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Postfix isn't the problem - ldap is - and /etc/hosts isn't the problem - DNS is. Ping is not a valid test, since it'll use the hosts file - run the host command (host `hostname`).

    So, you need to make sure that ldap can resolve your hostname via DNS, or this won't work.

    (FWIW, when I resolved it I got the info from a 69.x.x.x address)
    Bugzilla - Wiki - Downloads - Before posting... Search!

  6. #16
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    I realize that postfix isn't the issue. I was just mentioning why I have hail.networkpenguin.com registered in my dns. It was my understanding that when your /etc/nsswitch.conf's hosts: entry is set to "files dns" that any stuff that I put in /etc/hosts will be used, when being queried, before dns. I'm not as clear as to HOW ldap queries things. So if it uses another method of name resolution and is capable of bypassing /etc/hosts, things should still work from that system. Here is my query using dig. In addition to 4.2.2.1, I tried my other nameserver entries as well. I'm not sure how you queried hail.networkpenguin.com. Because it should resolve to a 192.etc..etc.. the domain networkpenguin.com will probably resolve the 69.x.x.x.

    Code:
    [root@hail ~]# dig @4.2.2.1 hail.networkpenguin.com
    
    ; <<>> DiG 9.3.1 <<>> @4.2.2.1 hail.networkpenguin.com
    ; (1 server found)
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32507
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;hail.networkpenguin.com.       IN      A
    
    ;; ANSWER SECTION:
    hail.networkpenguin.com. 43118  IN      A       192.168.200.11
    
    ;; Query time: 87 msec
    ;; SERVER: 4.2.2.1#53(4.2.2.1)
    ;; WHEN: Fri Apr 14 13:12:55 2006
    ;; MSG SIZE  rcvd: 57
    It seems to me that if this system was working properly before the attempted upgrade, that any DNS resolution issues should have caused probably previously as well-- and they didn't. Could it have been an openldap upgrade issue? What about the schema? Could something be bunged in my schema that would cause some sort of lookup issues? When it says "Setting defaults from ldap..." could that program be attempting to talk with openldap.. and maybe openldap wasn't able to start for some reasons?
    Last edited by hootjr29; 04-14-2006 at 10:26 AM.

  7. #17
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    14

    Default

    Is ldap running? Can you contact the server on port 389?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #18
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    I don't see it running:
    Code:
    [root@hail zcs]# netstat -an | grep 389
    [root@hail zcs]#

  9. #19
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    Question about the install.sh script. Originally the script kicks off and says "Saving existing configuration file to /opt/zimbra/.saveconfig" When it does this and my upgrade fails halfway through ( basically, packages were uninstalled, then new packages were installed, then configs are imported, etc..etc.. ), then I go and rerun the install.sh script and it says "Saving existing configuration file to /opt/zimbra/.saveconfig" again, I would assume that this means it was saving my failed configuration.

    Could that having anything to do with ldap not starting correctly and thus preventing the who thing from working correctly?

  10. #20
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    Here's another post that might relate to this ldap issue:

    http://www.zimbra.com/forums/showthread.php?t=2565

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  2. 3.1 Upgrade Problems
    By dee in forum Administrators
    Replies: 22
    Last Post: 07-13-2009, 05:51 PM
  3. fc4 zcs-3.0.1 -> 3.1 upgrade worked great.. almost
    By keyhman in forum Installation
    Replies: 29
    Last Post: 09-29-2006, 11:06 AM
  4. FC3 ZCS 3.1 Crash Recovery - Help!
    By stillSpirit in forum Administrators
    Replies: 0
    Last Post: 09-23-2006, 07:53 AM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •