Results 1 to 10 of 30

Thread: ZCS 3.1 upgrade

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    7
    Rep Power
    9

    Default ZCS 3.1 upgrade

    I've made a copy of opt/zimbra and installed the new version after stopping all services. I received the following ERROR:

    Setting defaults...Setting defaults from existing config...Done
    Upgrading from 3.0.1_GA_160 to 3.1.0_GA_328
    Fri Apr 14 12:19:16 2006: Stopping zimbra services
    Fri Apr 14 12:19:18 2006: Checking mysql status
    Fri Apr 14 12:19:18 2006: Starting mysql
    Fri Apr 14 12:19:18 2006: SELECT value FROM config WHERE name = 'db.version'
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Error while running
    Daniel Bülow (12:35 PM) :
    '/opt/zimbra/bin/mysql --user=zimbra --password=pRI1.tH4_GJH6kycTtxVPvqq1D --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 134.

  2. #2
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    I got the exact same error just now. The only difference that I have is that I'm upgrading from 3.0.0 to 3.1.0. I'm using Fedora Core 4:

    Upgrading from 3.0.0_GA_156 to 3.1.0_GA_328
    Last edited by hootjr29; 04-14-2006 at 08:11 AM.

  3. #3
    Join Date
    Mar 2006
    Posts
    67
    Rep Power
    9

    Default

    I just got:

    Upgrading from 3.1.0_GA_279 to 3.1.0_GA_328
    Fri Apr 14 09:15:35 2006: Stopping zimbra services
    Fri Apr 14 09:15:36 2006: Checking mysql status
    Fri Apr 14 09:15:36 2006: Starting mysql
    Fri Apr 14 09:15:36 2006: SELECT value FROM config WHERE name = 'db.version'
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2)
    Error while running '/opt/zimbra/bin/mysql --user=zimbra --password=... --database=zimbra --batch --skip-column-names'. at /opt/zimbra/libexec/scripts/Migrate.pm line 134.

    With opensuse 10. Where do I go from here?

  4. #4
    Join Date
    Feb 2006
    Posts
    6
    Rep Power
    9

    Default Error on upgrade

    And now I got:

    Code:
    $ sudo ./zmsetup.pl
    Password:
    Checking java version...1.5 found
    Operations logged to /tmp/zmsetup.log.28406
    Setting defaults...Setting defaults from existing config...Done
    Upgrading from 3.0.1_GA_160 to 3.1.0_GA_328
    Fri Apr 14 11:18:59 2006: Stopping zimbra services
    Fri Apr 14 11:20:38 2006: Stop failed - exiting
    UPGRADE FAILED - exiting

  5. #5
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Seems like MySQL is not starting. Can you try to start it manually?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  6. #6
    Join Date
    Mar 2006
    Posts
    10
    Rep Power
    9

    Default mysql not running... get the logs

    check the logs for mysql to see what's up:

    /opt/zimbra/log/my*

  7. #7
    Join Date
    Feb 2006
    Posts
    35
    Rep Power
    9

    Default

    Here's the end of my mysqld.log

    Code:
    060414  8:48:13  InnoDB: Shutdown completed; log sequence number 0 6822185
    060414  8:48:13 [Note] /opt/zimbra/mysql/bin/mysqld: Shutdown complete
    
    060414 08:48:13  mysqld ended
    
    060414 09:16:12  mysqld started
    060414  9:16:14  InnoDB: Started; log sequence number 0 6822185
    /opt/zimbra/mysql/bin/mysqld: ready for connections.
    Version: '4.1.16-standard-log'  socket: '/opt/zimbra/db/mysql.sock'  port: 7306  MySQL Community Edition
     - Standard (GPL)
    And I can see that its currently listening:
    Code:
    root@hail zcs]# netstat -an | grep 7306
    tcp        0      0 127.0.0.1:7306              0.0.0.0:*                   LISTEN
    Last edited by hootjr29; 04-14-2006 at 09:49 AM.

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 05:52 AM
  2. 3.1 Upgrade Problems
    By dee in forum Administrators
    Replies: 22
    Last Post: 07-13-2009, 06:51 PM
  3. fc4 zcs-3.0.1 -> 3.1 upgrade worked great.. almost
    By keyhman in forum Installation
    Replies: 29
    Last Post: 09-29-2006, 12:06 PM
  4. FC3 ZCS 3.1 Crash Recovery - Help!
    By stillSpirit in forum Administrators
    Replies: 0
    Last Post: 09-23-2006, 08:53 AM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 04:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •