Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: [SOLVED] Error 554

  1. #1
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Question [SOLVED] Error 554

    We're testing Zimbra for possible migration from another solution (or as a companion to); but we keep getting 554 errors like this:

    554 Transaction Failed: Command "FROM" field differs from data "FROM" field.

    The mail is first passed through a MailFoundry appliance for content filtering. Spam/virus filtering is disabled in Zimbra. For the domain, I've set inbound host field to that of the MailFoundry appliace (I've also tried leaving it blank).

    Where did I go wrong?

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Welcome to the forums

    I you send that email directly to Zimbra does it go through okay ? It sounds to me like the SMTP transaction is being munged.

  3. #3
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Question

    (thanks

    We have set-up another domain, which is not filtered via MailFoundry, and it goes straight through. So yes, there's something not-quite-right between MailFoundry and Zimbra. But MF have been doing this for a number of years, and while that in itself doesn't mean they can't screw up, it handles "relaying" to a number of other servers (including other postfix, qmail, exchange , and more..); it sounds a bit too simple, gut feeling.

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Why have you set the inbound host field ? Basically ZCS has become a smarthost that the MF talks too. If you compare the headers of the original email sent to what is received by ZCS are they all intact ?

  5. #5
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Default

    It was pure desperation Since it didn't work without it, I figured I'd give it a shot. And the configuration does say
    If your MX records point to a spam-relay or any other external non-zimbra server, enter the name of that server in "Inbound SMTP host name" field.
    As for what was received by ZCS, I don't know -- the transaction isn't completed (since it's an SMTP-level reject), so I don't know where I'd find the message as "received" by ZCS.

  6. #6
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Is the MF appliance on the same network address range as your ZCS server ?

  7. #7
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Default

    No, it's not on the same network. It's on a different C-class net. I added that network so it's shown when I type "postconf mynetworks"; should I be adding it elsewhere?

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Could you post the output from
    Code:
    su - zimbra
    zmprov gacf | grep -i mtarestriction
    to see what Postfix restrictions are in place.

  9. #9
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Default

    zimbraMtaRestriction: reject_invalid_hostname
    zimbraMtaRestriction: reject_non_fqdn_sender

  10. #10
    Join Date
    Jan 2009
    Location
    Stockholm, Sweden
    Posts
    96
    Rep Power
    6

    Exclamation

    We've done some manual testing, and something definitely isn't right:

    connected to (our server address)
    220 ourhost.address.com ESMTP Postfix
    ehlo my.local.server.com
    250-ourhost.address.com
    250-SIZE 10240000
    250-VRFY
    250-ETRN
    250-ENHANCEDSTATUSCODES
    250-8BITMIME
    250 DSN
    mail from: email@myaddress.com
    250 2.1.0 Ok
    rcpt to: info@thedomain.com
    250 2.1.5 Ok
    data
    353 End data with <CR><LF>.<CR><LF>
    from: email@myaddress.com
    to: info@thedomain.com
    subject: test


    test test


    .
    554 Transaction Failed: Command "FROM" field differs from data "FROM" field.
    Huh??

    (I've replaced the names of various things, but they match what's configured in Zimbra)

    Note that it doesn't matter if I do this from the MF appliance or locally.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •