Results 1 to 7 of 7

Thread: Incorrect New Message Count

Hybrid View

  1. #1
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    10

    Default Incorrect New Message Count

    Howdy,

    When using OSS Zimbra 3.0.1 with IMAP clients and not just the web interface, we're seeing a lot of cases where the new message count within the Zimbra web interface is incorrect.

    For example, one user of ours used squirrelmail to delete 3 messages the other day (his parents have dialup ;-) When he went to the Zimbra web interface, the Trash folder showed that there were 3 new messages, but really, no messages at all were in that folder (new or old). Choosing 'Empty Trash' does not solve the problem.

    For me, I mainly use mutt, which uses Zimbra as an imap server. Looking in mutt now, there are no new messages. Going to the Zimbra web interface, it says that there's 60 or so new messages, but there actually aren't any new ones.

    When I use the phrase "It think's there are X new messages", I'm referring to the message count in parenthesis after the folder name, in the folder list on the left.

    My appologies if this was an issue already solved in 3.1.0. I have not yet upgraded, as I was hoping to wait a few days for the installer kinks to get worked out, these guys would get irate if they went without email for more than a few minutes ;-)

    I didn't see it mentioned in bugzilla, the release notes, or the forum, so I figured I'd take the chance that this issue was present in 3.1.0 as well :-) If you prefer I upgrade first, I can get back to you in a few days as to whether we're still seeing this.

    Thanks!
    -Eric

  2. #2
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    10

    Default

    There has been an issue floating around the forums about a similar problem with the Inbox message count in the web client. This happens when the web client and another client be it pop3 or imap are accessing the same account at the same time or in close proximity of time. The work around to this is restart tomcat.

  3. #3
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Here's at least one of the bugs about unread counts.

    http://bugzilla.zimbra.com/show_bug.cgi?id=5012

    If you have a use case that can reproduce it that would really help. Feel free to file a new bug if you have some set of exact steps to reproduce the bug.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  4. #4
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    10

    Default

    Quote Originally Posted by KevinH
    If you have a use case that can reproduce it that would really help. Feel free to file a new bug if you have some set of exact steps to reproduce the bug.
    Okay, I'll work on reproducing it.

    In the bug that you mentioned above, someone suggested they thought it may be calendar invite related.

    I can verify that it's not shared calendar related. I'm dealing with a reasonably new installation here, and we all have yet to use the shared calendar / invite functions in this particular installation.

    But, I'll ask the users to try and come up with a series of steps to reproduct.

    Thanks,
    -Eric

  5. #5
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    10

    Default

    Quote Originally Posted by KevinH
    If you have a use case that can reproduce it that would really help. Feel free to file a new bug if you have some set of exact steps to reproduce the bug.
    Okay, one of the guys claims to be able to reproduce it with these steps:

    * have zimbra open and have another client open like squirrelmail.
    * send yourself an email
    * delete it in squirrelmail without reading it
    * empty trash in squirrelmail
    * go back to zimbra and you'll see trash can has increased the number in parens next to it
    * there's nothing in the can

    He also made mention of something about a Zimbra hat.... ;-)

    Anyhow, I'll pretty this up, and post it into a new bug.
    -Eric

  6. #6
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    10

    Default

    Quote Originally Posted by andreychek
    Anyhow, I'll pretty this up, and post it into a new bug.
    Alright, posted as bug #7266.

    Thanks,
    -Eric

  7. #7
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by andreychek
    Alright, posted as bug #7266.

    Thanks,
    -Eric
    You can temporarily solve the probem like this:

    su - zimbra
    zmtlsctl http
    zmcontrol stop
    zmcontrol start



    Chintan Zaveri.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

Similar Threads

  1. Per folder message count
    By gihrig in forum Users
    Replies: 10
    Last Post: 08-31-2012, 02:02 PM
  2. Missing Stats Message Count / Message Volume
    By rhostager in forum Installation
    Replies: 15
    Last Post: 12-18-2007, 10:29 AM
  3. Reset Message Count
    By bhickey in forum Administrators
    Replies: 3
    Last Post: 03-13-2007, 10:23 AM
  4. Inbox unread message count is wrong
    By dhallweb in forum Administrators
    Replies: 6
    Last Post: 08-26-2006, 02:03 PM
  5. Message count graph
    By reneanb in forum Administrators
    Replies: 1
    Last Post: 03-17-2006, 09:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •