Results 1 to 3 of 3

Thread: Zimbra 5.0.9 zmlogprocess needs patchin'

  1. #1
    Join Date
    Feb 2009
    Posts
    1
    Rep Power
    6

    Default Zimbra 5.0.9 zmlogprocess needs patchin'

    Hey there:

    I've been running 5.0.9 with some success-however, I always noticed how the spam and virus counts in the log database were always zero.

    It appears that a lot of the amavis log lines match none of the regexes in the zmlogprocess script. I've modified some of them, and I'd like to share them here:

    I put debug lines so the script tells me which regex matches.

    Code:
    elsif ($msg =~ /\(([^)]+)\) (Passed|Blocked) ([^,]+), \[([^]]+)\] <([^>]*)> -> (<[^>]+>(?:,<[^>]+>)*),(?: quarantine: [^,]+,)? Message-ID: <([^>]+)>,(?: Resent-Message-ID: <[^>]+>,)? mail_id: \S+, 
    Hits: (\S+), size: \d+, (\d+) ms/) {
                $pid = $1;
                $disp = $2;
                $reason = $3;
                $fromIP = $4;
                $origIP = "unknown";
                $sender = $5;
                $recips = $6;
                $msgid = $7;
                $hits = $8;
                $queued_as = "unknown";
                $ms = $9;
                print "REGEX 4c\n";
              } elsif ($msg =~ /\(([^)]+)\) (Passed|Blocked) ([^,]+), \[([^]]+)\] <([^>]*)> -> (<[^>]+>(?:,<[^>]+>)*),(?: quarantine: [^,]+,)? Message-ID: <([^>]+)>,(?: Resent-Message-ID: <[^>]+>,)? mail_id: \S+, 
    Hits: (\S+), size: \d+, queued_as: (\S+), (\d+) ms/) {
                $pid = $1;
                $disp = $2;
                $reason = $3;
                $fromIP = $4;
                $origIP = "unknown";
                $sender = $5;
                $recips = $6;
                $msgid = $7;
                $hits = $8;
                $queued_as = $9;
                $ms = $10;
                print "REGEX 5c\n";
              }

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Welcome to the forums.

    Could you check in bugzilla if this entry has been addressed if it hasn't can you file a bug entry so that it will get to the attention of development.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Join Date
    Oct 2008
    Posts
    17
    Rep Power
    7

    Default

    Thanks for posting this.. too bad I didn't look here 4 hours ago.

Similar Threads

  1. Replies: 8
    Last Post: 01-12-2012, 02:20 AM
  2. Replies: 12
    Last Post: 02-25-2008, 07:28 PM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 09:55 AM
  5. 3.1 on FC4 problems
    By cohnhead in forum Installation
    Replies: 8
    Last Post: 05-26-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •