Results 1 to 3 of 3

Thread: ERROR: service.FAILURE (system failure: unable to search gal)

  1. #1
    Join Date
    Jul 2006
    Rep Power

    Default ERROR: service.FAILURE (system failure: unable to search gal)


    I'm using zcs 5.0.13 on unbuntu.
    I configured active directory authentication on a replica domain controller and it works well.
    If I configure GAL same parameters (zmprov gd domain)
    zimbraGalAutoCompleteLdapFilter: adAutoComplete
    zimbraGalLdapBindDn: zimbra-replication@mydomain.lan
    zimbraGalLdapBindPassword: mypassowrd
    zimbraGalLdapFilter: ad
    zimbraGalLdapPageSize: 1000
    zimbraGalLdapSearchBase: dc=mydomain,dc=lan
    zimbraGalLdapURL: ldap://
    zimbraGalMaxResults: 100
    zimbraGalMode: ldap
    zimbraGalSyncLdapPageSize: 1000

    When I try to search GAL i receice an error:
    ERROR: service.FAILURE (system failure: unable to search gal)

    And in /opt/zimbra/log/mailbox.log I see:

    at com.zimbra.common.service.ServiceException.FAILURE (
    at com.zimbra.cs.account.ldap.LdapUtil.searchGal(Ldap
    at com.zimbra.cs.account.ldap.LdapUtil.searchLdapGal(
    at com.zimbra.cs.account.ldap.LdapUtil.searchLdapGal(
    at LdapGal(
    at Gal(
    at Gal(
    at com.zimbra.cs.service.account.SearchGal.handle(Sea
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:286)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:160)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:269)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:727)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:820)
    at org.mortbay.jetty.servlet.ServletHolder.handle(Ser
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.servlet.UserAgentFilter.doFilter(UserA
    at org.mortbay.servlet.GzipFilter.doFilter(GzipFilter .java:132)
    at org.mortbay.jetty.servlet.ServletHandler$CachedCha in.doFilter(
    at org.mortbay.jetty.servlet.ServletHandler.handle(Se
    at org.mortbay.jetty.servlet.SessionHandler.handle(Se
    at org.mortbay.jetty.handler.ContextHandler.handle(Co
    at org.mortbay.jetty.webapp.WebAppContext.handle(WebA
    at org.mortbay.jetty.handler.ContextHandlerCollection .handle(
    at org.mortbay.jetty.handler.HandlerCollection.handle (
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.handler.rewrite.RewriteHandler.h andle(
    at org.mortbay.jetty.handler.HandlerWrapper.handle(Ha
    at org.mortbay.jetty.Server.handle(
    at org.mortbay.jetty.HttpConnection.handleRequest(Htt
    at org.mortbay.jetty.HttpConnection$ ntent(
    at org.mortbay.jetty.HttpParser.parseNext(HttpParser. java:644)
    at org.mortbay.jetty.HttpParser.parseAvailable(HttpPa
    at org.mortbay.jetty.HttpConnection.handle(HttpConnec
    at org.mortbay.thread.BoundedThreadPool$ n(
    Caused by: javax.naming.PartialResultException [Root exception is javax.naming.CommunicationException: mydomain.lan:389 [Root exception is
    at com.sun.jndi.ldap.LdapNamingEnumeration.hasMoreImp l(
    at com.sun.jndi.ldap.LdapNamingEnumeration.hasMore(Ld
    at com.zimbra.cs.account.ldap.LdapUtil.searchGal(Ldap
    ... 36 more
    Caused by: javax.naming.CommunicationException: myd.lan:389 [Root exception is connect timed out]
    at com.sun.jndi.ldap.LdapReferralContext.<init>(LdapR
    at com.sun.jndi.ldap.LdapReferralException.getReferra lContext(
    at com.sun.jndi.ldap.LdapNamingEnumeration.hasMoreRef errals(
    at com.sun.jndi.ldap.LdapNamingEnumeration.hasMoreImp l(
    ... 38 more

    Can you help me ?

    Thank you

  2. #2
    Join Date
    Nov 2005
    Rep Power


    I am having the same issue. I have authentication working but I am not able to successfully test the GAL. My guess is an incorrect search term? I'm not sure what I need to put there. Suggestions? Guidance?

  3. #3
    Join Date
    Jul 2006
    Rep Power


    In release 5.0.15 i'm not experiencing the problem, in 5.0.13 I solved using a different LDAP filter than the one proposed by zimbra.

    using zmprov gacf zimbraGalLdapFilterDef you can see the definition for adAutoComplete that you can edit, otherwise try to use ldap instead of active directory and put (|(cn=&#37;s*)(sn=%s*)(givenName=%s*)(mail=%s*))
    as filter.

Similar Threads

  1. Installation zimbra Initializing ldap...failed. (28416)
    By farrukh.nadeem in forum Installation
    Replies: 10
    Last Post: 08-14-2009, 06:52 AM
  2. Replies: 4
    Last Post: 08-04-2008, 06:17 PM
  3. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  4. Replies: 2
    Last Post: 02-12-2008, 10:55 AM
  5. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts