Results 1 to 2 of 2

Thread: Problem with SOAP CreateAccountRequest

  1. #1
    Join Date
    Oct 2005
    Posts
    6
    Rep Power
    9

    Question Problem with SOAP CreateAccountRequest

    Hi,

    SOAP newbie at work here. I am successfully authenticating with the zimbra server and extracting the auth token. The next thing I do is put together a SOAP message to create an account. The error I get back is:

    <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope"><soap:Body><soap:Fault><soap:Code><soap: Value>soap:Sender</soap:Value></soap:Code><soap:Reason><soap:Text>parse error: Error on line 5 of document : XML document structures must start and end within the same entity. Nested exception: XML document structures must start and end within the same entity.</soap:Text></soap:Reason><soap:Detail><Error xmlns="urn:zimbra"><Code>service.PARSE_ERROR</Code><Trace>com.zimbra.cs.service.ServiceException : parse error: Error on line 5 of document : XML document structures must start and end within the same entity. Nested exception: XML document structures must start and end within the same entity.
    .....
    </soap:Envelope>

    The document header is below. The complaint is about line #5 and I don't see an error. What am I missing.

    <soap:Envelope xmlns:soap="http://www.w3.org/2003/05/soap-envelope">
    <soap:Header>
    <context xmlns="urn:zimbra">
    <sessionId id="95"/>
    <authToken> the Token </authToken>
    </context>
    </soap:Header>

    Thanks.

    Rob Tanner
    Linfield College

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Rob, Please use CODE in [] and [/CODE] to wrap code or XML that you post. It will make it much easier to read.

    Looks like your missing a closing </soap:Envelope> tag in your SOAP. Or was that a typo?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. soap CreateAccountRequest code
    By crossany in forum Developers
    Replies: 14
    Last Post: 09-01-2008, 11:26 PM
  2. SOAP Problem again!
    By bongkot in forum Developers
    Replies: 1
    Last Post: 08-01-2007, 04:16 AM
  3. php CreateAccountRequest via SOAP
    By bookatechie in forum Developers
    Replies: 2
    Last Post: 05-02-2007, 11:28 AM
  4. Problem to sync EXDATE in iCal with SOAP request
    By JackyQiu in forum Developers
    Replies: 1
    Last Post: 12-07-2006, 12:21 PM
  5. SSL Cert Problem using SOAP API
    By pbwebguy in forum Developers
    Replies: 1
    Last Post: 06-06-2006, 05:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •