Results 1 to 10 of 15

Thread: restore fails!

Hybrid View

  1. #1
    Join Date
    Feb 2006
    Posts
    38
    Rep Power
    9

    Default restore fails!

    Hey all,

    I tried to upgrade to 3.1.0 but it failed with a mysql error. I had made a copy of my /opt/zimbra install after the failed upgrade i removed zimbra and did a fresh install of 3.0.1 ( the same version i had been using before)

    I copy the backed up files back into /opt/zimbra (after stopping zimbra ) and start zimbra back up. It starts fine. I can log in to the admin console fine as well. i can log in as a user , but when i do I get the following:

    msg - system failure: missing blob for id: 2880, change: 3127
    com.zimbra.cs.service.ServiceException: system failure: missing blob for id: 2880, change: 3127
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:131)
    at com.zimbra.cs.mailbox.MailItem.getBlob(MailItem.ja va:669)
    at com.zimbra.cs.mailbox.MessageCache.fetchFromStore( MessageCache.java:189)
    at com.zimbra.cs.mailbox.MessageCache.getMimeMessage( MessageCache.java:154)
    at com.zimbra.cs.mailbox.Message.getMimeMessage(Messa ge.java:280)
    at com.zimbra.cs.service.mail.ToXML.encodeMessageAsMP (ToXML.java:477)
    at com.zimbra.cs.service.mail.GetMsg.handle(GetMsg.ja va:84)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:255)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:163)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:228)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:154)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)

    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver



    can someone PLEASE shed some light on this, I need to fix it fast.

    thanks

  2. #2
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    This means the data on disk does not match the blobs (aka message bodies) on disk. Was Zimbra fully shutdown when you made your copy of /opt/zimbra? If not you may not have a consistent backup of the data.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    Join Date
    Feb 2006
    Posts
    38
    Rep Power
    9

    Default

    zimbra was shutdown with zmcontrol shutdown prior to the copy


    is there any way to resolve this?

  4. #4
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    You could try the restore again. Not really any other way to "resync" the data and blobs.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  5. #5
    Join Date
    Feb 2006
    Posts
    38
    Rep Power
    9

    Default

    is there any other way to pull the messages out so they can be recovered?

  6. #6
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    You could use lmtpinject to reload the mail but that won't fix the database as it will be looking for the old mail id's. Did you try to re-restore that mailbox?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. How to restore the mail(/opt/zimbra/store)?
    By victorLeong in forum Administrators
    Replies: 11
    Last Post: 04-24-2009, 09:41 PM
  2. Disaster Recovery Restore of Zimbra on Apple OS X
    By k.beeby@albion.co.uk in forum Administrators
    Replies: 2
    Last Post: 03-11-2008, 08:40 AM
  3. Network Edition restore problems??
    By jdell in forum Administrators
    Replies: 0
    Last Post: 10-25-2006, 05:00 PM
  4. restore account to a point in time in the past
    By shanson in forum Administrators
    Replies: 1
    Last Post: 07-24-2006, 05:50 PM
  5. Restore options for OSS version
    By iain in forum Administrators
    Replies: 2
    Last Post: 03-22-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •