My biggest gripe with my stupid Iphone was its lack of push email from zimbra Open Source edition. But I have fixed it.

oh yeah, aint zimbra sweet!

and z-push..

on debian etch apache-ssl only listens on port 443, so no conflicts - you can do this on your zimbra box..

apt-get install apache-ssl php-mail libapache-mod-php4

set up your self signed certificate. common name is your hosts fqdn

get the zpush package from
Z-Push - open source push technology

follow the instructions to install. change the backend source to IMAP

a slight modification required...

/var/www/z-push/backend# vi imap.php

around line 592, comment out existing and add corrected... this stops z-push marking your emails as read.

// $mail = @imap_fetchheader($this->_mbox, $id,FT_PREFETCHTEXT | FT_UID) . @imap_body($this->_mbox, $id, FT_PEEK | FT_UID);
$mail = @imap_fetchheader($this->_mbox, $id, FT_UID) . @imap_body($this->_mbox, $id, FT_PEEK | FT_UID);


Set up your iphone with an exchange activesync email - disable contact and calender sync, only email sync... and it is a ssl connection...


send yourself an email and be gratified with the melodical "ding-dong"

I have no comments on battery and data usage.

cheers

I am feeling somewhat smug now. lol.