Results 1 to 1 of 1

Thread: [SOLVED] Mysql Error 2002 when restoring

  1. #1
    Join Date
    Mar 2007
    New England
    Rep Power

    Default [SOLVED] Mysql Error 2002 when restoring

    Using 5.0.12.

    I moved all my stuff over to a vm server running Ubuntu 8.04 server, so I could upgrade from Ubuntu 7.10 full to 8.04 server.

    Everything seemed to be running fine until I tried to do a cold backup using the lvm backup script, and it crashed out, however the server was still running, but it seemed there may be some bad sectors.

    The process is:
    Install zimbra using -s
    copy the old zimbra directory over (I've tried tarring, rsync, and copy).

    Then I re-install zimbra for it to "upgrade". When I tell it I want to check message store, it takes a while then spits out
    "/opt/zimbra/mysql/bin/mysqlcheck: Got error: 2002: Can't connect to local MySQL server through socket '/opt/zimbra/db/mysql.sock' (2) when trying to connect".

    If I continue the "upgrade", it fails at starting mysqld.

    I've tried using an older backup, but that is still showing the same errors.

    And now, the vm server is telling me the mysql server is not running (It restarted with a cold backup), so I am kinda without an email server right now. Any help would be appreciated.


    I had searched the forums, but apparently my keywords were wrong. I found another thread that talked about it. I instead did a full install, then moved the directory, then used a backup from earlier this morning, and it finally worked. I'm thinking it was the full vanilla install that finally fixed it, I had just done the -s install previously.
    Last edited by Cryophallion; 02-23-2009 at 11:40 AM. Reason: Solved

Similar Threads

  1. [SOLVED] mysql not starting after restoring from backup
    By jschnip in forum Administrators
    Replies: 4
    Last Post: 02-02-2009, 07:07 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. [SOLVED] Install Problem in Ubuntu 6.06 Server
    By xtimox in forum Installation
    Replies: 16
    Last Post: 03-27-2008, 09:36 AM
  4. DNS Questions and Trouble Installing
    By smurraysb in forum Installation
    Replies: 22
    Last Post: 03-14-2008, 03:27 PM
  5. Replies: 18
    Last Post: 03-20-2006, 01:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts