Results 1 to 3 of 3

Thread: Accepting unqualified usernames?

Hybrid View

  1. #1
    Join Date
    Jan 2009
    Posts
    12
    Rep Power
    6

    Post Accepting unqualified usernames?

    I have some iPhone users who access my Zimbra server as a plain IMAP client (they don't want to be notified for each new message, they want pull messaging). They're a little old-school and would like to be able to send mail to the unqualified <username>, not just <username@my.happy.domain>. I poked around and found the postfix reject_non_fqdn_recipient, but I can't seem to make that go. I have configured:

    $ zmprov gcf zimbraMtaRestriction
    zimbraMtaRestriction: reject_invalid_hostname

    Which used to contain an additional "zimbraMtaRestriction: reject_non_fqdn_recipient" specification, but after zmmtactl stop && zmmtactl start, I still see that reject_non_fqdn_recipient shows up in the postfix main.cf. Can anyone tell me the supported way to do this?

    My Zimbra installation sits behind a router ACL protecting SMTP, and I have a spam/virus appliance, so I'm not worried about spammers, just relaying/delivering for my authenticated clients.

    Thanks!

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    So how did you remove the reject_non_fqdn_recipient line ? You may need to perform a full ZCS stop / restart for the main.cf to be written correctly. I would also recommend that you consider upgrading to 5.0.13 when you can aswell

  3. #3
    Join Date
    Jan 2009
    Posts
    12
    Rep Power
    6

    Default

    I removed the line by using zmprov:

    $ zmprov mcf zimbraMtaRestriction reject_invalid_hostname

    I did not add any additional lines. I will try the full stop and start when I get a chance, and I am planning an upgrade to 5.0.13 soon.

Similar Threads

  1. Replies: 0
    Last Post: 02-04-2009, 12:41 PM
  2. [SOLVED] not accepting any email with postfix
    By BrianA in forum Installation
    Replies: 6
    Last Post: 07-29-2008, 02:14 AM
  3. Not accepting mail for my domain
    By pksings in forum Installation
    Replies: 3
    Last Post: 02-05-2007, 10:30 AM
  4. Events don't show up in my Outlook calendar after accepting the invitation
    By graefen in forum Zimbra Connector for Outlook
    Replies: 2
    Last Post: 05-23-2006, 07:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •