Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Connection refused = no mail delivered locally with lmtp

  1. #11
    Join Date
    Apr 2006
    Posts
    33
    Rep Power
    9

    Default

    I disabled SELinux completely now, no difference.

    With regards to the missing FQDN in the hosts file it is only required if DNS doesn't reflect the proper IP for the hostname, which it does in my case. But still I added in the public ip with the FQDN in the hosts file just to be sure.

    Unfortunately it still doesnt work.

  2. #12
    Join Date
    Apr 2006
    Posts
    33
    Rep Power
    9

    Default

    Is there really nothing I can do to debug this better? Nowhere to switch debugging mode on, no logs to trace nothing to check?

  3. #13
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    The only two things I can suggest at the moment are to try with IPTABLES disabled and check your DNS entries using this checking site.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    Join Date
    Apr 2006
    Posts
    33
    Rep Power
    9

    Default Still not working

    To make sure IPTables is not the problem I tried the following:

    1. Moved the server to an IP address that is not setup as primary MX in DNS
    2. Flushed all IPTables
    3. Fixed /etc/hosts to point the LMTP/SMTP name of the server to its correct IP address and remove "Enable DNS Lookups" in Admin
    4. Requeued the messages that failed before

    The result is still the same, the messages fail delivery to any email account that have delivery set up via LMTP. The error message is still :
    Code:
    May  5 11:32:59 zimbraserver postfix/lmtp[32149]: C55A84C88F: to=<denis@mydomain.com>, relay=none, delay=0, status=deferred (connect to zimbraserver.mydomain.com[192.168.192.168]: Connection refused)
    (192.168.192.168 is substituted with the real/correct IP address of the zimbraserver.mydomain.com)

    This problem is severely annoying, and I am a bit baffled that there isn't anything I can do to debug this? I am checking the /var/log/zimbra.log, the application logs in /opt/zimbra but I can't seem to find anything telling me why connection is refused when using LMTP??

    Is the /etc/services file important? The settings there suggest the LMTP port should have been 24, but Zimbra does set up LMTP at 10025 afaik?

  5. #15
    Join Date
    Apr 2006
    Posts
    33
    Rep Power
    9

    Default

    FWIW, here is the complete trace of the zimbra.log when trying to deliver a message to me via LMTP :
    Code:
    May  5 11:43:40 zimbraserver postfix/postsuper[7047]: Requeued: 1 message
    May  5 11:43:58 zimbraserver postfix/pickup[6385]: 2596A4C88C: uid=502 from=<denis@mydomain.com> orig_id=743794C88D
    May  5 11:43:58 zimbraserver postfix/cleanup[6392]: 2596A4C88C: message-id=<445B1BA8.6080505@mydomain.com>
    May  5 11:43:58 zimbraserver postfix/qmgr[6387]: 2596A4C88C: from=<denis@mydomain.com>, size=3098, nrcpt=1 (queue active)
    May  5 11:43:58 zimbraserver amavis[4265]: (04265-01) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20060505T114358-04265: <denis@mydomain.com> -> <denis@mydomain.com> Received: SIZE=3098 from zimbraserver.mydomain.com ([127.0.0.1]) by localhost (zimbraserver.mydomain.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 04265-01 for <denis@mydomain.com>; Fri,  5 May 2006 11:43:58 +0200 (CEST)
    May  5 11:43:58 zimbraserver amavis[4265]: (04265-01) Checking: 8vLb9qD4qj-R [127.0.0.1] <denis@mydomain.com> -> <denis@mydomain.com>
    May  5 11:43:58 zimbraserver amavis[4265]: (04265-01) cached 68b329da9893e34099c7d8ad5cb9c940 from <denis@mydomain.com> (1,0)
    May  5 11:43:58 zimbraserver postfix/smtpd[6461]: connect from localhost.localdomain[127.0.0.1]
    May  5 11:43:58 zimbraserver postfix/smtpd[6461]: 55D8D4C88D: client=localhost.localdomain[127.0.0.1]
    May  5 11:43:58 zimbraserver postfix/cleanup[6392]: 55D8D4C88D: message-id=<445B1BA8.6080505@mydomain.com>
    May  5 11:43:58 zimbraserver postfix/qmgr[6387]: 55D8D4C88D: from=<denis@mydomain.com>, size=4042, nrcpt=1 (queue active)
    May  5 11:43:58 zimbraserver postfix/smtpd[6461]: disconnect from localhost.localdomain[127.0.0.1]
    May  5 11:43:58 zimbraserver amavis[4265]: (04265-01) FWD via SMTP: <denis@mydomain.com> -> <denis@mydomain.com>, 250 2.6.0 Ok, id=04265-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as 55D8D4C88D
    May  5 11:43:58 zimbraserver amavis[4265]: (04265-01) Passed CLEAN, LOCAL [127.0.0.1] [195.159.43.66] <denis@mydomain.com> -> <denis@mydomain.com>, Message-ID: <445B1BA8.6080505@mydomain.com>, mail_id: 8vLb9qD4qj-R, Hits: -4.319, 245 ms
    May  5 11:43:58 zimbraserver postfix/smtp[6404]: 2596A4C88C: to=<denis@mydomain.com>, relay=127.0.0.1[127.0.0.1], delay=18, status=sent (250 2.6.0 Ok, id=04265-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as 55D8D4C88D)
    May  5 11:43:58 zimbraserver postfix/qmgr[6387]: 2596A4C88C: removed
    May  5 11:43:58 zimbraserver amavis[4265]: (04265-01) extra modules loaded: Net/LDAP/Bind.pm
    May  5 11:43:58 zimbraserver postfix/lmtp[6468]: 55D8D4C88D: to=<denis@mydomain.com>, relay=none, delay=0, status=deferred (connect to zimbraserver.mydomain.com[192.168.192.168]: Connection refused)
    This was actually after trying to alter the /etc/services file and restarting Zimbra, just to eliminate that as a source of the problem.

  6. #16
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Well, 10024 is the amavis port for Zimbra and you should have DNS lookup enabled for 'normal' inbound/outbound mail delivery unless you're relaying through another SMTP server.

    Can you actually telnet to port 10025 on the zimbar server and from another PC?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #17
    Join Date
    Apr 2006
    Posts
    33
    Rep Power
    9

    Default

    Well, no actually I can't telnet to anything other than localhost port 10025. In some of the netstat -l dumps above you can se why. Zimbra has bound that port to localhost.localdomain only. Is this the problem? If so, how can I make Zimbra bind to any interface or specifically the public one?

    I have tried setting options in admin under zimbraserver.mydomain.com :
    Code:
    Service host name 	zimbraserver.mydomain.com
    LMTP advertised name: 	zimbraserver.mydomain.com
    LMTP bind address: zimbraserver.mydomain.com
    For that matter, the LMTP bind address used to be empty, but that didn't work either.

    Thanks for the assistance!
    Last edited by denisb; 05-05-2006 at 05:11 AM.

  8. #18
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    9

    Default

    Zimbra implements LMTP on port 7025, could you run this command for me:

    zmprov ga denis@mydomain.com | grep -i transport

    This will tell you were it is trying to send the mail to could be numerous things, but what you would like it to return is most likey:

    zimbraMailTrasport = lmtp:<mailstore_server>:7025

  9. #19
    Join Date
    Apr 2006
    Posts
    33
    Rep Power
    9

    Default

    Hi rsharpe, thanks for your input. Cursed be the notion of all forums to divide threads into short pages..

    I have already listed my configuration above. The thing is everything works pretty much okay when I set my user to not use LMTP, and instead forwards mails to mysel to another server (like in the Split Domain setup).

    It is when I switch my user to use lmtp like you suggest checking for, that things start to break. Just for reference here is the output you requested:
    Code:
    zmprov ga denis@mydomain.com | grep -i transport
    zimbraMailTransport: lmtp:zimbraserver.mydomain.com
    The 7025 port is definitely reachable via telnet on the zimbraserver.mydomain.com address.. I just checked.

  10. #20
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    19

    Default

    Quote Originally Posted by denisb
    Hi rsharpe, thanks for your input. Cursed be the notion of all forums to divide threads into short pages..

    I have already listed my configuration above. The thing is everything works pretty much okay when I set my user to not use LMTP, and instead forwards mails to mysel to another server (like in the Split Domain setup).

    It is when I switch my user to use lmtp like you suggest checking for, that things start to break. Just for reference here is the output you requested:
    Code:
    zmprov ga denis@mydomain.com | grep -i transport
    zimbraMailTransport: lmtp:zimbraserver.mydomain.com
    The 7025 port is definitely reachable via telnet on the zimbraserver.mydomain.com address.. I just checked.
    \

    Try adding the :7025 at the end of the value. Not sure we default to 7025 is no port is found. So like

    zimbraMailTransport: lmtp:zimbraserver.mydomain.com:7025
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •