Results 1 to 10 of 21

Thread: Connection refused = no mail delivered locally with lmtp

Threaded View

  1. #1
    Join Date
    Apr 2006
    Posts
    33
    Rep Power
    9

    Default Connection refused = no mail delivered locally with lmtp

    I am currently betatesting a Zimbra setup for our company and have things setup like this :

    Zimbra is prefered MX in DNS but has port 25 blocked for everyone else except the zimbraserver and my office IP.
    I have setup all the existing users as forward users with the zimbraMailTransport setting as detailed in the Split Domain Wiki document. For what it's worth this part of the setup works fine.

    As a test before starting the proper migration (with opening SMTP port on the Zimbra server and letting it be the master in the setup) I altered my own account (denis@mydomain.com) setting zimbraMailTransport = lmtp:zimbraserver.mydomain.com

    I then sent a few test messages to myself via the zimbraserver SMTP, but these consistently fail delivery with the ominus "connection refused zimbraserver.mydomain.com" message.

    I have opened all the ports the server is listening to like this:
    Code:
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:smtp
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:7025
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:ldap
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:10024
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:10025
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:7306
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:7307
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:3310
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:7780
    ACCEPT     tcp  --  zimbraserver.mydomain.com    anywhere            state NEW tcp dpt:8005
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:smtp
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:7025
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:ldap
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:10024
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:10025
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:7306
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:7307
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:3310
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:7780
    ACCEPT     tcp  --  localhost.localdomain  anywhere            state NEW tcp dpt:8005
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ssh
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:http
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:https
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:7071
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:ldaps
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:smtp
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:imap
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:imaps
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:imaps
    ACCEPT     tcp  --  anywhere             anywhere            state NEW tcp dpt:99
    I checked connecting with telnet to both port 25, 10025 and 7025 from the server and this works fine.

    I then tailed the /var/log/zimbra.log and I find this when requeuing the messages :

    Code:
    Apr 28 11:36:09 ms1 postfix/postsuper[5988]: Requeued: 2 messages
    Apr 28 11:36:09 ms1 postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.2.9/conf/main.cf
    Apr 28 11:36:09 ms1 postfix/postfix-script: starting the Postfix mail system
    Apr 28 11:36:09 ms1 postfix/master[6038]: daemon started -- version 2.2.9, configuration /opt/zimbra/postfix-2.2.9/conf
    Apr 28 11:36:09 ms1 postfix/pickup[6046]: 6EFEA4C881: uid=502 from=<Administrator@oter.intra> orig_id=689E74C883
    Apr 28 11:36:09 ms1 postfix/cleanup[6050]: 6EFEA4C881: message-id=<000001c66a78$4457eab0$0500000a@intra>
    Apr 28 11:36:09 ms1 postfix/qmgr[6047]: 6EFEA4C881: from=<Administrator@oter.intra>, size=61826, nrcpt=1 (queue active)
    Apr 28 11:36:09 ms1 postfix/pickup[6046]: 744824C882: uid=502 from=<denis@mydomain.com> orig_id=046124C886
    Apr 28 11:36:09 ms1 postfix/cleanup[6050]: 744824C882: message-id=<4450AC33.7040403@mydomain.com>
    Apr 28 11:36:09 ms1 amavis[3747]: (03747-01) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20060428T113609-03747: <Administrator@oter.intra> -> <denis@mydomain.com> Received: SIZE=61826 from zimbraserver.mydomain.com ([127.0.0.1]) by localhost (zimbraserver.mydomain.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 03747-01 for <denis@mydomain.com>; Fri, 28 Apr 2006 11:36:09 +0200 (CEST)
    Apr 28 11:36:09 ms1 postfix/qmgr[6047]: 744824C882: from=<denis@mydomain.com>, size=213996, nrcpt=1 (queue active)
    Apr 28 11:36:09 ms1 zimbramon[2865]: 2865:info: Starting snmp
    Apr 28 11:36:09 ms1 amavis[3748]: (03748-01) ESMTP::10024 /opt/zimbra/amavisd/tmp/amavis-20060428T113609-03748: <denis@mydomain.com> -> <denis@mydomain.com> Received: SIZE=213996 from zimbraserver.mydomain.com ([127.0.0.1]) by localhost (zimbraserver.mydomain.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 03748-01 for <denis@mydomain.com>; Fri, 28 Apr 2006 11:36:09 +0200 (CEST)
    Apr 28 11:36:09 ms1 amavis[3747]: (03747-01) Checking: WMTyU+PB-tpe [127.0.0.1] <Administrator@oter.intra> -> <denis@mydomain.com>
    Apr 28 11:36:09 ms1 zimbramon[2865]: 2865:info: Starting spell
    Apr 28 11:36:09 ms1 amavis[3748]: (03748-01) Checking: UV-f93YUnLVr [127.0.0.1] <denis@mydomain.com> -> <denis@mydomain.com>
    Apr 28 11:36:09 ms1 amavis[3748]: (03748-01) spam_scan: not wasting time on SA, message longer than 65536 bytes: 4920+206025
    Apr 28 11:36:09 ms1 postfix/smtpd[6123]: initializing the server-side TLS engine
    Apr 28 11:36:09 ms1 postfix/smtpd[6123]: connect from localhost.localdomain[127.0.0.1]
    Apr 28 11:36:09 ms1 postfix/smtpd[6123]: D888C4C883: client=localhost.localdomain[127.0.0.1]
    Apr 28 11:36:09 ms1 postfix/cleanup[6066]: D888C4C883: message-id=<4450AC33.7040403@mydomain.com>
    Apr 28 11:36:09 ms1 postfix/qmgr[6047]: D888C4C883: from=<denis@mydomain.com>, size=214432, nrcpt=1 (queue active)
    Apr 28 11:36:09 ms1 postfix/smtpd[6123]: disconnect from localhost.localdomain[127.0.0.1]
    Apr 28 11:36:09 ms1 amavis[3748]: (03748-01) FWD via SMTP: <denis@mydomain.com> -> <denis@mydomain.com>, 250 2.6.0 Ok, id=03748-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as D888C4C883
    Apr 28 11:36:09 ms1 amavis[3748]: (03748-01) Passed CLEAN, LOCAL [127.0.0.1] [195.159.43.66] <denis@mydomain.com> -> <denis@mydomain.com>, Message-ID: <4450AC33.7040403@mydomain.com>, mail_id: UV-f93YUnLVr, Hits: -, 397 ms
    Apr 28 11:36:09 ms1 postfix/smtp[6086]: 744824C882: to=<denis@mydomain.com>, relay=127.0.0.1[127.0.0.1], delay=-736, status=sent (250 2.6.0 Ok, id=03748-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as D888C4C883)
    Apr 28 11:36:09 ms1 postfix/qmgr[6047]: 744824C882: removed
    Apr 28 11:36:09 ms1 amavis[3748]: (03748-01) extra modules loaded: Net/LDAP/Bind.pm
    Apr 28 11:36:09 ms1 postfix/lmtp[6129]: D888C4C883: to=<denis@mydomain.com>, relay=none, delay=0, status=deferred (connect to zimbraserver.mydomain.com[192.168.192.168]: Connection refused)
    Apr 28 11:36:10 ms1 postfix/smtpd[6123]: connect from localhost.localdomain[127.0.0.1]
    Apr 28 11:36:10 ms1 postfix/smtpd[6123]: B0E8E4C882: client=localhost.localdomain[127.0.0.1]
    Apr 28 11:36:10 ms1 postfix/cleanup[6050]: B0E8E4C882: message-id=<000001c66a78$4457eab0$0500000a@intra>
    Apr 28 11:36:10 ms1 postfix/qmgr[6047]: B0E8E4C882: from=<Administrator@oter.intra>, size=62757, nrcpt=1 (queue active)
    Apr 28 11:36:10 ms1 postfix/smtpd[6123]: disconnect from localhost.localdomain[127.0.0.1]
    Apr 28 11:36:10 ms1 amavis[3747]: (03747-01) FWD via SMTP: <Administrator@oter.intra> -> <denis@mydomain.com>, 250 2.6.0 Ok, id=03747-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as B0E8E4C882
    Apr 28 11:36:10 ms1 postfix/lmtp[6129]: B0E8E4C882: to=<denis@mydomain.com>, relay=none, delay=0, status=deferred (connect to zimbraserver.mydomain.com[192.168.192.168]: Connection refused)
    Apr 28 11:36:10 ms1 amavis[3747]: (03747-01) Passed CLEAN, LOCAL [127.0.0.1] [195.159.43.66] <Administrator@oter.intra> -> <denis@mydomain.com>, Message-ID: <000001c66a78$4457eab0$0500000a@intra>, mail_id: WMTyU+PB-tpe, Hits: 1.205, 1286 ms
    Apr 28 11:36:10 ms1 postfix/smtp[6065]: 6EFEA4C881: to=<denis@mydomain.com>, relay=127.0.0.1[127.0.0.1], delay=-735, status=sent (250 2.6.0 Ok, id=03747-01, from MTA([127.0.0.1]:10025): 250 Ok: queued as B0E8E4C882)
    Apr 28 11:36:10 ms1 postfix/qmgr[6047]: 6EFEA4C881: removed
    Apr 28 11:36:10 ms1 amavis[3747]: (03747-01) extra modules loaded: Net/LDAP/Bind.pm
    Note: the 192.168.192.168 address is not the real address I use.

    I am a bit puzzled by this, is there a port I didn't open, something I have overlooked? This log snipped was after I altered the servers /etc/hosts file adding :
    Code:
    127.0.0.1 localhost localhost.localdomain zimbraserver zimbraserver.mydomain.com
    But even without this (and the server has a correct IP in DNS) it produces the exact same problem and messages..

    Any help, insight in what could be wrong would be highly appreciated!

    Regards
    Last edited by denisb; 04-28-2006 at 04:25 AM.

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 02:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 09:09 AM
  4. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 04:34 PM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •