Results 1 to 6 of 6

Thread: zimbra "freezes" when a certain user logs in.

  1. #1
    Join Date
    Dec 2008
    Location
    vienna/austria
    Posts
    59
    Rep Power
    7

    Default zimbra "freezes" when a certain user logs in.

    Our Zimbra runs fine. But there is one user that suddenly can only login with the standard interface. As soon as he tries to use the advanced Ajax-interface the page displays the initial "loading ..." and "If you are using a slow connection or an older computer, you may want to switch to the Standard (HTML) version." Thats it. The page stays like this forever. The use can click on the "Standard Version" and this works fine.

    The problems occures with FireFox,Opera and IE under linux and windows.

    The problems started when I added a bunch of new filterrules for this user using the zmmailbox-command, but maybe thats a coincidence. I deleted all the rules later but the problems consists. I restarted zimbra, I upgraded to newest 5.0.14 (including the database-integrity-checks) but it didnt help.

    I quite stuck now, cause the zimbra-logs didnt show anything strange, but I've to admit that I'm quite new to zimbra and dont know which logs could be really relevant here and not even how to turn on extendend logging/debugging for this logs.

    Any help on solving the problem or finding the problems in the logs greatly appreatiated
    thnx

  2. #2
    Join Date
    Jun 2008
    Location
    Berkeley, CA
    Posts
    1,474
    Rep Power
    9

    Default

    You might try having the user export his account. (Preferences:Import/Export.) Then delete the account, recreate it, and have him import it.

    Might want to do this on a dummy account first just to make sure all the types of data the user needs will be preserved. Based on looking at the UI for Import/Export, it seems that each of the six types of data will be preserved, but not necessarily preferences or filters.

  3. #3
    Join Date
    Nov 2007
    Location
    Zürich, Switzerland
    Posts
    40
    Rep Power
    8

    Default

    Hi,

    I have exactly the same problem.
    A user could login without any problems until last week. Suddenly, the Ajax client does not load anymore (standard client works). I tried with several browsers on several systems, but had no success. Logging in with another user works without any problems. So it looks like this account has a problem...

    Did anyone found a solution for that problem?

    Thanks.
    Regards,
    Tobias

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    25

    Default

    Ask the user to login then check /opt/zimbra/log/mailbox.log to see if you are getting any error messages; it is possible a corrupt message.

  5. #5
    Join Date
    Nov 2007
    Location
    Zürich, Switzerland
    Posts
    40
    Rep Power
    8

    Default

    I did that, here are the results:

    User without problems:
    Code:
    2010-03-14 18:05:34,769 INFO  [btpool0-3://localhost/service/soap/AuthRequest] [oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - AuthRequest
    2010-03-14 18:05:34,941 INFO  [btpool0-3://localhost/service/soap/AuthRequest] [oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - AuthRequest
    2010-03-14 18:05:34,959 INFO  [btpool0-3://localhost:7071/service/admin/soap/GetDomainInfoRequest] [ip=127.0.0.1;] soap - GetDomainInfoRequest
    2010-03-14 18:05:34,977 INFO  [btpool0-3://localhost/service/soap/BatchRequest] [name=admin@domain.ch;mid=2;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - BatchRequest
    2010-03-14 18:05:34,977 INFO  [btpool0-3://localhost/service/soap/BatchRequest] [name=admin@domain.ch;mid=2;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - (batch) GetInfoRequest
    2010-03-14 18:05:35,035 INFO  [btpool0-3://localhost/service/soap/BatchRequest] [name=admin@domain.ch;mid=2;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - (batch) SearchRequest
    2010-03-14 18:05:36,860 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=admin@domain.ch;mid=2;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - BatchRequest
    2010-03-14 18:05:36,860 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=admin@domain.ch;mid=2;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - (batch) GetMailboxMetadataRequest
    2010-03-14 18:05:38,453 INFO  [btpool0-1://webmail.domain.ch/service/soap/SearchRequest] [name=admin@domain.ch;mid=2;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - SearchRequest
    2010-03-14 18:05:41,622 INFO  [btpool0-10://webmail.domain.ch/service/soap/SearchRequest] [name=admin@domain.ch;mid=2;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - SearchRequest
    2010-03-14 18:05:47,136 INFO  [btpool0-10://webmail.domain.ch/service/soap/GetMiniCalRequest] [name=admin@domain.ch;mid=2;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - GetMiniCalRequest
    2010-03-14 18:05:52,375 INFO  [btpool0-10://webmail.domain.ch/service/soap/SearchRequest] [name=admin@domain.ch;mid=2;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - SearchRequest
    2010-03-14 18:06:00,143 INFO  [btpool0-10://webmail.domain.ch/service/soap/EndSessionRequest] [name=admin@domain.ch;mid=2;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - EndSessionRequest
    User with problems:
    Code:
    2010-03-14 18:07:49,179 INFO  [btpool0-3://localhost/service/soap/AuthRequest] [oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - AuthRequest
    2010-03-14 18:07:49,254 INFO  [btpool0-3://localhost/service/soap/AuthRequest] [oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - AuthRequest
    2010-03-14 18:07:49,307 INFO  [btpool0-3://localhost:7071/service/admin/soap/GetDomainInfoRequest] [ip=127.0.0.1;] soap - GetDomainInfoRequest
    2010-03-14 18:07:49,325 INFO  [btpool0-3://localhost/service/soap/BatchRequest] [name=tobias@domain.ch;mid=3;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - BatchRequest
    2010-03-14 18:07:49,326 INFO  [btpool0-3://localhost/service/soap/BatchRequest] [name=tobias@domain.ch;mid=3;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - (batch) GetInfoRequest
    2010-03-14 18:07:49,550 INFO  [btpool0-3://localhost/service/soap/BatchRequest] [name=tobias@domain.ch;mid=3;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - (batch) SearchRequest
    2010-03-14 18:07:51,390 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=tobias@domain.ch;mid=3;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - BatchRequest
    2010-03-14 18:07:51,390 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=tobias@domain.ch;mid=3;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - (batch) GetMailboxMetadataRequest
    2010-03-14 18:07:52,779 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=webmaster@domain.ch;aname=tobias@domain.ch;mid=13;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - BatchRequest
    2010-03-14 18:07:52,779 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=webmaster@domain.ch;aname=tobias@domain.ch;mid=13;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - (batch) GetInfoRequest
    2010-03-14 18:07:52,954 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=webmaster@domain.ch;aname=tobias@domain.ch;mid=13;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - (batch) GetTagRequest
    2010-03-14 18:07:52,955 INFO  [btpool0-13://webmail.domain.ch/service/soap/BatchRequest] [name=webmaster@domain.ch;aname=tobias@domain.ch;mid=13;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - (batch) GetFolderRequest
    ### Change to standard html client
    2010-03-14 18:08:04,255 INFO  [btpool0-3://localhost/service/soap/AuthRequest] [oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - AuthRequest
    2010-03-14 18:08:04,303 INFO  [btpool0-3://localhost/service/soap/GetInfoRequest] [name=tobias@domain.ch;mid=3;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - GetInfoRequest
    2010-03-14 18:08:04,448 INFO  [btpool0-3://localhost/service/soap/SearchRequest] [name=tobias@domain.ch;mid=3;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - SearchRequest
    2010-03-14 18:08:04,518 INFO  [btpool0-3://localhost/service/soap/GetInfoRequest] [name=tobias@domain.ch;mid=3;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - GetInfoRequest
    2010-03-14 18:08:04,631 INFO  [btpool0-3://localhost/service/soap/GetAvailableSkinsRequest] [name=tobias@domain.ch;mid=3;oip=10.0.0.71;ua=zclient/6.0.5_GA_2213.UBUNTU8;] soap - GetAvailableSkinsRequest
    2010-03-14 18:08:04,640 INFO  [btpool0-3://localhost:7071/service/admin/soap/GetDomainInfoRequest] [ip=127.0.0.1;] soap - GetDomainInfoRequest
    2010-03-14 18:08:04,858 INFO  [btpool0-3://webmail.domain.ch/service/soap/EndSessionRequest] [name=tobias@domain.ch;mid=3;ip=10.0.0.71;ua=ZimbraWebClient - FF3.0 (Win)/6.0.5_GA_2213.UBUNTU8;] soap - EndSessionRequest
    2010-03-14 18:08:09,105 INFO  [btpool0-13://localhost:7071/service/admin/soap/GetDomainInfoRequest] [ip=127.0.0.1;] soap - GetDomainInfoRequest

  6. #6
    Join Date
    Nov 2007
    Location
    Zürich, Switzerland
    Posts
    40
    Rep Power
    8

    Default

    Problem solved...

    A long time ago I followed this blog post to connect more than one account together: Mailboxes: Sharing vs. Relationships » Zimbra :: Blog

    After checking the account with the troubles I saw that there were to attibutes, one without {}:
    Code:
    zimbra@server:~$ zmprov ga account@domain.ch | grep zimbraChildAccount
    zimbraChildAccount: {d7871f7d-13a5-47d1-8f14-23139be09f0b}
    zimbraChildAccount: d7871f7d-13a5-47d1-8f14-23139be09f0b
    After removing the attribute without {}, the AJAX client works again.

Similar Threads

  1. Replies: 21
    Last Post: 02-04-2010, 10:06 AM
  2. Cleanup after many upgrades
    By tobru in forum Installation
    Replies: 1
    Last Post: 12-23-2007, 09:21 AM
  3. Error loading on Mac OS X 10.4.10 server PPC
    By qprcanada in forum Installation
    Replies: 7
    Last Post: 10-26-2007, 07:25 AM
  4. 4.5 Upgrade failure
    By brained in forum Installation
    Replies: 9
    Last Post: 03-03-2007, 03:30 PM
  5. Post instsallation problems
    By Assaf in forum Installation
    Replies: 14
    Last Post: 01-29-2007, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •