Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: I can't run zimbra!

  1. #1
    Join Date
    Apr 2008
    Location
    Spain
    Posts
    55
    Rep Power
    7

    Default I can't run zimbra!

    Hello,

    Please I need urgent help. We're using Zimbra 5.0.12_GA during 2 months in debian 4. Today I've been restarting the server because we can't receive emails and when I try to start zimbra it shows this message:

    zmcontrol start:
    Code:
    Host mail.obertic.com
    	Starting ldap...Done.
    Unable to determine enabled services from ldap.
    Enabled services read from cache. Service list may be inaccurate.
    	Starting logger...Done.
    	Starting mailbox...Done.
    	Starting imapproxy...Done.
    	Starting antispam...Done.
    	Starting antivirus...Done.
    	Starting snmp...Done.
    	Starting spell...Done.
    	Starting mta...Done.
    	Starting stats...Done.
    after, zmcontrol status:

    Code:
    Host mail.obertic.com
    	antispam                Running
    	antivirus               Running
    	imapproxy               Running
    	ldap                    Running
    	logger                  Stopped
    		logmysql.server is not running
    		zmlogswatchctl is not running
    	mailbox                 Stopped
    		mysql.server is not running.
    	mta                     Running
    	snmp                    Running
    	spell                   Running
    	stats                   Stopped


    My etc/hosts:

    Code:
    127.0.0.1		localhost.localdomain localhost
    82.194.87.236		mail.obertic.com mail
    82.194.87.236		obertic.com obertic
    My etc/resolv.con:

    Code:
    nameserver 82.194.64.28
    nameserver 82.194.80.28

    Thanks

  2. #2
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Please post the following information so we are able to check your DNS setup for you
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

  3. #3
    Join Date
    Apr 2008
    Location
    Spain
    Posts
    55
    Rep Power
    7

    Default

    Thanks

    cat /etc/hosts:

    Code:
    127.0.0.1		localhost.localdomain localhost
    82.194.87.236		mail.obertic.com mail
    82.194.87.236		obertic.com obertic
    cat /etc/resolv.conf:

    Code:
    nameserver 127.0.0.1
    I've installed bind9.

    dig obertic.com mx:

    Code:
    ; <<>> DiG 9.3.4-P1.1 <<>> obertic.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6586
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;obertic.com.			IN	MX
    
    ;; ANSWER SECTION:
    obertic.com.		604800	IN	MX	20 obertic.com.
    obertic.com.		604800	IN	MX	10 mail.obertic.com.
    
    ;; AUTHORITY SECTION:
    obertic.com.		604800	IN	NS	obertic.com.
    
    ;; ADDITIONAL SECTION:
    obertic.com.		604800	IN	A	127.0.0.1
    
    ;; Query time: 16 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Mar 23 21:40:34 2009
    ;; MSG SIZE  rcvd: 96
    dig obertic.com any:

    Code:
    ; <<>> DiG 9.3.4-P1.1 <<>> obertic.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 18786
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;obertic.com.			IN	ANY
    
    ;; ANSWER SECTION:
    obertic.com.		604800	IN	SOA	obertic.com. root.obertic.com. 1 604800 86400 2419200 604800
    obertic.com.		604800	IN	MX	10 mail.obertic.com.
    obertic.com.		604800	IN	MX	20 obertic.com.
    obertic.com.		604800	IN	NS	obertic.com.
    obertic.com.		604800	IN	A	127.0.0.1
    
    ;; ADDITIONAL SECTION:
    obertic.com.		604800	IN	A	127.0.0.1
    
    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Mon Mar 23 21:42:17 2009
    ;; MSG SIZE  rcvd: 153
    host `hostname`:

    Code:
    Host mail.obertic.com not found: 3(NXDOMAIN)
    Why does not found my host?

  4. #4
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Okay, so your BIND install is incorrect for a start so please post your named.conf and the appropriate zone file. Are you behind a firewall on a private IP ? If so your /etc/hosts shows a public IP which is not good. Also you have listed two entries for the same domain in /etc/hosts, I guess you would like mail.domain.com

  5. #5
    Join Date
    Apr 2008
    Location
    Spain
    Posts
    55
    Rep Power
    7

    Default

    Thanks very much, uxbod.

    Bind has been working fine since today, and all system and zimbra have been working. Server is hosted by our provider, I supose that it's installed in a private network, but we've a public ip.

    named.conf shows:

    Code:
    // This is the primary configuration file for the BIND DNS server named.
    //
    // Please read /usr/share/doc/bind9/README.Debian.gz for information on the 
    // structure of BIND configuration files in Debian, *BEFORE* you customize 
    // this configuration file.
    //
    // If you are just adding zones, please do that in /etc/bind/named.conf.local
    
    include "/etc/bind/named.conf.options";
    
    // prime the server with knowledge of the root servers
    zone "." {
    	type hint;
    	file "/etc/bind/db.root";
    };
    
    // be authoritative for the localhost forward and reverse zones, and for
    // broadcast zones as per RFC 1912
    
    zone "localhost" {
    	type master;
    	file "/etc/bind/db.local";
    };
    
    zone "127.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.127";
    };
    
    zone "0.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.0";
    };
    
    zone "255.in-addr.arpa" {
    	type master;
    	file "/etc/bind/db.255";
    };
    
    // zone "com" { type delegation-only; };
    // zone "net" { type delegation-only; };
    
    // From the release notes:
    //  Because many of our users are uncomfortable receiving undelegated answers
    //  from root or top level domains, other than a few for whom that behaviour
    //  has been trusted and expected for quite some length of time, we have now
    //  introduced the "root-delegations-only" feature which applies delegation-only
    //  logic to all top level domains, and to the root domain.  An exception list
    //  should be specified, including "MUSEUM" and "DE", and any other top level
    //  domains from whom undelegated responses are expected and trusted.
    // root-delegation-only exclude { "DE"; "MUSEUM"; };
    
    include "/etc/bind/named.conf.local";
    named.conf.local is included, this is the content:

    Code:
    //
    // Do any local configuration here
    //
    
    // Consider adding the 1918 zones here, if they are not used in your
    // organization
    //include "/etc/bind/zones.rfc1918";
    
    zone "obertic.com" { 
    	type master; 
    	file "/etc/bind/db.obertic"; 
    	};
    And this db.obertic, my zone file for the domain:

    Code:
    ;
    ; BIND data file for local loopback interface
    ;
    $TTL	604800
    @	IN	SOA	obertic.com. root.obertic.com. (
    			      1		; Serial
    			 604800		; Refresh
    			  86400		; Retry
    			2419200		; Expire
    			 604800 )	; Negative Cache TTL
    
                    MX      10 mail            ; MTA primario
                    MX      20 obertic.com.     ; MTA secundario
    
    @	IN	NS	obertic.com.
    @	IN	A	127.0.0.1
    @	IN	MX 10	mail
    @	IN	A	127.0.0.1
    @	IN	MX 20	obertic.com.
    @	IN	A	127.0.0.1
    Thanks
    Last edited by ttortosa; 03-23-2009 at 04:03 PM.

  6. #6
    Join Date
    Apr 2008
    Location
    Spain
    Posts
    55
    Rep Power
    7

    Default

    Trying to do a new install all works except to logmysql.server and mysql.server. In logs from mysql server I see:

    Code:
    090324  8:30:07 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
    090324  8:30:07 [ERROR] Can't start server: cannot resolve hostname!: Success
    Installation of system tables failed!
    dig obertic.com any shows now:

    Code:
    ; <<>> DiG 9.3.4-P1.1 <<>> obertic.com any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 27940
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 4, ADDITIONAL: 5
    
    ;; QUESTION SECTION:
    ;obertic.com.			IN	ANY
    
    ;; ANSWER SECTION:
    obertic.com.		3560	IN	MX	10 mail.obertic.com.
    obertic.com.		495	IN	NS	dns1.canaldominios.com.
    obertic.com.		495	IN	NS	dns4.canaldominios.com.
    obertic.com.		495	IN	NS	dns3.canaldominios.com.
    obertic.com.		495	IN	NS	dns2.canaldominios.com.
    
    ;; AUTHORITY SECTION:
    obertic.com.		495	IN	NS	dns2.canaldominios.com.
    obertic.com.		495	IN	NS	dns1.canaldominios.com.
    obertic.com.		495	IN	NS	dns4.canaldominios.com.
    obertic.com.		495	IN	NS	dns3.canaldominios.com.
    
    ;; ADDITIONAL SECTION:
    mail.obertic.com.	495	IN	A	82.194.87.236
    dns1.canaldominios.com.	66668	IN	A	82.194.64.50
    dns2.canaldominios.com.	66668	IN	A	82.194.64.51
    dns3.canaldominios.com.	66668	IN	A	82.194.64.50
    dns4.canaldominios.com.	66668	IN	A	82.194.64.51
    
    ;; Query time: 1 msec
    ;; SERVER: 82.194.64.28#53(82.194.64.28)
    ;; WHEN: Tue Mar 24 08:59:39 2009
    ;; MSG SIZE  rcvd: 276
    and dig obertic.com mx shows:

    Code:
    ; <<>> DiG 9.3.4-P1.1 <<>> obertic.com mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33549
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 4, ADDITIONAL: 5
    
    ;; QUESTION SECTION:
    ;obertic.com.			IN	MX
    
    ;; ANSWER SECTION:
    obertic.com.		3536	IN	MX	10 mail.obertic.com.
    
    ;; AUTHORITY SECTION:
    obertic.com.		471	IN	NS	dns1.canaldominios.com.
    obertic.com.		471	IN	NS	dns4.canaldominios.com.
    obertic.com.		471	IN	NS	dns3.canaldominios.com.
    obertic.com.		471	IN	NS	dns2.canaldominios.com.
    
    ;; ADDITIONAL SECTION:
    mail.obertic.com.	471	IN	A	82.194.87.236
    dns1.canaldominios.com.	66644	IN	A	82.194.64.50
    dns2.canaldominios.com.	66644	IN	A	82.194.64.51
    dns3.canaldominios.com.	66644	IN	A	82.194.64.50
    dns4.canaldominios.com.	66644	IN	A	82.194.64.51
    
    ;; Query time: 1 msec
    ;; SERVER: 82.194.64.28#53(82.194.64.28)
    ;; WHEN: Tue Mar 24 09:00:03 2009
    ;; MSG SIZE  rcvd: 220
    Thanks

  7. #7
    Join Date
    Apr 2008
    Location
    Spain
    Posts
    55
    Rep Power
    7

    Default

    I also have this error installing zimbra, just after install common zimlets.

    Code:
    Initializing Documents...failed to initialize documents...see logfile for details.

  8. #8
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Why are you binding your ZCS installation to the loopback address If you have a public IP why are you not using it for your server ?

  9. #9
    Join Date
    Apr 2008
    Location
    Spain
    Posts
    55
    Rep Power
    7

    Default

    I changed my resolv.conf to loopback address because I thought DNS didn't work fine yesterday.

    I've modified resolv.conf, and this is the original resolv.conf, that is producing the recent errors in mysqlsever.

    Code:
    nameserver 82.194.64.28
    nameserver 82.194.80.28

  10. #10
    Join Date
    Nov 2006
    Location
    UK
    Posts
    8,017
    Rep Power
    24

    Default

    Okay, so please post again the following now you have changed resolv.conf
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig yourdomain mx
    dig yourdomain any
    host `hostname` <- note backticks and not single quotes

Similar Threads

  1. [SOLVED] Zimbra logwatch.
    By nishith in forum Administrators
    Replies: 5
    Last Post: 06-10-2009, 04:42 PM
  2. Replies: 8
    Last Post: 01-20-2009, 12:06 PM
  3. Big Fubar on 5 FOSS GA Upgrade
    By uxbod in forum Administrators
    Replies: 24
    Last Post: 01-21-2008, 02:37 AM
  4. Zimbra shutdowns every n hours.
    By Andrewb in forum Administrators
    Replies: 13
    Last Post: 08-14-2007, 08:55 AM
  5. Mail logs
    By Rick Baker in forum Installation
    Replies: 8
    Last Post: 01-17-2006, 03:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •