Results 1 to 4 of 4

Thread: Oops! Help! Postfix & mta-dummy

  1. #1
    Join Date
    Mar 2009
    Rep Power

    Default Oops! Help! Postfix & mta-dummy

    I screwed up. Ack.

    I'm running still, thankfully. But, I don't want to do anything further until I figure out how to properly undo what I did without breaking Zimbra (further).

    I was trying to install a command line mailer and forgot about the optional instructions in the Ubuntu 8.04 guide. So, mailx is installed and from the command line it works. (Logwatch doesn't though, that'll be another question).

    So, there is a 'postfix' directory in the /etc directory dated today. When trying to run 'dpkg -i mta-dummy_1.0_all.deb' I get "postfix conflicts with mail-transport-agent.." and so on.

    I also stopped receiving mail until I ran as zimbra zmmtactl restart.

    So, if I run apt-get remove postfix mailx will I break Zimbra? What should I do?

    I would like to end up with the command line mailer so that I can get logwatch to work.



  2. #2
    Join Date
    Nov 2006
    Rep Power


    Just uninstall it as Zimbra contains its own Postfix version which is outside of the normal repository. If you want a command line mail program that has no dependencies then
    apt-get install sendemail

  3. #3
    Join Date
    Mar 2009
    Rep Power


    Okay, thanks. I was afraid that since Zimbra uses postfix that maybe removing postfix would break Zimbra. I removed them and it is still working.

    However, I installed 'sendemail' as you suggested but I still get:

    root@mail:~/Downloads# mail
    The program 'mail' can be found in the following packages:
    * mailx
    * mailutils
    Try: apt-get install <selected package>
    bash: mail: command not found
    and if I just try to run 'sendemail,' I am told "command not found" even though there is a man page giving usage. I am guessing it needs to be in a path and somehow the command "mail" needs to be remapped to "sendemail" for this to work for cron jobs that mail stuff (such as logwatch). Is that right? Can you point me to instructions on how to do so?


    Last edited by kazooless; 04-01-2009 at 10:42 AM.

  4. #4
    Join Date
    Mar 2009
    Rep Power


    Okay, I've got it working now. Being that I am a total hack as it goes with Linux, what I did to get it working may or may not be recommended. And, who knows if I've broken something. So, you've been warned.

    However, I uninstalled logwatch, postfix & mailx. Then I installed "sendemail" according to uxbod's suggestion above. Didn't seem to help or do anything.

    But then I followed the instructions found at this link and added one more thing:

    1) MTA Dummy Package

    "To install mailx without additional postfix" use "mta-dummy" package
    • wget
    • dpkg -i mta-dummy_1.0_all.deb

    Please check my further posts or google for it. It allows installing packages by resolve mailer dependencies.

    2) Use apt-get to install the 'mailx' package.

    3) Edit /etc/mail.rc to add the following:
    set sendmail=/opt/zimbra/postfix/sbin/sendmail

    4) ) Install Logwatch
    • apt-get install logwatch

    Tested mail by CLI & logwatch - OK!
    The last step is what might just be a bad 'hack' by me, but logwatch started working for me after I did this:

    ln -s /opt/zimbra/postfix- /usr/sbin/sendmail
    Hopefully, that will help others, and more hopefully, someone who really knows what they're doing will respond with approval or an understandable correction.



Similar Threads

  1. postdrop fail to create file after upgrade to 5.0.3
    By echoadisan in forum Installation
    Replies: 23
    Last Post: 07-15-2013, 03:02 PM
  2. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  3. changed ip addr/zmmailboxdctl not running
    By pwhite76 in forum Installation
    Replies: 23
    Last Post: 03-11-2009, 11:43 AM
  4. DMZ relay to Zimbra internal host
    By swordfish in forum Installation
    Replies: 12
    Last Post: 02-04-2009, 10:30 AM
  5. mta and postfix can not work
    By wildhuman in forum Administrators
    Replies: 3
    Last Post: 08-12-2006, 08:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts