Page 5 of 5 FirstFirst ... 345
Results 41 to 44 of 44

Thread: [SOLVED] postfix/postqueue fatal: Queue report unavailable - mail system is down

  1. #41
    Join Date
    Oct 2010
    Posts
    22
    Rep Power
    5

    Default

    Quote Originally Posted by tempusfugit View Post
    Odd that didn't take previously.

    cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.0.5 mail.extremexposures.net mail

    cat /etc/resolv.conf
    search extremexposures.net
    nameserver 192.168.0.5

    I did a stop/start again, everything is running - no joy, so I ran the postfix check:
    zimbra@pixserver:~$ postfix check
    sudo: unable to resolve host pixserver
    sudo: unable to resolve host pixserver
    You need to add pixserver to your /etc/hosts

    192.168.0.5 mail.extremexposures.net mail pixserver.extremexposures.net pixserver

    Quote Originally Posted by tempusfugit View Post
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.4.7.5z/conf/main.cf
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.4.7.5z/conf/master.cf
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.4.7.5z/conf/master.cf.in

  2. #42
    Join Date
    Oct 2010
    Posts
    22
    Rep Power
    5

    Default

    Hey dude it is clear you have running exim4, remove it or stop it.

    To stop it and remove it from the rc2.d:

    # /etc/init.d/exim4 stop
    # rm /etc/rc2.d/*exim*

    To remove it just run:
    # aptitude --purge remove exim4

    Which reason you would have exim4 if zimbra does that job?

    Zimbra use postfix Already, you need to dump exim4, it is garbage

    Quote Originally Posted by godmod View Post
    Why the hell is this marked als solved?

    I am experiencing the same problem!
    Hope somebody can help me...

    Some Information for you:

    Code:
    icons:/var/log# cat /etc/hosts
    ### Hetzner Online AG installimage
    # nameserver config
    # IPv4
    
    127.0.0.1 localhost
    78.46.20.10     icons.at                icons
    
    #
    # IPv6
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts
    Code:
    icons:/var/log# cat /etc/resolv.conf
    ### Hetzner Online AG installimage
    # nameserver config
    nameserver 213.133.100.100
    nameserver 213.133.98.98
    nameserver 213.133.99.99
    
    search icons.at
    nameserver 78.46.20.10
    Code:
    icons:/var/log# dig icons.at mx
    
    ; <<>> DiG 9.5.1-P3 <<>> icons.at mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 11542
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;icons.at.                      IN      MX
    
    ;; ANSWER SECTION:
    icons.at.               7200    IN      MX      10 mail.icons.at.
    
    ;; AUTHORITY SECTION:
    icons.at.               7200    IN      NS      ns3.second-ns.de.
    icons.at.               7200    IN      NS      ns.second-ns.com.
    icons.at.               7200    IN      NS      ns1.your-server.de.
    
    ;; ADDITIONAL SECTION:
    mail.icons.at.          7200    IN      A       78.46.20.10
    
    ;; Query time: 17 msec
    ;; SERVER: 213.133.100.100#53(213.133.100.100)
    ;; WHEN: Thu Apr 15 14:16:12 2010
    ;; MSG SIZE  rcvd: 153
    Code:
    icons:/var/log# dig icons.at any
    
    ; <<>> DiG 9.5.1-P3 <<>> icons.at any
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53303
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;icons.at.                      IN      ANY
    
    ;; ANSWER SECTION:
    icons.at.               7200    IN      SOA     ns1.your-server.de. admin.icons.at. 2010041500 86400 1800 3600000 86400
    icons.at.               7200    IN      MX      10 mail.icons.at.
    icons.at.               7200    IN      NS      ns3.second-ns.de.
    icons.at.               7200    IN      NS      ns.second-ns.com.
    icons.at.               7200    IN      NS      ns1.your-server.de.
    icons.at.               7200    IN      A       78.46.20.10
    
    ;; ADDITIONAL SECTION:
    mail.icons.at.          7200    IN      A       78.46.20.10
    
    ;; Query time: 17 msec
    ;; SERVER: 213.133.100.100#53(213.133.100.100)
    ;; WHEN: Thu Apr 15 14:16:25 2010
    ;; MSG SIZE  rcvd: 211
    Code:
    icons:/var/log# host `hostname`
    Host icons not found: 3(NXDOMAIN)




    Code:
    zimbra@icons:/etc/ssh$ zmcontrol -v
    Release 6.0.6_GA_2324.DEBIAN5_64 DEBIAN5_64 FOSS edition.
    Code:
    icons:/var/log# netstat -luntp | grep 25
    tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      3537/exim4
    Code:
    zimbra@icons:/etc/ssh$ dpkg -l | grep postfix
    while zcs stopped:
    Code:
    zimbra@icons:/etc/ssh$ ps aux | grep zimbra
    zimbra    3565  0.0  0.0  34512  1244 pts/1    S    13:54   0:00 su zimbra
    zimbra    3566  0.0  0.0  19292  2140 pts/1    S    13:54   0:00 bash
    zimbra   29741  0.0  0.0  16012  1100 pts/1    R+   14:11   0:00 ps aux
    zimbra   29742  0.0  0.0   5160   776 pts/1    R+   14:11   0:00 grep zimbra
    Code:
    zimbra@icons:/etc/ssh$ ps -u zimbra
      PID TTY          TIME CMD
     3565 pts/1    00:00:00 su
     3566 pts/1    00:00:00 bash
    30175 pts/1    00:00:00 ps
    Code:
    icons:/var/log# netstat -luntp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
    tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      3218/mysqld
    tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      23072/sshd
    tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      3537/exim4
    tcp6       0      0 :::80                   :::*                    LISTEN      2942/apache2
    tcp6       0      0 :::22                   :::*                    LISTEN      23072/sshd
    tcp6       0      0 :::443                  :::*                    LISTEN      2942/apache2
    udp        0      0 78.46.20.10:123         0.0.0.0:*                           3567/ntpd
    udp        0      0 127.0.0.1:123           0.0.0.0:*                           3567/ntpd
    udp        0      0 0.0.0.0:123             0.0.0.0:*                           3567/ntpd
    udp6       0      0 fe80::4261:86ff:fe9:123 :::*                                3567/ntpd
    udp6       0      0 ::1:123                 :::*                                3567/ntpd
    udp6       0      0 :::123                  :::*                                3567/ntpd

    Starting Zimbra. looks fine..
    Code:
    zimbra@icons:/etc/ssh$ zmcontrol start
    Host icons.at
            Starting ldap...Done.
            Starting logger...Done.
            Starting mailbox...Done.
            Starting snmp...Done.
            Starting spell...Done.
            Starting mta...Done.
            Starting stats...Done.
    Testing status...
    Code:
    zimbra@icons:/etc/ssh$ zmcontrol status
    Host icons.at
            ldap                    Running
            logger                  Running
            mailbox                 Running
            mta                     Stopped
                    postfix is not running
            snmp                    Running
            spell                   Running
            stats                   Running
    Code:
    zimbra@icons:/etc/ssh$ postfix check
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/data/postfix/spool
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/main.cf
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf.in
    zimbra.log
    Code:
    Apr 15 14:02:04 icons zmmailboxdmgr[8527]: status requested
    Apr 15 14:02:04 icons zmmailboxdmgr[8527]: file /opt/zimbra/log/zmmailboxd_manager.pid does not exist
    Apr 15 14:02:04 icons zmmailboxdmgr[8527]: assuming no other instance is running
    Apr 15 14:02:04 icons zmmailboxdmgr[8527]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Apr 15 14:02:04 icons zmmailboxdmgr[8527]: assuming no other instance is running
    Apr 15 14:02:04 icons zmmailboxdmgr[8527]: no manager process is running
    Apr 15 14:03:03 icons zimbramon[8649]: 8649:info: Starting services initiated by zmcontrol
    Apr 15 14:03:03 icons slapd[8705]: @(#) $OpenLDAP: slapd 2.4.21 (Mar 24 2010 19:15:31) $#012#011root@build32.lab.zimbra.com:/home/build/p4/main/ThirdParty/openldap/openldap-2.4.21.7z/servers/slapd
    Apr 15 14:03:03 icons slapd[8706]: slapd starting
    Apr 15 14:03:11 icons zimbramon[8649]: 8649:info: Rewriting configs    webxml mailbox amavis antispam antivirus mta sasl
    Apr 15 14:03:28 icons zimbramon[8649]: 8649:info: Starting logger via zmcontrol
    Apr 15 14:03:32 icons zimbramon[8649]: 8649:info: Starting mailbox via zmcontrol
    Apr 15 14:03:32 icons zimbramon[10888]: 10888:info: zmmtaconfig: zmmtaconfig started on icons.at with loglevel=3 pid=10888
    Apr 15 14:03:55 icons zmmailboxdmgr[14332]: status requested
    Apr 15 14:03:55 icons zmmailboxdmgr[14332]: file /opt/zimbra/log/zmmailboxd_manager.pid does not exist
    Apr 15 14:03:55 icons zmmailboxdmgr[14332]: assuming no other instance is running
    Apr 15 14:03:55 icons zmmailboxdmgr[14332]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Apr 15 14:03:55 icons zmmailboxdmgr[14332]: assuming no other instance is running
    Apr 15 14:03:55 icons zmmailboxdmgr[14332]: no manager process is running
    Apr 15 14:03:55 icons zmmailboxdmgr[14339]: start requested
    Apr 15 14:03:55 icons zmmailboxdmgr[14339]: checking if another instance of manager is already running
    Apr 15 14:03:55 icons zmmailboxdmgr[14339]: file /opt/zimbra/log/zmmailboxd_manager.pid does not exist
    Apr 15 14:03:55 icons zmmailboxdmgr[14339]: assuming no other instance is running
    Apr 15 14:03:55 icons zmmailboxdmgr[14339]: file /opt/zimbra/log/zmmailboxd.pid does not exist
    Apr 15 14:03:55 icons zmmailboxdmgr[14339]: assuming no other instance is running
    Apr 15 14:03:55 icons zmmailboxdmgr[14340]: wrote manager pid 14340 to /opt/zimbra/log/zmmailboxd_manager.pid
    Apr 15 14:03:55 icons zmmailboxdmgr[14340]: manager started mailboxd/JVM with pid 14341
    Apr 15 14:03:55 icons zmmailboxdmgr[14341]: wrote java pid 14341 to /opt/zimbra/log/zmmailboxd_java.pid
    Apr 15 14:03:55 icons zimbramon[8649]: 8649:info: Starting snmp via zmcontrol
    Apr 15 14:03:55 icons zimbramon[8649]: 8649:info: Starting spell via zmcontrol
    Apr 15 14:03:55 icons zimbramon[8649]: 8649:info: Starting mta via zmcontrol
    Apr 15 14:04:05 icons zmmailboxdmgr[15677]: status requested
    Apr 15 14:04:05 icons zmmailboxdmgr[15677]: status OK
    Apr 15 14:04:15 icons postfix/postfix-script[16539]: warning: not owned by root: /opt/zimbra/data/postfix/spool
    Apr 15 14:04:15 icons postfix/postfix-script[16546]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/main.cf
    Apr 15 14:04:15 icons postfix/postfix-script[16547]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf
    Apr 15 14:04:15 icons postfix/postfix-script[16548]: warning: not owned by root: /opt/zimbra/postfix-2.6.5.2z/conf/master.cf.in
    Apr 15 14:04:15 icons postfix/postfix-script[16563]: starting the Postfix mail system
    Apr 15 14:04:15 icons postfix/master[16564]: fatal: bind 0.0.0.0 port 25: Address already in use
    Apr 15 14:04:15 icons saslauthd[16570]: detach_tty      : master pid is: 16570
    Apr 15 14:04:15 icons saslauthd[16570]: ipc_init        : listening on socket: /opt/zimbra/cyrus-sasl-2.1.23.3z/state/mux
    Apr 15 14:04:15 icons zimbramon[8649]: 8649:info: Starting stats via zmcontrol
    Apr 15 14:04:30 icons postfix/postqueue[17544]: fatal: Queue report unavailable - mail system is down
    Apr 15 14:04:39 icons zmmailboxdmgr[18084]: status requested
    Apr 15 14:04:39 icons zmmailboxdmgr[18084]: status OK
    Apr 15 14:05:00 icons postfix/postqueue[19172]: fatal: Queue report unavailable - mail system is down
    Apr 15 14:05:05 icons zmmailboxdmgr[19655]: status requested
    Apr 15 14:05:05 icons zmmailboxdmgr[19655]: status OK
    Apr 15 14:05:06 icons zmmailboxdmgr[19792]: status requested
    Apr 15 14:05:06 icons zmmailboxdmgr[19792]: status OK
    Apr 15 14:05:30 icons postfix/postqueue[19843]: fatal: Queue report unavailable - mail system is down

  3. #43
    Join Date
    Oct 2010
    Posts
    22
    Rep Power
    5

    Default

    Quote Originally Posted by godmod View Post
    dammit, must have overlooked this. thank you!

    Code:
    icons:/var/log# netstat -luntp | grep 25
    tcp        0      0 127.0.0.1:25            0.0.0.0:*               LISTEN      3537/exim4
    the process that's listening is exim4. i don't really know it, is is part of zimbra?
    No, it is not part of zimbra, since zimbra use postfix as MTA
    Quote Originally Posted by godmod View Post
    EDIT:

    the history to the whole phenomenon:
    i changed the server domain from one to another. i suspect that that's the cause for all these problems at the beginning i thought about the certificates, but now i am unsure. i would really need some help.

    just killed exim4. must wait unit i finished zimbra backup to start it and look whether it works.

  4. #44
    Join Date
    Oct 2010
    Posts
    22
    Rep Power
    5

    Default

    Quote Originally Posted by godmod View Post
    then i really wonder how that got installed on my server
    hmm, how can i determine if it's save just to remove it?

    i hope so mucht that this is the solution to this whole spooky thing
    How? when you installed the OS, of course, while installing you did not make an empty clear install, surely you install additional packages. Thats all, anything appear from nowhere.

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 06:01 AM
  2. Messages not being delivered
    By buee in forum Administrators
    Replies: 53
    Last Post: 10-23-2009, 10:28 AM
  3. cant send emails/ims
    By christy123 in forum Administrators
    Replies: 2
    Last Post: 09-19-2008, 07:51 PM
  4. [SOLVED] Mailserver down when send file attach of 50Mb
    By ZMilton in forum Administrators
    Replies: 20
    Last Post: 04-10-2008, 11:44 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 03:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •