Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: DNS SERVER WITH ERROR: "Server Can't Find : SERVFAIL"

  1. #11
    Join Date
    Nov 2008
    Location
    Rio de Janeiro - Brazil
    Posts
    34
    Rep Power
    6

    Thumbs down log Files

    File /var/log/syslog

    Apr 2 06:25:09 mail syslogd 1.4.1#18: restart.
    Apr 2 06:43:00 mail -- MARK --
    Apr 2 07:03:00 mail -- MARK --
    Apr 2 07:17:01 mail /USR/SBIN/CRON[6026]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
    Apr 2 07:43:01 mail -- MARK --
    Apr 2 08:03:01 mail -- MARK --
    Apr 2 08:17:01 mail /USR/SBIN/CRON[6040]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
    Apr 2 08:43:01 mail -- MARK --
    Apr 2 08:56:17 mail named[2490]: shutting down: flushing changes
    Apr 2 08:56:17 mail named[2490]: stopping command channel on 127.0.0.1#953
    Apr 2 08:56:17 mail named[2490]: stopping command channel on ::1#953
    Apr 2 08:56:17 mail named[2490]: no longer listening on ::#53
    Apr 2 08:56:17 mail named[2490]: no longer listening on 127.0.0.1#53
    Apr 2 08:56:17 mail named[2490]: no longer listening on 10.0.0.250#53
    Apr 2 08:56:17 mail named[2490]: no longer listening on 200.11.20.111#53
    Apr 2 08:56:17 mail named[2490]: exiting
    Apr 2 08:56:19 mail named[6082]: starting BIND 9.3.4-P1.1 -u bind
    Apr 2 08:56:19 mail named[6082]: found 1 CPU, using 1 worker thread
    Apr 2 08:56:19 mail named[6082]: loading configuration from '/etc/bind/named.conf'
    Apr 2 08:56:19 mail named[6082]: listening on IPv6 interfaces, port 53
    Apr 2 08:56:19 mail named[6082]: listening on IPv4 interface lo, 127.0.0.1#53
    Apr 2 08:56:19 mail named[6082]: listening on IPv4 interface eth1, 10.0.0.250#53
    Apr 2 08:56:19 mail named[6082]: listening on IPv4 interface eth0, 200.11.20.111#53
    Apr 2 08:56:19 mail named[6082]: command channel listening on 127.0.0.1#953
    Apr 2 08:56:19 mail named[6082]: command channel listening on ::1#953
    Apr 2 08:56:19 mail named[6082]: zone 0.in-addr.arpa/IN: loaded serial 1
    Apr 2 08:56:19 mail named[6082]: zone 127.in-addr.arpa/IN: loaded serial 1
    Apr 2 08:56:19 mail named[6082]: /etc/bind/db.111.20.11.200:4: no current owner name
    Apr 2 08:56:19 mail named[6082]: zone 111.20.11.200.in-addr.arpa/IN: loading master file /etc/bind/db.111.20.11.200: no owner
    Apr 2 08:56:19 mail named[6082]: zone 255.in-addr.arpa/IN: loaded serial 1
    Apr 2 08:56:19 mail named[6082]: /etc/bind/db.hotelpart.com:4: no current owner name
    Apr 2 08:56:19 mail named[6082]: zone hotelpart.com/IN: loading master file /etc/bind/db.hotelpart.com: no owner
    Apr 2 08:56:19 mail named[6082]: zone localhost/IN: loaded serial 1
    Apr 2 08:56:19 mail named[6082]: running
    Apr 2 09:17:01 mail /USR/SBIN/CRON[6096]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
    Apr 2 09:43:02 mail -- MARK --
    Apr 2 10:03:02 mail -- MARK --
    Apr 2 10:11:49 mail named[6082]: lame server resolving 'www.estadosp.com.br' (in 'estadosp.com.br'?): 72.233.50.75#53
    Apr 2 10:11:49 mail named[6082]: lame server resolving 'www.estadosp.com.br' (in 'estadosp.com.br'?): 72.233.50.76#53
    Apr 2 10:17:01 mail /USR/SBIN/CRON[6133]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
    Apr 2 10:43:03 mail -- MARK --
    Apr 2 11:03:03 mail -- MARK --

  2. #12
    Join Date
    Nov 2008
    Location
    Rio de Janeiro - Brazil
    Posts
    34
    Rep Power
    6

    Default

    I managed to solve one problem, now tell me if this is normal????

    mail:~# nslookup mail.hotelpart.com
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    Name: mail.hotelpart.com
    Address: 200.11.20.111

    mail:~# nslookup 200.11.20.111
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    ** server can't find 111.20.11.200.in-addr.arpa: SERVFAIL

    I still have something wrong with my DNS!!!

    I hope I can count on your help!!!

  3. #13
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    To verify your DNS behind a NAT router you should use the commands given earlier:
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig hotelpart.com mx
    dig hotelpart.com any
    host `hostname` <- note backticks and not single quotes
    and you should not see your public IP address in any of the results nor should the results for your LAN IP be the 127.0.0.1 address.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    Join Date
    Nov 2008
    Location
    Rio de Janeiro - Brazil
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    To verify your DNS behind a NAT router you should use the commands given earlier:
    Code:
    cat /etc/hosts
    cat /etc/resolv.conf
    dig hotelpart.com mx
    dig hotelpart.com any
    host `hostname` <- note backticks and not single quotes
    and you should not see your public IP address in any of the results nor should the results for your LAN IP be the 127.0.0.1 address.

    mail:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    200.11.20.111 mail.hotelpart.com mail

    # The following lines are desirable for IPv6 capable hosts
    ::1 ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    ff02::3 ip6-allhosts

    --------------------------------------------------------------------

    mail:~# cat /etc/resolv.conf
    domain hotelpart.com
    search hotelpart.com
    nameserver 127.0.0.1
    nameserver 10.0.0.1
    nameserver 200.222.0.34
    nameserver 200.222.0.35

    ---------------------------------------------------------------------

    mail:~# dig hotelpart.com mx

    ; <<>> DiG 9.3.4-P1.1 <<>> hotelpart.com mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 31821
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hotelpart.com. IN MX

    ;; ANSWER SECTION:
    hotelpart.com. 86400 IN MX 5 mail.hotelpart.com.

    ;; AUTHORITY SECTION:
    hotelpart.com. 86400 IN NS mail.hotelpart.com.

    ;; ADDITIONAL SECTION:
    mail.hotelpart.com. 86400 IN A 200.11.20.111

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Apr 3 10:00:05 2009
    ;; MSG SIZE rcvd: 85

    -------------------------------------------------------------------

    mail:~# dig hotelpart.com any

    ; <<>> DiG 9.3.4-P1.1 <<>> hotelpart.com any
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 24635
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 3, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;hotelpart.com. IN ANY

    ;; ANSWER SECTION:
    hotelpart.com. 86400 IN SOA mail.hotelpart.com. root.hotelpart.com. 1 3600 86400 2419200 3600
    hotelpart.com. 86400 IN NS mail.hotelpart.com.
    hotelpart.com. 86400 IN MX 5 mail.hotelpart.com.

    ;; ADDITIONAL SECTION:
    mail.hotelpart.com. 86400 IN A 200.11.20.111

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Apr 3 10:03:19 2009
    ;; MSG SIZE rcvd: 126

    -------------------------------------------------------------------

    mail:~# host `hostname`
    mail.hotelpart.com has address 200.11.20.111

    Thanks

  5. #15
    Join Date
    Nov 2008
    Location
    Rio de Janeiro - Brazil
    Posts
    34
    Rep Power
    6

    Default

    I'm still having problems someone could help me?????

    mail:~# nslookup 200.11.20.111
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    ** server can't find 111.20.11.200.in-addr.arpa: NXDOMAIN


  6. #16
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by jcvalim View Post
    I'm still having problems someone could help me?????

    mail:~# nslookup 200.11.20.111
    Server: 127.0.0.1
    Address: 127.0.0.1#53

    ** server can't find 111.20.11.200.in-addr.arpa: NXDOMAIN

    From that output your server would appear to have no Reverse DNS, you need to contact your ISP and get it fixed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #17
    Join Date
    Nov 2008
    Location
    Rio de Janeiro - Brazil
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    From that output your server would appear to have no Reverse DNS, you need to contact your ISP and get it fixed.
    what is it that ISP????

  8. #18
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    Quote Originally Posted by jcvalim View Post
    what is it that ISP????
    Your Internet Service Provider i.e. the company that provides your network connection.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #19
    Join Date
    Nov 2008
    Location
    Rio de Janeiro - Brazil
    Posts
    34
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    Your Internet Service Provider i.e. the company that provides your network connection.
    but what should I ask for them???

    The problem seems to be setting my server....

  10. #20
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,587
    Rep Power
    58

    Default

    I've already told you, a reverse DNS. This is not a Zimbra problem, speak to your ISP.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Similar Threads

  1. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  2. [SOLVED] Multi Server - DNS - Imapproxy
    By innercy in forum Installation
    Replies: 1
    Last Post: 12-29-2007, 09:21 PM
  3. Please help
    By scott_summers in forum Administrators
    Replies: 0
    Last Post: 09-26-2007, 11:11 PM
  4. Replies: 3
    Last Post: 06-07-2007, 07:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •