Results 1 to 6 of 6

Thread: [SOLVED] Question on domains

  1. #1
    Join Date
    Sep 2008
    Posts
    8
    Rep Power
    7

    Default [SOLVED] Question on domains

    Hey Everyone,

    I have zimbra installed, and I'm working on getting it setup proper. My question comes from the use of domains, and the proper way to implement it.

    Here's our setup.

    1.) Mail comes and goes to our mail relays
    2.) Our relays contain an alias for all users, that send it to our spam hardware

    user: user@spamHardware.X.example.com

    3.) Our spam hardware does it's thing, and forwards all mail to our linux email server.

    user@email.X.example.com

    So my questions come in as this.

    If our domain is example.com and we want all email to go out and come in as that, what do I do?

    Our email comes into the server with an alias of sorts, as user@email.X.example.com. Do I need 2 domains and setup aliases for everyone so they can be user@example.com but have email come in as user@email.X.example.com?

    Thanks for any insight.

    Charlie

  2. #2
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    11

    Default

    you should read this link
    Managing Domains - Zimbra :: Wiki

    example which will work for you is:

    zmprov cd email.X.example.com zimbraDomainType alias
    zmprov md email.X.example.com zimbraMailCatchAllAddress @email.X.example.com zimbraMailCatchAllForwardingAddress @example.com

    This will forward user@email.X.example.com -> user@example.com


    * but the way you are realying email its really unique..not sure why usernames are getting changed and why you should do that at all.

    Raj
    i2k2 Networks
    Dedicated & Shared Zimbra Hosting Provider

  3. #3
    Join Date
    Sep 2008
    Posts
    8
    Rep Power
    7

    Default

    Yea, I'm not sure why we do that either, this is how it was when I got here. One of these days I'll figure it out.

    Thanks for the read, it appears to be what I was looking for.

  4. #4
    Join Date
    Sep 2008
    Posts
    8
    Rep Power
    7

    Default

    I should also note, that we relay for couple reasons.

    1.) Not all email should be pushed to our spam hardware
    2.) Adds additional layer of security for our email server
    3.) We are a small company and can get away with it

    I do agree there should be a better way.

    And as for the email getting changed...

    The email comes to the zimbra server as user@email.X.example.com. But the message itself was sent and shows up as example.com. My headache was getting zimbra to accept the mail as the longer fqdn.

  5. #5
    Join Date
    Sep 2008
    Posts
    8
    Rep Power
    7

    Default

    Thanks so much, this worked perfectly.

  6. #6
    Join Date
    Sep 2009
    Location
    Portland, Oregon USA
    Posts
    30
    Rep Power
    6

    Default

    Hi Raj! I hope you're still around. I have the same problem as the OP but in reverse. Total noob with Zimbra (one day) so not at all comfortable working under the hood yet.

    Plan to roll everything over to Zimbra if all goes well but right now we're in evaluation mode. So far so good.

    I am forwarding some depreciated e-mail to Zimbra and want Zimbra to send out an auto-reply. This seems to work ok for mail addressed specifically for the test MX FQDN that Zimbra is on. But if mail to user@foo.com (our production domain) is forwarded to user@test.foo.com (the Zimbra server), no auto reply is generated. The mail is correctly delivered to user@test.foo.com though.

    It would REALLY help our roll-out if there is a fix for this,

    TIA!

Similar Threads

  1. [SOLVED] 1 single GAL for 2 domains
    By CatiaL in forum Administrators
    Replies: 11
    Last Post: 04-27-2009, 11:29 AM
  2. [SOLVED] unable to send mail to external domains
    By gtdaqua in forum Administrators
    Replies: 8
    Last Post: 01-08-2008, 04:41 AM
  3. [SOLVED] Mulitple domains
    By leog21 in forum Installation
    Replies: 1
    Last Post: 10-17-2007, 11:33 AM
  4. Multiple Domains Question
    By kristiaan_d in forum Administrators
    Replies: 2
    Last Post: 03-14-2007, 05:38 AM
  5. Quick question on adding domains
    By agnOstos in forum Installation
    Replies: 2
    Last Post: 10-12-2005, 12:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •